summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-07-03 19:48:28 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-07-03 19:48:28 +0000
commit6044bbbbc60cffed8c5472a0cb6f2e70c2a2cd1d (patch)
tree9a00916dd683a77ea670566efbd2f028e29ca533 /packages/linux
parent2a5fdf6434cc0bee885bf52bdf5f600e33421e39 (diff)
parent2f711c565e08b3ae9553226a80456d259e5a12bb (diff)
merge of '290305d126092679b5d9b8f4f299b6dce4dd8da6'
and 'dac58e411440987135799adb8235fe46a6d6e1c7'
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-x86_2.6.20.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/packages/linux/linux-x86_2.6.20.bb b/packages/linux/linux-x86_2.6.20.bb
index ec79c94bc4..cfc8af6f21 100644
--- a/packages/linux/linux-x86_2.6.20.bb
+++ b/packages/linux/linux-x86_2.6.20.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Linux Kernel for x86 compatible machines"
SECTION = "kernel"
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 "
@@ -29,3 +29,12 @@ do_configure_prepend_i686() {
install -m 0644 ${WORKDIR}/i686-defconfig ${S}/.config
}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 arch/i386/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_populate_staging after do_compile