summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2006-01-15 05:45:44 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-15 05:45:44 +0000
commit47cde1bfb6658f5464862c4cf362fac5f5e90cda (patch)
tree5a4aa2f1592da8cac7cabd1d13950aed58cb403e /packages/linux
parent42985047a476cf2ba4e4a27cdc5a4f7ee2756e19 (diff)
parentbbf67faea13558e9ad23b6faca2c0745630f8939 (diff)
merge of 87e4f0da031411c350745ff1cd9325a82c7c3cb9
and e08e5d284b9c3633dc77b46afcf0f14fd5cab232
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/ixp4xx-kernel.inc2
-rw-r--r--packages/linux/ixp4xx-kernel/2.6.15/defconfig9
-rw-r--r--packages/linux/ixp4xx-kernel_2.6.15.bb4
-rw-r--r--packages/linux/linux-openzaurus.inc5
4 files changed, 11 insertions, 9 deletions
diff --git a/packages/linux/ixp4xx-kernel.inc b/packages/linux/ixp4xx-kernel.inc
index 233d2a655c..452c8c956b 100644
--- a/packages/linux/ixp4xx-kernel.inc
+++ b/packages/linux/ixp4xx-kernel.inc
@@ -196,7 +196,7 @@ CMDLINE_KERNEL_OPTIONS ?= "${MACH_KERNEL_OPTIONS}"
# CMDLINE_ROOT: machine specific boot options - should not be set on a
# generic kernel!
-CMDLINE_ROOT ?= "init=/linuxrc"
+CMDLINE_ROOT ?= ""
# CMDLINE_DEBUG: debug options such as noirqdebug, defaults to empty
# override in local.conf etc
diff --git a/packages/linux/ixp4xx-kernel/2.6.15/defconfig b/packages/linux/ixp4xx-kernel/2.6.15/defconfig
index c05034de19..1643ab8b43 100644
--- a/packages/linux/ixp4xx-kernel/2.6.15/defconfig
+++ b/packages/linux/ixp4xx-kernel/2.6.15/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.15
-# Thu Jan 12 17:44:50 2006
+# Fri Jan 13 23:40:57 2006
#
CONFIG_ARM=y
CONFIG_MMU=y
@@ -112,12 +112,13 @@ CONFIG_ARCH_SUPPORTS_BIG_ENDIAN=y
# IXP4xx Platforms
#
CONFIG_MACH_NSLU2=y
-# CONFIG_ARCH_AVILA is not set
+CONFIG_ARCH_AVILA=y
CONFIG_MACH_LOFT=y
# CONFIG_ARCH_ADI_COYOTE is not set
-# CONFIG_ARCH_IXDP425 is not set
+CONFIG_ARCH_IXDP425=y
# CONFIG_MACH_IXDPG425 is not set
# CONFIG_MACH_IXDP465 is not set
+CONFIG_ARCH_IXCDP1100=y
# CONFIG_ARCH_PRPMC1100 is not set
CONFIG_MACH_NAS100D=y
CONFIG_ARCH_IXDP4XX=y
@@ -1362,7 +1363,7 @@ CONFIG_RTC_INTF_DEV=y
# RTC drivers
#
CONFIG_RTC_DRV_X1205=y
-# CONFIG_RTC_DRV_DS1672 is not set
+CONFIG_RTC_DRV_DS1672=y
# CONFIG_RTC_DRV_TEST is not set
#
diff --git a/packages/linux/ixp4xx-kernel_2.6.15.bb b/packages/linux/ixp4xx-kernel_2.6.15.bb
index 4a7cd96d37..6da130772c 100644
--- a/packages/linux/ixp4xx-kernel_2.6.15.bb
+++ b/packages/linux/ixp4xx-kernel_2.6.15.bb
@@ -3,12 +3,12 @@
# Increment PR_CONFIG for changes to the ixp4xx-kernel specific
# defconfig (do *NOT* increment anything in here for changes
# to other kernel configs!)
-PR_CONFIG = "0"
+PR_CONFIG = "1"
#
# Increment the number below (i.e. the digits after PR) when
# making changes within this file or for changes to the patches
# applied to the kernel.
-PR = "r4.${PR_CONFIG}"
+PR = "r5.${PR_CONFIG}"
include ixp4xx-kernel.inc
diff --git a/packages/linux/linux-openzaurus.inc b/packages/linux/linux-openzaurus.inc
index 7b7a6e72f2..2fc6f58007 100644
--- a/packages/linux/linux-openzaurus.inc
+++ b/packages/linux/linux-openzaurus.inc
@@ -25,7 +25,8 @@ CMDLINE_CON = "console=ttyS0,115200n8 console=tty1 noinitrd"
CMDLINE_ROOT = "root=/dev/mtdblock2 rootfstype=jffs2"
CMDLINE_ROOT_spitz = "root=/dev/hda1 rootfstype=ext3 rw"
CMDLINE_ROOT_borzoi = "root=/dev/hda1 rootfstype=ext3 rw"
-CMDLINE_OTHER = "dyntick=enable debug"
+CMDLINE_OTHER = "dyntick=enable"
+CMDLINE_DEBUG = '${@base_conditional("DISTRO_TYPE", "release", "quiet", "debug",d)}'
##############################################################
# Configure memory/ramdisk split for collie
@@ -37,7 +38,7 @@ CMDLINE_MEM_collie = "mem=${mem}M"
CMDLINE_ROTATE_spitz = "fbcon=rotate:1"
CMDLINE_ROTATE_akita = "fbcon=rotate:1"
CMDLINE_ROTATE_borzoi = "fbcon=rotate:1"
-CMDLINE = "${CMDLINE_CON} ${CMDLINE_ROOT} ${CMDLINE_MEM} ${CMDLINE_ROTATE} ${CMDLINE_OTHER}"
+CMDLINE = "${CMDLINE_CON} ${CMDLINE_ROOT} ${CMDLINE_MEM} ${CMDLINE_ROTATE} ${CMDLINE_OTHER} ${CMDLINE_DEBUG}"
###############################################################
# Enable or disable ELPP via local.conf - default is "no"