summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-06-13 09:40:53 +0000
committerKoen Kooi <koen@openembedded.org>2007-06-13 09:40:53 +0000
commit23c20b0182b031338d5e89b226ebb1ae869f432a (patch)
treed6e119e479b0640cd1719c41a2746956b9b5a942 /packages/linux
parentdf6f7f3624879b030ed9f1d47f1d71bccde1de84 (diff)
linux 2.6.20, 2.6.21, 2.6.21+2.6.22-rc1: fix install for uImage
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux_2.6.20.bb6
-rw-r--r--packages/linux/linux_2.6.21+2.6.22-rc1.bb5
-rw-r--r--packages/linux/linux_2.6.21.bb6
3 files changed, 17 insertions, 0 deletions
diff --git a/packages/linux/linux_2.6.20.bb b/packages/linux/linux_2.6.20.bb
index 91388a2f95..76a90006d0 100644
--- a/packages/linux/linux_2.6.20.bb
+++ b/packages/linux/linux_2.6.20.bb
@@ -43,6 +43,12 @@ do_configure_prepend() {
yes '' | oe_runmake oldconfig
}
+do_install_prepend() {
+ if test -e arch/${ARCH}/boot/Image ; then
+ ln -f arch/arm/boot/Image arch/arm/boot/uImage
+ fi
+}
+
do_install_append_n2100() {
install -d ${DEPLOY_DIR_IMAGE}
install -m 0644 ${S}/arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
diff --git a/packages/linux/linux_2.6.21+2.6.22-rc1.bb b/packages/linux/linux_2.6.21+2.6.22-rc1.bb
index 2773280da2..b127d33f24 100644
--- a/packages/linux/linux_2.6.21+2.6.22-rc1.bb
+++ b/packages/linux/linux_2.6.21+2.6.22-rc1.bb
@@ -59,3 +59,8 @@ do_configure_prepend() {
yes '' | oe_runmake oldconfig
}
+do_install_prepend() {
+ if test -e arch/${ARCH}/boot/Image ; then
+ ln -f arch/arm/boot/Image arch/arm/boot/uImage
+ fi
+}
diff --git a/packages/linux/linux_2.6.21.bb b/packages/linux/linux_2.6.21.bb
index d823b4d625..34dd5355e0 100644
--- a/packages/linux/linux_2.6.21.bb
+++ b/packages/linux/linux_2.6.21.bb
@@ -51,3 +51,9 @@ do_configure_prepend() {
yes '' | oe_runmake oldconfig
}
+do_install_prepend() {
+ if test -e arch/${ARCH}/boot/Image ; then
+ ln -f arch/arm/boot/Image arch/arm/boot/uImage
+ fi
+}
+