summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-05-17 09:57:41 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-17 09:57:41 +0000
commit0091cc5ff3569a41be98a47ec9e6395767607c68 (patch)
treed92e4d9106da257d3a205f967ee24fbd6605c0c3 /packages/linux
parent2377ba188fe480437374953241753df9cc0eb51d (diff)
linux-openzaurus: sync with last changes in .oz354x
- enabled logo for c7x0, akita, spitz, tosa, poodle - collie does not get logo as its kernel need booting config first - logo was created by Sebastian 'xaos' Rosik - PNG and SVG versions: http://openzaurus.org/gfx-contest/xaos/ - kernel logo was made from logo01.svg (inversed colors) - also added one CF memory card to pcmcia ids - Ecco@#openzaurus - added hostap patch (2 new ids) - sent upstream - dropped 24-hostap_cs_id patch
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-openzaurus-2.6.16/00-hostap.patch45
-rw-r--r--packages/linux/linux-openzaurus-2.6.16/24-hostap_cs_id.diff107
-rw-r--r--packages/linux/linux-openzaurus-2.6.16/defconfig-akita5
-rw-r--r--packages/linux/linux-openzaurus-2.6.16/defconfig-c7x05
-rw-r--r--packages/linux/linux-openzaurus-2.6.16/defconfig-poodle5
-rw-r--r--packages/linux/linux-openzaurus-2.6.16/defconfig-spitz5
-rw-r--r--packages/linux/linux-openzaurus-2.6.16/defconfig-tosa5
-rw-r--r--packages/linux/linux-openzaurus-2.6.16/hrw-pcmcia-ids-r2.patch9
-rw-r--r--packages/linux/linux-openzaurus_2.6.16.bb17
9 files changed, 85 insertions, 118 deletions
diff --git a/packages/linux/linux-openzaurus-2.6.16/00-hostap.patch b/packages/linux/linux-openzaurus-2.6.16/00-hostap.patch
new file mode 100644
index 0000000000..20432b404a
--- /dev/null
+++ b/packages/linux/linux-openzaurus-2.6.16/00-hostap.patch
@@ -0,0 +1,45 @@
+Platform: Sharp Zaurus C760 running 2.6.16 and pcmciautils 013.
+
+root@c7x0:~# pccardctl ident
+Socket 0:
+ product info: "Pretec", "CompactWLAN Card 802.11b", "2.5"
+ manfid: 0x0156, 0x0002
+ function: 6 (network)
+
+==========================================================================
+From: Jochen Friedrich
+
+Yet another card known to work OK with hostap_cs:
+
+# pccardctl ident
+Socket 0:
+ no product info available
+Socket 1:
+ product info: "U.S. Robotics", "IEEE 802.11b PC-CARD", "Version 01.02", ""
+ manfid: 0x0156, 0x0002
+ function: 6 (network)
+
+==========================================================================
+
+Signed-off-by: Marcin Juszkiewicz <openembedded@hrw.one.pl>
+
+ drivers/net/wireless/hostap/hostap_cs.c | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+Index: linux/drivers/net/wireless/hostap/hostap_cs.c
+===================================================================
+--- linux.orig/drivers/net/wireless/hostap/hostap_cs.c 2006-05-17 10:23:00.000000000 +0200
++++ linux/drivers/net/wireless/hostap/hostap_cs.c 2006-05-17 10:25:45.000000000 +0200
+@@ -923,6 +923,12 @@
+ PCMCIA_DEVICE_PROD_ID12(
+ "ZoomAir 11Mbps High", "Rate wireless Networking",
+ 0x273fe3db, 0x32a1eaee),
++ PCMCIA_DEVICE_PROD_ID123(
++ "Pretec", "CompactWLAN Card 802.11b", "2.5",
++ 0x1cadd3e5, 0xe697636c, 0x7a5bfcf1),
++ PCMCIA_DEVICE_PROD_ID123(
++ "U.S. Robotics", "IEEE 802.11b PC-CARD", "Version 01.02",
++ 0xc7b8df9d, 0x1700d087, 0x4b74baa0),
+ PCMCIA_DEVICE_NULL
+ };
+ MODULE_DEVICE_TABLE(pcmcia, hostap_cs_ids);
diff --git a/packages/linux/linux-openzaurus-2.6.16/24-hostap_cs_id.diff b/packages/linux/linux-openzaurus-2.6.16/24-hostap_cs_id.diff
deleted file mode 100644
index b90ead9e4f..0000000000
--- a/packages/linux/linux-openzaurus-2.6.16/24-hostap_cs_id.diff
+++ /dev/null
@@ -1,107 +0,0 @@
-Add more IDs for PCMCIA cards
-
-From: Pavel Roskin <proski@gnu.org>
-
-Add string IDs for cards that were covered by 0x0156,0x0002, which is no
-longer used in hostap_cs due to conflict with Orinoco cards.
-
-Also add more IDs for cards that are supported by linux-wlan-ng. Thanks
-to Arnold Schulz <arnysch@gmx.net> for providing the list.
-
-Signed-off-by: Pavel Roskin <proski@gnu.org>
----
-
- drivers/net/wireless/hostap/hostap_cs.c | 46 +++++++++++++++++++++++++++++++
- 1 files changed, 46 insertions(+), 0 deletions(-)
-
-diff --git a/drivers/net/wireless/hostap/hostap_cs.c b/drivers/net/wireless/hostap/hostap_cs.c
-index 55bed92..9ac1aec 100644
---- a/drivers/net/wireless/hostap/hostap_cs.c
-+++ b/drivers/net/wireless/hostap/hostap_cs.c
-@@ -832,9 +832,11 @@ static int hostap_cs_resume(struct pcmci
- static struct pcmcia_device_id hostap_cs_ids[] = {
- PCMCIA_DEVICE_MANF_CARD(0x000b, 0x7100),
- PCMCIA_DEVICE_MANF_CARD(0x000b, 0x7300),
-+ PCMCIA_DEVICE_MANF_CARD(0x0089, 0x0002),
- PCMCIA_DEVICE_MANF_CARD(0x0101, 0x0777),
- PCMCIA_DEVICE_MANF_CARD(0x0126, 0x8000),
- PCMCIA_DEVICE_MANF_CARD(0x0138, 0x0002),
-+ PCMCIA_DEVICE_MANF_CARD(0x01ff, 0x0008),
- PCMCIA_DEVICE_MANF_CARD(0x0250, 0x0002),
- PCMCIA_DEVICE_MANF_CARD(0x026f, 0x030b),
- PCMCIA_DEVICE_MANF_CARD(0x0274, 0x1612),
-@@ -844,7 +846,10 @@ static struct pcmcia_device_id hostap_cs
- PCMCIA_DEVICE_MANF_CARD(0x02d2, 0x0001),
- PCMCIA_DEVICE_MANF_CARD(0x50c2, 0x0001),
- PCMCIA_DEVICE_MANF_CARD(0x50c2, 0x7300),
-+ PCMCIA_DEVICE_MANF_CARD(0x9005, 0x0021),
-+ PCMCIA_DEVICE_MANF_CARD(0xc001, 0x0008),
- PCMCIA_DEVICE_MANF_CARD(0xc00f, 0x0000),
-+ PCMCIA_DEVICE_MANF_CARD(0xc250, 0x0002),
- PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0002),
- PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0005),
- PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0010),
-@@ -862,22 +867,63 @@ static struct pcmcia_device_id hostap_cs
- "Addtron", "AWP-100 Wireless PCMCIA", "Version 01.02",
- 0xe6ec52ce, 0x08649af2, 0x4b74baa0),
- PCMCIA_DEVICE_PROD_ID123(
-+ "Belkin", "11Mbps Wireless Notebook Network Adapter",
-+ "Version 01.02", 0x3805a391, 0xad4c7744, 0x4b74baa0),
-+ PCMCIA_DEVICE_PROD_ID123(
- "D", "Link DWL-650 11Mbps WLAN Card", "Version 01.02",
- 0x71b18589, 0xb6f1b0ab, 0x4b74baa0),
- PCMCIA_DEVICE_PROD_ID123(
- "Instant Wireless ", " Network PC CARD", "Version 01.02",
- 0x11d901af, 0x6e9bd926, 0x4b74baa0),
- PCMCIA_DEVICE_PROD_ID123(
-+ "Intersil", "PRISM Freedom PCMCIA Adapter", "ISL37100P",
-+ 0x4b801a17, 0xf222ec2d, 0x630d52b2),
-+ PCMCIA_DEVICE_PROD_ID123(
-+ "OEM", "PRISM2 IEEE 802.11 PC-Card", "Version 01.02",
-+ 0xfea54c90, 0x48f2bdd6, 0x4b74baa0),
-+ PCMCIA_DEVICE_PROD_ID123(
-+ "Pretec", "CompactWLAN Card 802.11b", "2.5",
-+ 0x1cadd3e5, 0xe697636c, 0x7a5bfcf1),
-+ PCMCIA_DEVICE_PROD_ID123(
- "SMC", "SMC2632W", "Version 01.02",
- 0xc4f8b18b, 0x474a1f2a, 0x4b74baa0),
-+ PCMCIA_DEVICE_PROD_ID123(
-+ "The Linksys Group, Inc.", "Instant Wireless Network PC Card",
-+ "ISL37300P", 0xa5f472c2, 0x590eb502, 0xc9049a39),
-+ PCMCIA_DEVICE_PROD_ID123(
-+ "U.S. Robotics", "IEEE 802.11b PC-CARD", "Version 01.02",
-+ 0xc7b8df9d, 0x1700d087, 0x4b74baa0),
-+ PCMCIA_DEVICE_PROD_ID12("ASUS", "802_11b_PC_CARD_25",
-+ 0x78fc06ee, 0xdb9aa842),
-+ PCMCIA_DEVICE_PROD_ID12("ASUS", "802_11B_CF_CARD_25",
-+ 0x78fc06ee, 0x45a50c1e),
- PCMCIA_DEVICE_PROD_ID12("BUFFALO", "WLI-CF-S11G",
- 0x2decece3, 0x82067c18),
- PCMCIA_DEVICE_PROD_ID12("Compaq", "WL200_11Mbps_Wireless_PCI_Card",
- 0x54f7c49c, 0x15a75e5b),
-+ PCMCIA_DEVICE_PROD_ID12("corega K.K.", "Wireless LAN PCC-11",
-+ 0x5261440f, 0xa6405584),
-+ PCMCIA_DEVICE_PROD_ID12("corega K.K.", "Wireless LAN PCCA-11",
-+ 0x5261440f, 0xdf6115f9),
-+ PCMCIA_DEVICE_PROD_ID12("D", "Link DRC-650 11Mbps WLAN Card",
-+ 0x71b18589, 0xf144e3ac),
-+ PCMCIA_DEVICE_PROD_ID12("Digital Data Communications", "WPC-0100",
-+ 0xfdd73470, 0xe0b6f146),
- PCMCIA_DEVICE_PROD_ID12("INTERSIL", "HFA384x/IEEE",
- 0x74c5e40d, 0xdb472a18),
-+ PCMCIA_DEVICE_PROD_ID12("LeArtery",
-+ "SYNCBYAIR 11Mbps Wireless LAN PC Card",
-+ 0x7e3b326a, 0x49893e92),
- PCMCIA_DEVICE_PROD_ID12("Linksys", "Wireless CompactFlash Card",
- 0x0733cc81, 0x0c52f395),
-+ PCMCIA_DEVICE_PROD_ID12("NETGEAR MA401 Wireless PC", "Card",
-+ 0xa37434e9, 0x9762e8f1),
-+ PCMCIA_DEVICE_PROD_ID12("OTC", "Wireless AirEZY 2411-PCC WLAN Card",
-+ 0x4ac44287, 0x235a6bed),
-+ PCMCIA_DEVICE_PROD_ID12("PLANEX", "GeoWave/GW-CF110",
-+ 0x209f40ab, 0xd9715264),
-+ PCMCIA_DEVICE_PROD_ID12("PLANEX", "GeoWave/GW-NS110",
-+ 0x209f40ab, 0x46263178),
- PCMCIA_DEVICE_PROD_ID12(
- "ZoomAir 11Mbps High", "Rate wireless Networking",
- 0x273fe3db, 0x32a1eaee),
diff --git a/packages/linux/linux-openzaurus-2.6.16/defconfig-akita b/packages/linux/linux-openzaurus-2.6.16/defconfig-akita
index d91cde2bd8..c46cab31b2 100644
--- a/packages/linux/linux-openzaurus-2.6.16/defconfig-akita
+++ b/packages/linux/linux-openzaurus-2.6.16/defconfig-akita
@@ -957,7 +957,10 @@ CONFIG_FONT_8x16=y
#
# Logo configuration
#
-# CONFIG_LOGO is not set
+CONFIG_LOGO=y
+# CONFIG_LOGO_LINUX_MONO is not set
+# CONFIG_LOGO_LINUX_VGA16 is not set
+CONFIG_LOGO_LINUX_CLUT224=y
CONFIG_BACKLIGHT_LCD_SUPPORT=y
CONFIG_BACKLIGHT_CLASS_DEVICE=y
CONFIG_BACKLIGHT_DEVICE=y
diff --git a/packages/linux/linux-openzaurus-2.6.16/defconfig-c7x0 b/packages/linux/linux-openzaurus-2.6.16/defconfig-c7x0
index 694a0d5793..522c793033 100644
--- a/packages/linux/linux-openzaurus-2.6.16/defconfig-c7x0
+++ b/packages/linux/linux-openzaurus-2.6.16/defconfig-c7x0
@@ -991,7 +991,10 @@ CONFIG_FONT_8x16=y
#
# Logo configuration
#
-# CONFIG_LOGO is not set
+CONFIG_LOGO=y
+# CONFIG_LOGO_LINUX_MONO is not set
+# CONFIG_LOGO_LINUX_VGA16 is not set
+CONFIG_LOGO_LINUX_CLUT224=y
CONFIG_BACKLIGHT_LCD_SUPPORT=y
CONFIG_BACKLIGHT_CLASS_DEVICE=y
CONFIG_BACKLIGHT_DEVICE=y
diff --git a/packages/linux/linux-openzaurus-2.6.16/defconfig-poodle b/packages/linux/linux-openzaurus-2.6.16/defconfig-poodle
index bd2b8ef2c2..f02694d67f 100644
--- a/packages/linux/linux-openzaurus-2.6.16/defconfig-poodle
+++ b/packages/linux/linux-openzaurus-2.6.16/defconfig-poodle
@@ -1037,7 +1037,10 @@ CONFIG_FONT_MINI_4x6=y
#
# Logo configuration
#
-# CONFIG_LOGO is not set
+CONFIG_LOGO=y
+# CONFIG_LOGO_LINUX_MONO is not set
+# CONFIG_LOGO_LINUX_VGA16 is not set
+CONFIG_LOGO_LINUX_CLUT224=y
CONFIG_BACKLIGHT_LCD_SUPPORT=y
CONFIG_BACKLIGHT_CLASS_DEVICE=y
CONFIG_BACKLIGHT_DEVICE=y
diff --git a/packages/linux/linux-openzaurus-2.6.16/defconfig-spitz b/packages/linux/linux-openzaurus-2.6.16/defconfig-spitz
index f542435c47..33eae4385e 100644
--- a/packages/linux/linux-openzaurus-2.6.16/defconfig-spitz
+++ b/packages/linux/linux-openzaurus-2.6.16/defconfig-spitz
@@ -957,7 +957,10 @@ CONFIG_FONT_8x16=y
#
# Logo configuration
#
-# CONFIG_LOGO is not set
+CONFIG_LOGO=y
+# CONFIG_LOGO_LINUX_MONO is not set
+# CONFIG_LOGO_LINUX_VGA16 is not set
+CONFIG_LOGO_LINUX_CLUT224=y
CONFIG_BACKLIGHT_LCD_SUPPORT=y
CONFIG_BACKLIGHT_CLASS_DEVICE=y
CONFIG_BACKLIGHT_DEVICE=y
diff --git a/packages/linux/linux-openzaurus-2.6.16/defconfig-tosa b/packages/linux/linux-openzaurus-2.6.16/defconfig-tosa
index ed4cfd8cb3..a757139661 100644
--- a/packages/linux/linux-openzaurus-2.6.16/defconfig-tosa
+++ b/packages/linux/linux-openzaurus-2.6.16/defconfig-tosa
@@ -991,7 +991,10 @@ CONFIG_FONT_8x8=y
#
# Logo configuration
#
-# CONFIG_LOGO is not set
+CONFIG_LOGO=y
+# CONFIG_LOGO_LINUX_MONO is not set
+# CONFIG_LOGO_LINUX_VGA16 is not set
+CONFIG_LOGO_LINUX_CLUT224=y
CONFIG_BACKLIGHT_LCD_SUPPORT=y
CONFIG_BACKLIGHT_CLASS_DEVICE=y
CONFIG_BACKLIGHT_DEVICE=y
diff --git a/packages/linux/linux-openzaurus-2.6.16/hrw-pcmcia-ids-r2.patch b/packages/linux/linux-openzaurus-2.6.16/hrw-pcmcia-ids-r2.patch
index 3d5d197920..6f77d51dee 100644
--- a/packages/linux/linux-openzaurus-2.6.16/hrw-pcmcia-ids-r2.patch
+++ b/packages/linux/linux-openzaurus-2.6.16/hrw-pcmcia-ids-r2.patch
@@ -4,6 +4,12 @@ The ident for Seagate 8GB microdrive is
hash 0x76dc4190, 0xcfba9599
manfid 0x0111, 0x0000
+CF card:
+ product info: "SAMSUNG", "04/05/06", "", ""
+ manfid : 0x0000, 0x0000
+ function 4 (fixed disk)
+
+
Signed-off-by: Marcin Juszkiewicz <openembedded@hrw.one.pl>
drivers/ide/legacy/ide-cs.c | 1 +
@@ -13,11 +19,12 @@ Index: linux-2.6.16/drivers/ide/legacy/ide-cs.c
===================================================================
--- linux-2.6.16.orig/drivers/ide/legacy/ide-cs.c 2006-04-20 12:41:41.000000000 +0200
+++ linux-2.6.16/drivers/ide/legacy/ide-cs.c 2006-04-20 12:45:19.640621552 +0200
-@@ -444,6 +444,7 @@
+@@ -444,6 +444,8 @@
PCMCIA_DEVICE_PROD_ID12("PCMCIA", "CD-ROM", 0x281f1c5d, 0x66536591),
PCMCIA_DEVICE_PROD_ID12("PCMCIA", "PnPIDE", 0x281f1c5d, 0x0c694728),
PCMCIA_DEVICE_PROD_ID12("SHUTTLE TECHNOLOGY LTD.", "PCCARD-IDE/ATAPI Adapter", 0x4a3f0ba0, 0x322560e1),
+ PCMCIA_DEVICE_PROD_ID12("SEAGATE", "ST1", 0x87c1b330, 0xe1f30883), /* Seagate 8GB microdrive */
++ PCMCIA_DEVICE_PROD_ID12("SAMSUNG", "04/05/06", 0x43d74cb4, 0x6a22777d),
PCMCIA_DEVICE_PROD_ID12("TOSHIBA", "MK2001MPL", 0xb4585a1a, 0x3489e003),
PCMCIA_DEVICE_PROD_ID1("TRANSCEND 512M ", 0xd0909443),
PCMCIA_DEVICE_PROD_ID12("WIT", "IDE16", 0x244e5994, 0x3e232852),
diff --git a/packages/linux/linux-openzaurus_2.6.16.bb b/packages/linux/linux-openzaurus_2.6.16.bb
index 1a75f350b8..e6db465519 100644
--- a/packages/linux/linux-openzaurus_2.6.16.bb
+++ b/packages/linux/linux-openzaurus_2.6.16.bb
@@ -1,6 +1,6 @@
include linux-openzaurus.inc
-PR = "r25"
+PR = "r31"
# Handy URLs
# git://rsync.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git \
@@ -91,11 +91,11 @@ SRC_URI = "http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.16.tar.bz2 \
${RPSRC}/pxa-linking-bug.patch;patch=1 \
file://serial-add-support-for-non-standard-xtals-to-16c950-driver.patch;patch=1 \
file://connectplus-remove-ide-HACK.patch;patch=1 \
- file://24-hostap_cs_id.diff;patch=1 \
file://hrw-pcmcia-ids-r2.patch;patch=1 \
- file://locomo-kbd-hotkeys.patch;patch=1 \
- file://locomo-sysrq+keyrepeat.patch;patch=1 \
- file://locomo-lcd-def-bightness.patch;patch=1 \
+ file://00-hostap.patch;patch=1 \
+ file://locomo-kbd-hotkeys.patch;patch=1 \
+ file://locomo-sysrq+keyrepeat.patch;patch=1 \
+ file://locomo-lcd-def-bightness.patch;patch=1 \
file://defconfig-c7x0 \
file://defconfig-ipaq-pxa270 \
file://defconfig-collie \
@@ -105,6 +105,13 @@ SRC_URI = "http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.16.tar.bz2 \
file://defconfig-qemuarm \
file://defconfig-tosa "
+SRC_URI_append_c7x0 = "file://oz-logo-640.patch.bz2;patch=1"
+SRC_URI_append_akita = "file://oz-logo-640.patch.bz2;patch=1"
+SRC_URI_append_spitz = "file://oz-logo-640.patch.bz2;patch=1"
+SRC_URI_append_collie = "file://oz-logo-240.patch.bz2;patch=1"
+SRC_URI_append_poodle = "file://oz-logo-240.patch.bz2;patch=1"
+SRC_URI_append_tosa = "file://oz-logo-480.patch.bz2;patch=1"
+
# Disabled until I find the reason this gives issues with cdc_subset
# ${RPSRC}/usb_rndis_tweaks-r0.patch;patch=1 \