summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2006-09-23 02:04:03 +0000
committerRod Whitby <rod@whitby.id.au>2006-09-23 02:04:03 +0000
commit9b9ba6895e4d6e0d911a4a7659e20db84f495206 (patch)
treed26bbe643a15fb0e864c05407e2fb14312c80ca9 /packages/linux
parente664c9a7751b0b75b1bcebb77dc42108af42208d (diff)
ixp4xx-kernel: Updated to svn repo rev after layout revert. Enanced svnpatch to take a configurable kernel repo path.
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/ixp4xx-kernel-svnpatch.inc6
-rw-r--r--packages/linux/ixp4xx-kernel_2.6.18.bb2
2 files changed, 5 insertions, 3 deletions
diff --git a/packages/linux/ixp4xx-kernel-svnpatch.inc b/packages/linux/ixp4xx-kernel-svnpatch.inc
index 3acd06d3ac..573888f30a 100644
--- a/packages/linux/ixp4xx-kernel-svnpatch.inc
+++ b/packages/linux/ixp4xx-kernel-svnpatch.inc
@@ -1,10 +1,12 @@
addtask svnpatch before do_configure after do_patch
+IXP4XX_KERNEL_SVN_REPO ?= http://svn.nslu2-linux.org/svnroot/kernel/trunk
+
do_svnpatch() {
- svn co http://svn.nslu2-linux.org/svnroot/kernel/trunk/patches/${PV} --revision ${IXP4XX_KERNEL_SVN_REV} ${WORKDIR}/patches-${PV}
+ svn co ${IXP4XX_KERNEL_SVN_REPO}/patches/${PV} --revision ${IXP4XX_KERNEL_SVN_REV} ${WORKDIR}/patches-${PV}
cp ${WORKDIR}/patches-${PV}/defconfig ${WORKDIR}/defconfig
rm -rf ${S}/patches
- cd ${S} && ln -s ${WORKDIR}/patches-${PV} ${S}/patches
+ cd ${S} && ln -s ${WORKDIR}/patches-${PV} ${S}/patches
cd ${S} && ${STAGING_BINDIR}/quilt push -av
}
diff --git a/packages/linux/ixp4xx-kernel_2.6.18.bb b/packages/linux/ixp4xx-kernel_2.6.18.bb
index 12f608bf03..b9ca8b44c9 100644
--- a/packages/linux/ixp4xx-kernel_2.6.18.bb
+++ b/packages/linux/ixp4xx-kernel_2.6.18.bb
@@ -6,7 +6,7 @@
# http://trac.nslu2-linux.org/kernel/
#
# The revision that is pulled from SVN is specified below
-IXP4XX_KERNEL_SVN_REV = "416"
+IXP4XX_KERNEL_SVN_REV = "421"
#
# Increment the number below (i.e. the digits after PR) when
# the changes in SVN between revisions include changes in the