summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-07-03 17:49:53 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-07-03 17:49:53 +0000
commit2f711c565e08b3ae9553226a80456d259e5a12bb (patch)
tree07678e2a83ac366d61bb4e51015f1024830d0a16 /packages/linux
parent25550bf2091bb90cbde005e19b8e0dd049d239c8 (diff)
parent7e66b8bf6f85be497947f41753a4a0f47dfb1c34 (diff)
merge of '80ab682c6bb8a0598f7082eb2cfc84039cc516ba'
and '9e9051124800e7d4f113baa880bf489834c0fbf2'
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-x86_2.6.20.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/packages/linux/linux-x86_2.6.20.bb b/packages/linux/linux-x86_2.6.20.bb
index ec79c94bc4..cfc8af6f21 100644
--- a/packages/linux/linux-x86_2.6.20.bb
+++ b/packages/linux/linux-x86_2.6.20.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Linux Kernel for x86 compatible machines"
SECTION = "kernel"
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 "
@@ -29,3 +29,12 @@ do_configure_prepend_i686() {
install -m 0644 ${WORKDIR}/i686-defconfig ${S}/.config
}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 arch/i386/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_populate_staging after do_compile