summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-06-15 14:43:40 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-15 14:43:40 +0000
commit59dd32c83d45a68ffd97331bf473b849960f7863 (patch)
tree1e846b7668f2cfdef1631a1e71d182189a2fd54f /packages/linux
parentbc03091e3e838c63b8b28342144b5abd0119f10a (diff)
linux-oz-2.6: Rearrange patches to reflect submission status. Minor tweaks to make the defconfigs more equal. Update git kernel to a more recent version of the kernel.
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-openzaurus-2.6.16+git/hrw-pcmcia-ids-r2.patch9
-rw-r--r--packages/linux/linux-openzaurus-2.6.16+git/locomo-kbd-hotkeys.patch48
-rw-r--r--packages/linux/linux-openzaurus-2.6.16+git/locomo-lcd-def-bightness.patch11
-rw-r--r--packages/linux/linux-openzaurus-2.6.16+git/locomo-sysrq+keyrepeat.patch49
-rw-r--r--packages/linux/linux-openzaurus-2.6.16/defconfig-ipaq-pxa2705
-rw-r--r--packages/linux/linux-openzaurus-2.6.16/defconfig-qemuarm5
-rw-r--r--packages/linux/linux-openzaurus-2.6.16/defconfig-tosa2
-rw-r--r--packages/linux/linux-openzaurus-2.6.16/locomo-kbd-hotkeys.patch8
-rw-r--r--packages/linux/linux-openzaurus-2.6.16/locomo-sysrq+keyrepeat.patch17
-rw-r--r--packages/linux/linux-openzaurus_2.6.16+git.bb31
-rw-r--r--packages/linux/linux-openzaurus_2.6.16.bb108
11 files changed, 192 insertions, 101 deletions
diff --git a/packages/linux/linux-openzaurus-2.6.16+git/hrw-pcmcia-ids-r2.patch b/packages/linux/linux-openzaurus-2.6.16+git/hrw-pcmcia-ids-r2.patch
index 3d5d197920..6f77d51dee 100644
--- a/packages/linux/linux-openzaurus-2.6.16+git/hrw-pcmcia-ids-r2.patch
+++ b/packages/linux/linux-openzaurus-2.6.16+git/hrw-pcmcia-ids-r2.patch
@@ -4,6 +4,12 @@ The ident for Seagate 8GB microdrive is
hash 0x76dc4190, 0xcfba9599
manfid 0x0111, 0x0000
+CF card:
+ product info: "SAMSUNG", "04/05/06", "", ""
+ manfid : 0x0000, 0x0000
+ function 4 (fixed disk)
+
+
Signed-off-by: Marcin Juszkiewicz <openembedded@hrw.one.pl>
drivers/ide/legacy/ide-cs.c | 1 +
@@ -13,11 +19,12 @@ Index: linux-2.6.16/drivers/ide/legacy/ide-cs.c
===================================================================
--- linux-2.6.16.orig/drivers/ide/legacy/ide-cs.c 2006-04-20 12:41:41.000000000 +0200
+++ linux-2.6.16/drivers/ide/legacy/ide-cs.c 2006-04-20 12:45:19.640621552 +0200
-@@ -444,6 +444,7 @@
+@@ -444,6 +444,8 @@
PCMCIA_DEVICE_PROD_ID12("PCMCIA", "CD-ROM", 0x281f1c5d, 0x66536591),
PCMCIA_DEVICE_PROD_ID12("PCMCIA", "PnPIDE", 0x281f1c5d, 0x0c694728),
PCMCIA_DEVICE_PROD_ID12("SHUTTLE TECHNOLOGY LTD.", "PCCARD-IDE/ATAPI Adapter", 0x4a3f0ba0, 0x322560e1),
+ PCMCIA_DEVICE_PROD_ID12("SEAGATE", "ST1", 0x87c1b330, 0xe1f30883), /* Seagate 8GB microdrive */
++ PCMCIA_DEVICE_PROD_ID12("SAMSUNG", "04/05/06", 0x43d74cb4, 0x6a22777d),
PCMCIA_DEVICE_PROD_ID12("TOSHIBA", "MK2001MPL", 0xb4585a1a, 0x3489e003),
PCMCIA_DEVICE_PROD_ID1("TRANSCEND 512M ", 0xd0909443),
PCMCIA_DEVICE_PROD_ID12("WIT", "IDE16", 0x244e5994, 0x3e232852),
diff --git a/packages/linux/linux-openzaurus-2.6.16+git/locomo-kbd-hotkeys.patch b/packages/linux/linux-openzaurus-2.6.16+git/locomo-kbd-hotkeys.patch
new file mode 100644
index 0000000000..8b296780d4
--- /dev/null
+++ b/packages/linux/linux-openzaurus-2.6.16+git/locomo-kbd-hotkeys.patch
@@ -0,0 +1,48 @@
+--- linux-2.6.16/drivers/input/keyboard/locomokbd.c 2006-05-11 18:15:17.392063008 +0200
++++ linux-2.6.16/drivers/input/keyboard/locomokbd.c.ok 2006-05-11 18:14:55.870334808 +0200
+@@ -44,24 +44,29 @@
+
+ #define LOCOMOKBD_NUMKEYS 128
+
+-#define KEY_ACTIVITY KEY_F16
+-#define KEY_CONTACT KEY_F18
+-#define KEY_CENTER KEY_F15
++
++#define LOCOMO_KEY_CALENDER KEY_F1
++#define LOCOMO_KEY_ADDRESS KEY_F2
++#define LOCOMO_KEY_CANCEL KEY_F4
++#define LOCOMO_KEY_CENTER KEY_F5
++#define LOCOMO_KEY_MAIL KEY_F10
++#define LOCOMO_KEY_OK KEY_F11
++#define LOCOMO_KEY_MENU KEY_F12
+
+ static unsigned char locomokbd_keycode[LOCOMOKBD_NUMKEYS] = {
+- 0, KEY_ESC, KEY_ACTIVITY, 0, 0, 0, 0, 0, 0, 0, /* 0 - 9 */
+- 0, 0, 0, 0, 0, 0, 0, KEY_MENU, KEY_HOME, KEY_CONTACT, /* 10 - 19 */
+- 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, /* 20 - 29 */
+- 0, 0, 0, KEY_CENTER, 0, KEY_MAIL, 0, 0, 0, 0, /* 30 - 39 */
+- 0, 0, 0, 0, 0, 0, 0, 0, 0, KEY_RIGHT, /* 40 - 49 */
+- KEY_UP, KEY_LEFT, 0, 0, KEY_P, 0, KEY_O, KEY_I, KEY_Y, KEY_T, /* 50 - 59 */
+- KEY_E, KEY_W, 0, 0, 0, 0, KEY_DOWN, KEY_ENTER, 0, 0, /* 60 - 69 */
+- KEY_BACKSPACE, 0, KEY_L, KEY_U, KEY_H, KEY_R, KEY_D, KEY_Q, 0, 0, /* 70 - 79 */
+- 0, 0, 0, 0, 0, 0, KEY_ENTER, KEY_RIGHTSHIFT, KEY_K, KEY_J, /* 80 - 89 */
+- KEY_G, KEY_F, KEY_X, KEY_S, 0, 0, 0, 0, 0, 0, /* 90 - 99 */
+- 0, 0, KEY_DOT, 0, KEY_COMMA, KEY_N, KEY_B, KEY_C, KEY_Z, KEY_A, /* 100 - 109 */
+- KEY_LEFTSHIFT, KEY_TAB, KEY_LEFTCTRL, 0, 0, 0, 0, 0, 0, 0, /* 110 - 119 */
+- KEY_M, KEY_SPACE, KEY_V, KEY_APOSTROPHE, KEY_SLASH, 0, 0, 0 /* 120 - 128 */
++ 0, LOCOMO_KEY_CANCEL, LOCOMO_KEY_CALENDER, KEY_HOME, 0, 0, 0, 0, 0, 0, /* 0 - 9 */
++ KEY_HOME, 0, 0, 0, 0, 0, 0, LOCOMO_KEY_MENU, KEY_HOME, LOCOMO_KEY_ADDRESS, /* 10 - 19 */
++ 0, 0, 0, 0, 0, LOCOMO_KEY_MAIL, 0, 0, 0, 0, /* 20 - 29 */
++ 0, 0, 0, LOCOMO_KEY_CENTER, 0, LOCOMO_KEY_MAIL, 0, 0, 0, 0, /* 30 - 39 */
++ 0, 0, 0, 0, 0, 0, 0, 0, 0, KEY_RIGHT, /* 40 - 49 */
++ KEY_UP, KEY_LEFT, 0, 0, KEY_P, 0, KEY_O, KEY_I, KEY_Y, KEY_T, /* 50 - 59 */
++ KEY_E, KEY_W, 0, 0, 0, 0, KEY_DOWN, LOCOMO_KEY_OK, 0, 0, /* 60 - 69 */
++ KEY_BACKSPACE, 0, KEY_L, KEY_U, KEY_H, KEY_R, KEY_D, KEY_Q, 0, 0, /* 70 - 79 */
++ 0, 0, 0, 0, 0, 0, KEY_ENTER, KEY_RIGHTSHIFT, KEY_K, KEY_J, /* 80 - 89 */
++ KEY_G, KEY_F, KEY_X, KEY_S, 0, 0, 0, 0, 0, 0, /* 90 - 99 */
++ 0, 0, KEY_DOT, 0, KEY_COMMA, KEY_N, KEY_B, KEY_C, KEY_Z, KEY_A, /* 100 - 109 */
++ KEY_LEFTSHIFT, KEY_TAB, KEY_LEFTCTRL, 0, 0, 0, 0, 0, 0, 0, /* 110 - 119 */
++ KEY_M, KEY_SPACE, KEY_V, KEY_APOSTROPHE, KEY_SLASH, 0, 0, 0 /* 120 - 128 */
+ };
+
+ #define KB_ROWS 16
diff --git a/packages/linux/linux-openzaurus-2.6.16+git/locomo-lcd-def-bightness.patch b/packages/linux/linux-openzaurus-2.6.16+git/locomo-lcd-def-bightness.patch
new file mode 100644
index 0000000000..6408ef9551
--- /dev/null
+++ b/packages/linux/linux-openzaurus-2.6.16+git/locomo-lcd-def-bightness.patch
@@ -0,0 +1,11 @@
+--- linux-2.6.16/drivers/video/backlight/locomolcd.c.orig 2006-05-14 13:24:01.354435088 +0200
++++ linux-2.6.16/drivers/video/backlight/locomolcd.c 2006-05-14 13:24:11.920828752 +0200
+@@ -201,7 +201,7 @@
+ return PTR_ERR (locomolcd_bl_device);
+
+ /* Set up frontlight so that screen is readable */
+- locomobl_data.brightness = 2;
++ locomobl_data.brightness = 3;
+ locomolcd_set_intensity(locomolcd_bl_device);
+
+ return 0;
diff --git a/packages/linux/linux-openzaurus-2.6.16+git/locomo-sysrq+keyrepeat.patch b/packages/linux/linux-openzaurus-2.6.16+git/locomo-sysrq+keyrepeat.patch
new file mode 100644
index 0000000000..7e233277da
--- /dev/null
+++ b/packages/linux/linux-openzaurus-2.6.16+git/locomo-sysrq+keyrepeat.patch
@@ -0,0 +1,49 @@
+--- linux-2.6.16/drivers/input/keyboard/locomokbd.c.orig 2006-05-13 22:53:33.810228656 +0200
++++ linux-2.6.16/drivers/input/keyboard/locomokbd.c 2006-05-13 22:56:56.544408376 +0200
+@@ -45,17 +45,20 @@
+ #define LOCOMOKBD_NUMKEYS 128
+
+
+-#define LOCOMO_KEY_CALENDER KEY_F1
+-#define LOCOMO_KEY_ADDRESS KEY_F2
+-#define LOCOMO_KEY_CANCEL KEY_F4
+-#define LOCOMO_KEY_CENTER KEY_F5
+-#define LOCOMO_KEY_MAIL KEY_F10
+-#define LOCOMO_KEY_OK KEY_F11
++#define LOCOMO_KEY_CALENDER KEY_LEFTCTRL
++#define LOCOMO_KEY_ADDRESS KEY_LEFTALT /* Needed for SysRQ */
++#define LOCOMO_KEY_HOME KEY_SYSRQ /* Needed for SysRQ */
+ #define LOCOMO_KEY_MENU KEY_F12
++#define LOCOMO_KEY_MAIL KEY_F10
++#define LOCOMO_KEY_OK KEY_F11 /* Don't hardwire to KEY_RETURN */
++#define LOCOMO_KEY_CANCEL KEY_POWER
++#define LOCOMO_KEY_CENTER KEY_F5 /* Don't hardwire to KEY_RETURN */
++
++#define LOCOMO_KEY_FN KEY_F9
+
+ static unsigned char locomokbd_keycode[LOCOMOKBD_NUMKEYS] = {
+- 0, LOCOMO_KEY_CANCEL, LOCOMO_KEY_CALENDER, KEY_HOME, 0, 0, 0, 0, 0, 0, /* 0 - 9 */
+- KEY_HOME, 0, 0, 0, 0, 0, 0, LOCOMO_KEY_MENU, KEY_HOME, LOCOMO_KEY_ADDRESS, /* 10 - 19 */
++ 0, LOCOMO_KEY_CANCEL, LOCOMO_KEY_CALENDER, LOCOMO_KEY_HOME, 0, 0, 0, 0, 0, 0, /* 0 - 9 */
++ 0, 0, 0, 0, 0, 0, 0, LOCOMO_KEY_MENU, 0, LOCOMO_KEY_ADDRESS, /* 10 - 19 */
+ 0, 0, 0, 0, 0, LOCOMO_KEY_MAIL, 0, 0, 0, 0, /* 20 - 29 */
+ 0, 0, 0, LOCOMO_KEY_CENTER, 0, LOCOMO_KEY_MAIL, 0, 0, 0, 0, /* 30 - 39 */
+ 0, 0, 0, 0, 0, 0, 0, 0, 0, KEY_RIGHT, /* 40 - 49 */
+@@ -65,7 +68,7 @@
+ 0, 0, 0, 0, 0, 0, KEY_ENTER, KEY_RIGHTSHIFT, KEY_K, KEY_J, /* 80 - 89 */
+ KEY_G, KEY_F, KEY_X, KEY_S, 0, 0, 0, 0, 0, 0, /* 90 - 99 */
+ 0, 0, KEY_DOT, 0, KEY_COMMA, KEY_N, KEY_B, KEY_C, KEY_Z, KEY_A, /* 100 - 109 */
+- KEY_LEFTSHIFT, KEY_TAB, KEY_LEFTCTRL, 0, 0, 0, 0, 0, 0, 0, /* 110 - 119 */
++ KEY_LEFTSHIFT, KEY_TAB, LOCOMO_KEY_FN, 0, 0, 0, 0, 0, 0, 0, /* 110 - 119 */
+ KEY_M, KEY_SPACE, KEY_V, KEY_APOSTROPHE, KEY_SLASH, 0, 0, 0 /* 120 - 128 */
+ };
+
+@@ -76,7 +79,7 @@
+ #define NR_SCANCODES 128
+
+ #define KB_DELAY 8
+-#define SCAN_INTERVAL (HZ/10)
++#define SCAN_INTERVAL (HZ/20)
+ #define LOCOMOKBD_PRESSED 1
+
+ struct locomokbd {
diff --git a/packages/linux/linux-openzaurus-2.6.16/defconfig-ipaq-pxa270 b/packages/linux/linux-openzaurus-2.6.16/defconfig-ipaq-pxa270
index d6e3558456..2b1299116c 100644
--- a/packages/linux/linux-openzaurus-2.6.16/defconfig-ipaq-pxa270
+++ b/packages/linux/linux-openzaurus-2.6.16/defconfig-ipaq-pxa270
@@ -205,7 +205,7 @@ CONFIG_BINFMT_ELF=y
# Power management options
#
CONFIG_PM=y
-CONFIG_PM_LEGACY=y
+# CONFIG_PM_LEGACY is not set
# CONFIG_PM_DEBUG is not set
CONFIG_APM=y
@@ -627,8 +627,7 @@ CONFIG_SERIAL_PXA_CONSOLE=y
CONFIG_SERIAL_CORE=y
CONFIG_SERIAL_CORE_CONSOLE=y
CONFIG_UNIX98_PTYS=y
-CONFIG_LEGACY_PTYS=y
-CONFIG_LEGACY_PTY_COUNT=256
+# CONFIG_LEGACY_PTYS is not set
#
# IPMI
diff --git a/packages/linux/linux-openzaurus-2.6.16/defconfig-qemuarm b/packages/linux/linux-openzaurus-2.6.16/defconfig-qemuarm
index 2d896af0e6..a12c7f4302 100644
--- a/packages/linux/linux-openzaurus-2.6.16/defconfig-qemuarm
+++ b/packages/linux/linux-openzaurus-2.6.16/defconfig-qemuarm
@@ -221,7 +221,7 @@ CONFIG_BINFMT_ELF=y
# Power management options
#
CONFIG_PM=y
-CONFIG_PM_LEGACY=y
+# CONFIG_PM_LEGACY is not set
# CONFIG_PM_DEBUG is not set
# CONFIG_APM is not set
@@ -570,8 +570,7 @@ CONFIG_SERIAL_AMBA_PL011_CONSOLE=y
CONFIG_SERIAL_CORE=y
CONFIG_SERIAL_CORE_CONSOLE=y
CONFIG_UNIX98_PTYS=y
-CONFIG_LEGACY_PTYS=y
-CONFIG_LEGACY_PTY_COUNT=256
+# CONFIG_LEGACY_PTYS is not set
#
# IPMI
diff --git a/packages/linux/linux-openzaurus-2.6.16/defconfig-tosa b/packages/linux/linux-openzaurus-2.6.16/defconfig-tosa
index d09989c4dd..4302f47e15 100644
--- a/packages/linux/linux-openzaurus-2.6.16/defconfig-tosa
+++ b/packages/linux/linux-openzaurus-2.6.16/defconfig-tosa
@@ -230,7 +230,7 @@ CONFIG_BINFMT_MISC=m
# Power management options
#
CONFIG_PM=y
-CONFIG_PM_LEGACY=y
+# CONFIG_PM_LEGACY is not set
# CONFIG_PM_DEBUG is not set
CONFIG_APM=y
diff --git a/packages/linux/linux-openzaurus-2.6.16/locomo-kbd-hotkeys.patch b/packages/linux/linux-openzaurus-2.6.16/locomo-kbd-hotkeys.patch
index 44a37dbc29..8b296780d4 100644
--- a/packages/linux/linux-openzaurus-2.6.16/locomo-kbd-hotkeys.patch
+++ b/packages/linux/linux-openzaurus-2.6.16/locomo-kbd-hotkeys.patch
@@ -46,11 +46,3 @@
};
#define KB_ROWS 16
-@@ -150,6 +155,7 @@
- for (row = 0; row < KB_ROWS; row++) {
- scancode = SCANCODE(col, row);
- if (rowd & KB_ROWMASK(row)) {
-+ /* printk(KERN_ERR "locomokbd: COL [%i] ROW [%i] scancode [%i] keycode [%i]\n",col,row,scancode,locomokbd->keycode[scancode]); */
- num_pressed += 1;
- input_report_key(locomokbd->input, locomokbd->keycode[scancode], 1);
- } else {
diff --git a/packages/linux/linux-openzaurus-2.6.16/locomo-sysrq+keyrepeat.patch b/packages/linux/linux-openzaurus-2.6.16/locomo-sysrq+keyrepeat.patch
index 94dabf4384..7e233277da 100644
--- a/packages/linux/linux-openzaurus-2.6.16/locomo-sysrq+keyrepeat.patch
+++ b/packages/linux/linux-openzaurus-2.6.16/locomo-sysrq+keyrepeat.patch
@@ -47,20 +47,3 @@
#define LOCOMOKBD_PRESSED 1
struct locomokbd {
-@@ -146,6 +149,7 @@
- locomokbd_charge_all(membase);
-
- num_pressed = 0;
-+
- for (col = 0; col < KB_COLS; col++) {
-
- locomokbd_activate_col(membase, col);
-@@ -155,7 +159,7 @@
- for (row = 0; row < KB_ROWS; row++) {
- scancode = SCANCODE(col, row);
- if (rowd & KB_ROWMASK(row)) {
-- /* printk(KERN_ERR "locomokbd: COL [%i] ROW [%i] scancode [%i] keycode [%i]\n",col,row,scancode,locomokbd->keycode[scancode]); */
-+ /* printk(KERN_ERR "locomokbd: ROW [%i] COL [%i] scancode [%i] keycode [%i]\n",row,col,scancode,locomokbd->keycode[scancode]); */
- num_pressed += 1;
- input_report_key(locomokbd->input, locomokbd->keycode[scancode], 1);
- } else {
diff --git a/packages/linux/linux-openzaurus_2.6.16+git.bb b/packages/linux/linux-openzaurus_2.6.16+git.bb
index 4a3d8d62b4..e81838ba66 100644
--- a/packages/linux/linux-openzaurus_2.6.16+git.bb
+++ b/packages/linux/linux-openzaurus_2.6.16+git.bb
@@ -1,6 +1,6 @@
include linux-openzaurus.inc
-PR = "r15"
+PR = "r18"
DEFAULT_PREFERENCE = "-1"
@@ -15,12 +15,16 @@ DEFAULT_PREFERENCE = "-1"
# Patches submitted upstream are towards top of this list
# Hacks should clearly named and at the bottom
# ftp://ftp.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.14-rc2/2.6.14-rc2-mm1/2.6.14-rc2-mm1.bz2;patch=1 \
-SRC_URI = "git://rsync.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;tag=cbdf811c77cf2906a099b8da92e9f6f335b68a73 \
- file://rmk-mmc1.patch;patch=1 \
- file://rmk-mmc2.patch;patch=1 \
+SRC_URI = "git://rsync.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;tag=553698f944ed715dfe023b4cef07601f0ce735f0 \
+ ${RPSRC}/zlib_inflate-r3.patch;patch=1;status=pending \
+ ${RPSRC}/logo_rotate_fix-r1.patch;patch=1;status=pending \
+ ${RPSRC}/poodle_partsize-r0.patch;patch=1;status=pending \
${RPSRC}/mmc_oops_fix-r0.patch;patch=1 \
${RPSRC}/mmcsd_large_cards-r0.patch;patch=1 \
+ ${RPSRC}/mmcsd_no_scr_check-r0.patch;patch=1 \
+# ${RPSRC}/alsa/asoc-v0.10rc8.patch;patch=1 \
${RPSRC}/alsa/asoc-v0.10rc4.patch;patch=1 \
+ ${RPSRC}/asoc_fixups-r1.patch;patch=1 \
${RPSRC}/hx2750_base-r24.patch;patch=1 \
${RPSRC}/hx2750_bl-r5.patch;patch=1 \
${RPSRC}/hx2750_pcmcia-r2.patch;patch=1 \
@@ -31,32 +35,28 @@ SRC_URI = "git://rsync.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.gi
${RPSRC}/input_power-r5.patch;patch=1 \
${RPSRC}/jffs2_longfilename-r1.patch;patch=1 \
${RPSRC}/pxa25x_cpufreq-r0.patch;patch=1 \
- ${RPSRC}/poodle_partsize-r0.patch;patch=1 \
${RPSRC}/collie_frontlight-r4.patch;patch=1 \
- ${RPSRC}/zlib_inflate-r3.patch;patch=1 \
${RPSRC}/zaurus_reboot-r1.patch;patch=1 \
${RPSRC}/sharpsl_pm_fixes1-r0.patch;patch=1 \
- ${RPSRC}/asoc_fixups-r2.patch;patch=1 \
${RPSRC}/pm_changes-r1.patch;patch=1 \
- ${RPSRC}/input_switch_rename-r0.patch;patch=1 \
- ${RPSRC}/led_class_kconfig-r0.patch;patch=1 \
- ${RPSRC}/led_maintainer-r0.patch;patch=1 \
- ${RPSRC}/led_sysfs_fix-r0.patch;patch=1 \
- ${RPSRC}/backlight_sysfs_fix-r0.patch;patch=1 \
${RPSRC}/sharpsl_pm-do-r2.patch;patch=1 \
${RPSRC}/usb_pxa27x_udc-r0.patch;patch=1 \
${RPSRC}/usb_add_epalloc-r1.patch;patch=1 \
${DOSRC}/kexec-arm-r2.patch;patch=1 \
${RPSRC}/pxa_cf_initorder_hack-r1.patch;patch=1 \
- ${RPSRC}/mmcsd_no_scr_check-r0.patch;patch=1 \
${RPSRC}/poodle_ts_hack-r0.patch;patch=1 \
${RPSRC}/integrator_rgb-r0.patch;patch=1 \
+ ${RPSRC}/logo_oh-r0.patch.bz2;patch=1 \
+ ${RPSRC}/logo_oz-r1.patch.bz2;patch=1 \
file://add-oz-release-string.patch;patch=1 \
file://pxa-serial-hack.patch;patch=1 \
${RPSRC}/pxa-linking-bug.patch;patch=1 \
file://serial-add-support-for-non-standard-xtals-to-16c950-driver.patch;patch=1 \
file://connectplus-remove-ide-HACK.patch;patch=1 \
file://24-hostap_cs_id.diff;patch=1 \
+ file://locomo-kbd-hotkeys.patch;patch=1 \
+ file://locomo-sysrq+keyrepeat.patch;patch=1 \
+ file://locomo-lcd-def-bightness.patch;patch=1 \
file://hrw-pcmcia-ids-r2.patch;patch=1 \
file://defconfig-c7x0 \
file://defconfig-ipaq-pxa270 \
@@ -66,7 +66,10 @@ SRC_URI = "git://rsync.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.gi
file://defconfig-spitz \
file://defconfig-qemuarm \
file://defconfig-tosa "
-
+
+# Disabled until I find the reason this gives issues with cdc_subset
+# ${RPSRC}/usb_rndis_tweaks-r0.patch;patch=1 \
+
# http://tglx.de/projects/armirq/2.6.17-rc3/patch-2.6.17-rc3-armirq4.patch;patch=1 \
# ${RPSRC}/../pxa27x_overlay-r0.patch;patch=1 \
diff --git a/packages/linux/linux-openzaurus_2.6.16.bb b/packages/linux/linux-openzaurus_2.6.16.bb
index 8ebccdf961..0116d3098a 100644
--- a/packages/linux/linux-openzaurus_2.6.16.bb
+++ b/packages/linux/linux-openzaurus_2.6.16.bb
@@ -1,6 +1,6 @@
include linux-openzaurus.inc
-PR = "r36"
+PR = "r37"
# Handy URLs
# git://rsync.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git \
@@ -13,47 +13,61 @@ PR = "r36"
# Patches submitted upstream are towards top of this list
# Hacks should clearly named and at the bottom
SRC_URI = "http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.16.tar.bz2 \
- file://rmk-mmc1.patch;patch=1 \
- file://rmk-mmc2.patch;patch=1 \
- ${RPSRC}/led_core-r15.patch;patch=1 \
- ${RPSRC}/led_triggers-r14.patch;patch=1 \
- ${RPSRC}/led_trig_timer-r8.patch;patch=1 \
- ${RPSRC}/led_trig_sharpsl_pm-r5.patch;patch=1 \
- ${RPSRC}/led_zaurus-r10.patch;patch=1 \
- ${RPSRC}/led_locomo-r7.patch;patch=1 \
- ${RPSRC}/led_ixp4xx-r2.patch;patch=1 \
- ${RPSRC}/led_tosa-r5.patch;patch=1 \
- ${RPSRC}/led_ide-r6.patch;patch=1 \
- ${RPSRC}/led_nand-r3.patch;patch=1 \
- ${RPSRC}/ide_end_request-r1.patch;patch=1 \
- ${RPSRC}/rtc-subsystem-library-functions.patch;patch=1 \
- ${RPSRC}/rtc-subsystem-arm-cleanup-r1.patch;patch=1 \
- ${RPSRC}/rtc-subsystem-class.patch;patch=1 \
- ${RPSRC}/rtc-subsystem-class-fix.patch;patch=1 \
- ${RPSRC}/rtc-subsystem-class-fix-2.patch;patch=1 \
- ${RPSRC}/rtc-subsystem-i2c-cleanup-r1.patch;patch=1 \
- ${RPSRC}/rtc-subsystem-sysfs-interface.patch;patch=1 \
- ${RPSRC}/rtc-subsystem-proc-interface.patch;patch=1 \
- ${RPSRC}/rtc-subsystem-dev-interface.patch;patch=1 \
- ${RPSRC}/rtc-subsystem-x1205-driver.patch;patch=1 \
- ${RPSRC}/rtc-subsystem-test-device-driver.patch;patch=1 \
- ${RPSRC}/rtc-subsystem-ds1672-driver.patch;patch=1 \
- ${RPSRC}/rtc-subsystem-pcf8563-driver.patch;patch=1 \
- ${RPSRC}/rtc-subsystem-rs5c372-driver.patch;patch=1 \
- ${RPSRC}/rtc_class_pxa-r2.patch;patch=1 \
- ${RPSRC}/rmk_pxa_mmc_timeout-r0.patch;patch=1 \
- ${RPSRC}/integrator_rtc-r0.patch;patch=1 \
- ${RPSRC}/zaurus_keyboard_tweak-r3.patch;patch=1 \
- ${RPSRC}/arm_eabi_enum_fix-r0.patch;patch=1 \
- ${RPSRC}/pxafb_tweaks-r0.patch;patch=1 \
- ${RPSRC}/spitz_kbd_fix-r0.patch;patch=1 \
- ${RPSRC}/mmcsd_large_cards-r0.patch;patch=1 \
- ${RPSRC}/fbmem_fix-r1.patch;patch=1 \
+ file://rmk-mmc1.patch;patch=1;status=merged \
+ file://rmk-mmc2.patch;patch=1;status=merged \
+ ${RPSRC}/led_core-r15.patch;patch=1;status=merged \
+ ${RPSRC}/led_triggers-r14.patch;patch=1;status=merged \
+ ${RPSRC}/led_trig_timer-r8.patch;patch=1;status=merged \
+ ${RPSRC}/led_trig_sharpsl_pm-r5.patch;patch=1;status=merged \
+ ${RPSRC}/led_zaurus-r10.patch;patch=1;status=merged \
+ ${RPSRC}/led_locomo-r7.patch;patch=1;status=merged \
+ ${RPSRC}/led_ixp4xx-r2.patch;patch=1;status=merged \
+ ${RPSRC}/led_tosa-r5.patch;patch=1;status=merged \
+ ${RPSRC}/led_ide-r6.patch;patch=1;status=merged \
+ ${RPSRC}/led_nand-r3.patch;patch=1;status=merged \
+ ${RPSRC}/ide_end_request-r1.patch;patch=1;status=merged \
+ ${RPSRC}/rtc-subsystem-library-functions.patch;patch=1;status=merged \
+ ${RPSRC}/rtc-subsystem-arm-cleanup-r1.patch;patch=1;status=merged \
+ ${RPSRC}/rtc-subsystem-class.patch;patch=1;status=merged \
+ ${RPSRC}/rtc-subsystem-class-fix.patch;patch=1;status=merged \
+ ${RPSRC}/rtc-subsystem-class-fix-2.patch;patch=1;status=merged \
+ ${RPSRC}/rtc-subsystem-i2c-cleanup-r1.patch;patch=1;status=merged \
+ ${RPSRC}/rtc-subsystem-sysfs-interface.patch;patch=1;status=merged \
+ ${RPSRC}/rtc-subsystem-proc-interface.patch;patch=1;status=merged \
+ ${RPSRC}/rtc-subsystem-dev-interface.patch;patch=1;status=merged \
+ ${RPSRC}/rtc-subsystem-x1205-driver.patch;patch=1;status=merged \
+ ${RPSRC}/rtc-subsystem-test-device-driver.patch;patch=1;status=merged \
+ ${RPSRC}/rtc-subsystem-ds1672-driver.patch;patch=1;status=merged \
+ ${RPSRC}/rtc-subsystem-pcf8563-driver.patch;patch=1;status=merged \
+ ${RPSRC}/rtc-subsystem-rs5c372-driver.patch;patch=1;status=merged \
+ ${RPSRC}/rtc_class_pxa-r2.patch;patch=1;status=merged \
+ ${RPSRC}/rmk_pxa_mmc_timeout-r0.patch;patch=1;status=merged \
+ ${RPSRC}/integrator_rtc-r0.patch;patch=1;status=merged \
+ ${RPSRC}/zaurus_keyboard_tweak-r3.patch;patch=1;status=merged \
+ ${RPSRC}/arm_eabi_enum_fix-r0.patch;patch=1;status=merged \
+ ${RPSRC}/pxafb_tweaks-r0.patch;patch=1;status=merged \
+ ${RPSRC}/spitz_kbd_fix-r0.patch;patch=1;status=merged \
+ ${RPSRC}/fbmem_fix-r1.patch;patch=1;status=merged \
+ ${RPSRC}/scoop_linkage-r0.patch;patch=1;status=merged \
+ ${RPSRC}/ssp_cleanup-r0.patch;patch=1;status=merged \
+ ${RPSRC}/misc_fix1-r0.patch;patch=1;status=merged \
+ ${RPSRC}/corgi_bl_cleanup-r3.patch;patch=1;status=merged \
+ ${RPSRC}/corgi_bl_generic-r3.patch;patch=1;status=merged \
+ ${RPSRC}/w100_accel1-r0.patch;patch=1;status=merged \
+ ${RPSRC}/poodle_memsize-r0.patch;patch=1;status=merged \
+ ${RPSRC}/led_class_kconfig-r0.patch;patch=1;status=merged \
+ ${RPSRC}/led_maintainer-r0.patch;patch=1;status=merged \
+ ${RPSRC}/led_sysfs_fix-r0.patch;patch=1;status=merged \
+ ${RPSRC}/backlight_sysfs_fix-r0.patch;patch=1;status=merged \
+ ${RPSRC}/pxaohci_pwrlimit-r0.patch;patch=1;status=merged \
+ ${RPSRC}/zlib_inflate-r3.patch;patch=1;status=pending \
+ ${RPSRC}/logo_rotate_fix-r1.patch;patch=1;status=pending \
+ ${RPSRC}/poodle_partsize-r0.patch;patch=1;status=pending \
${RPSRC}/mmc_oops_fix-r0.patch;patch=1 \
- ${RPSRC}/pxaohci_pwrlimit-r0.patch;patch=1 \
- ${RPSRC}/scoop_linkage-r0.patch;patch=1 \
- ${RPSRC}/ssp_cleanup-r0.patch;patch=1 \
+ ${RPSRC}/mmcsd_large_cards-r0.patch;patch=1 \
+ ${RPSRC}/mmcsd_no_scr_check-r0.patch;patch=1 \
${RPSRC}/alsa/asoc-v0.10rc4.patch;patch=1 \
+ ${RPSRC}/asoc_fixups-r0.patch;patch=1 \
${RPSRC}/hx2750_base-r24.patch;patch=1 \
${RPSRC}/hx2750_bl-r5.patch;patch=1 \
${RPSRC}/hx2750_pcmcia-r2.patch;patch=1 \
@@ -64,33 +78,19 @@ SRC_URI = "http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.16.tar.bz2 \
${RPSRC}/input_power-r4.patch;patch=1 \
${RPSRC}/jffs2_longfilename-r1.patch;patch=1 \
${RPSRC}/pxa25x_cpufreq-r0.patch;patch=1 \
- ${RPSRC}/misc_fix1-r0.patch;patch=1 \
- ${RPSRC}/corgi_bl_cleanup-r3.patch;patch=1 \
- ${RPSRC}/corgi_bl_generic-r3.patch;patch=1 \
- ${RPSRC}/w100_accel1-r0.patch;patch=1 \
- ${RPSRC}/poodle_partsize-r0.patch;patch=1 \
- ${RPSRC}/poodle_memsize-r0.patch;patch=1 \
${RPSRC}/collie_frontlight-r1.patch;patch=1 \
- ${RPSRC}/zlib_inflate-r3.patch;patch=1 \
${RPSRC}/zaurus_reboot-r0.patch;patch=1 \
${RPSRC}/sharpsl_pm_fixes1-r0.patch;patch=1 \
- ${RPSRC}/asoc_fixups-r0.patch;patch=1 \
${RPSRC}/pm_changes-r1.patch;patch=1 \
- ${RPSRC}/led_class_kconfig-r0.patch;patch=1 \
- ${RPSRC}/led_maintainer-r0.patch;patch=1 \
- ${RPSRC}/led_sysfs_fix-r0.patch;patch=1 \
- ${RPSRC}/backlight_sysfs_fix-r0.patch;patch=1 \
${RPSRC}/sharpsl_pm-do-r2.patch;patch=1 \
${RPSRC}/usb_pxa27x_udc-r0.patch;patch=1 \
${RPSRC}/usb_add_epalloc-r1.patch;patch=1 \
${DOSRC}/kexec-arm-r2.patch;patch=1 \
${RPSRC}/pxa_cf_initorder_hack-r1.patch;patch=1 \
- ${RPSRC}/mmcsd_no_scr_check-r0.patch;patch=1 \
${RPSRC}/poodle_ts_hack-r0.patch;patch=1 \
${RPSRC}/integrator_rgb-r0.patch;patch=1 \
${RPSRC}/logo_oh-r0.patch.bz2;patch=1 \
${RPSRC}/logo_oz-r1.patch.bz2;patch=1 \
- ${RPSRC}/logo_rotate_fix-r1.patch;patch=1 \
file://add-oz-release-string.patch;patch=1 \
file://pxa-serial-hack.patch;patch=1 \
${RPSRC}/pxa-linking-bug.patch;patch=1 \