summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-12-06 18:22:02 +0000
committerKoen Kooi <koen@openembedded.org>2006-12-06 18:22:02 +0000
commit04a66a402db68dd442a8b8c97f54fe1bf6bc788e (patch)
tree3bf725d80694305312d9e91bd526b8737995598c /packages/linux
parent2ed20ec8ccdab45a071057b75ad92d1ee63b0f65 (diff)
linux-efika: OE sets ARCH=ppc for TARGET_ARCH=powerpc and apparently that's wrong for a 603e core, so set ARCH to powerpc
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-efika_2.6.18+2.6.19-rc6.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/packages/linux/linux-efika_2.6.18+2.6.19-rc6.bb b/packages/linux/linux-efika_2.6.18+2.6.19-rc6.bb
index 8f5debfe03..15be1736bd 100644
--- a/packages/linux/linux-efika_2.6.18+2.6.19-rc6.bb
+++ b/packages/linux/linux-efika_2.6.18+2.6.19-rc6.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Linux Kernel for the EFIKA dev platform"
SECTION = "kernel"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
COMPATIBLE_MACHINE = "efika"
@@ -13,11 +13,13 @@ S = "${WORKDIR}/linux-2.6.19-rc6_efika"
inherit kernel
-KERNEL_IMAGETYPE = "images/zImage.elf"
+export ARCH=powerpc
+
+KERNEL_IMAGETYPE = "zImage"
do_configure() {
install -m 644 ${WORKDIR}/defconfig ${S}/.config
- make ARCH=ppc oldconfig
+ make ARCH=${ARCH} oldconfig
}
do_deploy() {