summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-08-29 09:03:15 +0000
committerKoen Kooi <koen@openembedded.org>2006-08-29 09:03:15 +0000
commitbb4b9a807fd9ff8a3dc37e26303c805a358f3085 (patch)
tree02813ff39d40ae6c055a98d5ce9fa537b82b54b9 /packages/linux
parent12cd6ac5f22b09038542f066633367bf60513bed (diff)
linux-ezx: update to ezx7 and add 2 patches for gcc4-isms
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-ezx/pxa-serial-gcc4.diff11
-rw-r--r--packages/linux/linux-ezx/sa1100-rtc-gcc4.diff11
-rw-r--r--packages/linux/linux-ezx_2.6.16.13.bb36
3 files changed, 29 insertions, 29 deletions
diff --git a/packages/linux/linux-ezx/pxa-serial-gcc4.diff b/packages/linux/linux-ezx/pxa-serial-gcc4.diff
new file mode 100644
index 0000000000..7f827965e9
--- /dev/null
+++ b/packages/linux/linux-ezx/pxa-serial-gcc4.diff
@@ -0,0 +1,11 @@
+--- /tmp/pxa.c 2006-08-29 10:51:57.000000000 +0200
++++ linux-2.6.16/drivers/serial/pxa.c 2006-08-29 10:52:38.545780000 +0200
+@@ -241,7 +241,7 @@
+ /*
+ * This handles the interrupt from one port.
+ */
+-static inline irqreturn_t
++inline irqreturn_t
+ serial_pxa_irq(int irq, void *dev_id, struct pt_regs *regs)
+ {
+ struct uart_pxa_port *up = (struct uart_pxa_port *)dev_id;
diff --git a/packages/linux/linux-ezx/sa1100-rtc-gcc4.diff b/packages/linux/linux-ezx/sa1100-rtc-gcc4.diff
new file mode 100644
index 0000000000..6fd54ece3a
--- /dev/null
+++ b/packages/linux/linux-ezx/sa1100-rtc-gcc4.diff
@@ -0,0 +1,11 @@
+--- /tmp/sa1100-rtc.c 2006-08-29 10:51:48.000000000 +0200
++++ linux-2.6.16/drivers/char/sa1100-rtc.c 2006-08-29 10:52:14.995780000 +0200
+@@ -126,7 +126,7 @@
+ tval->tm_mday = days + 1;
+ }
+
+-static irqreturn_t rtc_interrupt(int irq, void *dev_id, struct pt_regs *regs)
++irqreturn_t rtc_interrupt(int irq, void *dev_id, struct pt_regs *regs)
+ {
+ unsigned int rtsr = RTSR;
+
diff --git a/packages/linux/linux-ezx_2.6.16.13.bb b/packages/linux/linux-ezx_2.6.16.13.bb
index f326321217..6da8a32a21 100644
--- a/packages/linux/linux-ezx_2.6.16.13.bb
+++ b/packages/linux/linux-ezx_2.6.16.13.bb
@@ -5,8 +5,8 @@ HOMEPAGE = "http://www.openezx.org"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@vanille.de>"
LICENSE = "GPL"
DEPENDS += "quilt-native"
-EZX = "ezx6"
-PR = "${EZX}-r13"
+EZX = "ezx7"
+PR = "${EZX}-r0"
inherit kernel
@@ -17,33 +17,12 @@ RPSRC = "http://www.rpsys.net/openzaurus/patches/archive"
# source and patches
#
SRC_URI = "http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.16.tar.bz2 \
- http://people.openezx.org/stefan/patches/patches-2.6.16-2.6.16.13-exz6-symlink-fix.tar.bz2 \
+ http://people.openezx.org/stefan/patches/patches-2.6.16-2.6.16.13-ezx7.tar.bz2 \
\
- ${RPSRC}/led_core-r15.patch;patch=1 \
- ${RPSRC}/led_triggers-r14.patch;patch=1 \
- ${RPSRC}/led_trig_timer-r8.patch;patch=1 \
- ${RPSRC}/led_trig_sharpsl_pm-r5.patch;patch=1 \
- ${RPSRC}/led_zaurus-r10.patch;patch=1 \
- ${RPSRC}/led_locomo-r7.patch;patch=1 \
- ${RPSRC}/led_ixp4xx-r2.patch;patch=1 \
- ${RPSRC}/led_tosa-r5.patch;patch=1 \
- ${RPSRC}/led_ide-r6.patch;patch=1 \
- ${RPSRC}/led_nand-r3.patch;patch=1 \
- ${RPSRC}/corgi_bl_cleanup-r3.patch;patch=1 \
- ${RPSRC}/corgi_bl_generic-r3.patch;patch=1 \
- ${RPSRC}/backlight_sysfs_fix-r0.patch;patch=1 \
- \
- file://touchscreen-fix-r0.patch;patch=1 \
- \
- file://e680-disable-boomer-HACK.patch;patch=1 \
- \
- file://e680-leds-r1.patch;patch=1 \
- file://a780-leds-r0.patch;patch=1 \
- file://ezx-backlight-r1.patch;patch=1 \
- file://e680-fix-keypad.patch;patch=1 \
- file://pxakbd-fix-directkeys.patch;patch=1 \
- \
- file://logo_linux_clut224.ppm \
+ file://sa1100-rtc-gcc4.diff;patch=1 \
+ file://pxa-serial-gcc4.diff;patch=1 \
+ \
+ file://logo_linux_clut224.ppm \
file://defconfig-a780 \
file://defconfig-e680"
S = "${WORKDIR}/linux-2.6.16"
@@ -79,7 +58,6 @@ do_ezxpatch() {
}
do_configure() {
- mv ${S}/.config harald.config
install -m 0644 ${WORKDIR}/logo_linux_clut224.ppm drivers/video/logo/logo_linux_clut224.ppm
if [ ! -e ${WORKDIR}/defconfig-${MACHINE} ]; then