summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-10-13 17:27:32 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-10-13 17:27:32 +0000
commita0f27933e6c3dcf106a140cae0a49573453c291c (patch)
tree18567a029151ea6757bac414e399a6b52559879d /packages/linux
parent3f46d1f4abd22c338fba930235c1a08375ec1f9b (diff)
linux-omap1: split common stuff into linux-omap1.inc and fixed do_deploy()
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-omap1.inc30
-rw-r--r--packages/linux/linux-omap1_2.6.12-rc2.bb41
-rw-r--r--packages/linux/linux-omap1_2.6.x+git.bb41
3 files changed, 38 insertions, 74 deletions
diff --git a/packages/linux/linux-omap1.inc b/packages/linux/linux-omap1.inc
new file mode 100644
index 0000000000..27e470a6a0
--- /dev/null
+++ b/packages/linux/linux-omap1.inc
@@ -0,0 +1,30 @@
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for OMAP processors"
+LICENSE = "GPL"
+DEPENDS = "u-boot"
+
+COMPATIBLE_MACHINE = "omap5912osk"
+
+inherit kernel
+
+KERNEL_IMAGETYPE = "vmlinux"
+KERNEL_OUTPUT = "${KERNEL_IMAGETYPE}"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ oe_runmake oldconfig
+}
+
+do_deploy() {
+ if [ "${MACHINE}" == "omap5912osk" ]; then
+ install -d ${DEPLOY_DIR_IMAGE}
+ arm-linux-objcopy -O binary -R .note -R .comment -S ${KERNEL_OUTPUT} ${DEPLOY_DIR_IMAGE}/linux.bin
+ gzip -f -9 ${DEPLOY_DIR_IMAGE}/linux.bin
+ mkimage -A arm -O linux -T kernel -C gzip -a 0x10c08000 -e 0x10c08000 -n "OE" -d ${DEPLOY_DIR_IMAGE}/linux.bin.gz ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${MACHINE}-${DATETIME}.bin
+ rm ${DEPLOY_DIR_IMAGE}/linux.bin.gz
+ fi
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_build after do_compile
diff --git a/packages/linux/linux-omap1_2.6.12-rc2.bb b/packages/linux/linux-omap1_2.6.12-rc2.bb
index 46e7d0ba95..54b1e304c9 100644
--- a/packages/linux/linux-omap1_2.6.12-rc2.bb
+++ b/packages/linux/linux-omap1_2.6.12-rc2.bb
@@ -1,44 +1,11 @@
-PR = "r3"
-SECTION = "kernel"
-DESCRIPTION = "Linux kernel for OMAP processors"
-LICENSE = "GPL"
+require linux-omap1.inc
+
+PR = "r4"
SRC_URI = "http://www.kernel.org/pub/linux/kernel/v2.6/testing/linux-2.6.12-rc2.tar.bz2 \
http://www.muru.com/linux/omap/patches/patch-2.6.12-rc2-omap1.bz2;patch=1 \
file://defconfig"
-
S = "${WORKDIR}/linux-2.6.12-rc2"
-KERNEL_IMAGETYPE = "vmlinux"
-KERNEL_OUTPUT = "arch/${ARCH}/boot/compressed/${KERNEL_IMAGETYPE}"
-KERNEL_CCSUFFIX = "-3.3.4"
-
-DEPENDS = "u-boot"
-
-inherit kernel
-
-COMPATIBLE_HOST = 'arm.*-linux'
-
-do_configure_prepend() {
- install -m 0644 ${WORKDIR}/defconfig ${S}/.config
- oe_runmake oldconfig
-}
-
-do_deploy() {
- if [ "${MACHINE}" == "omap5912osk" ]; then
- install -d ${DEPLOY_DIR_IMAGE}
- arm-linux-objcopy -O binary -R .note -R .comment -S arch/arm/boot/compressed/vmlinux ${DEPLOY_DIR_IMAGE}/linux.bin
- gzip -f -9 ${DEPLOY_DIR_IMAGE}/linux.bin
- mkimage -A arm -O linux -T kernel -C gzip -a 0x10c08000 -e 0x10c08000 -n "OE" -d ${DEPLOY_DIR_IMAGE}/linux.bin.gz ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${MACHINE}-${DATETIME}.bin
- rm ${DEPLOY_DIR_IMAGE}/linux.bin.gz
-
-# cp ${DEPLOY_DIR}/uImage_bb.cc /tftpboot
-# install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${MACHINE}-${DATETIME}.bin
- fi
-}
-
-
-do_deploy[dirs] = "${S}"
-
-addtask deploy before do_build after do_compile
+KERNEL_RELEASE = "2.6.12-rc2-omap1"
diff --git a/packages/linux/linux-omap1_2.6.x+git.bb b/packages/linux/linux-omap1_2.6.x+git.bb
index 4c1bb7ccd8..a599bffc72 100644
--- a/packages/linux/linux-omap1_2.6.x+git.bb
+++ b/packages/linux/linux-omap1_2.6.x+git.bb
@@ -1,43 +1,10 @@
-PR = "r0"
-SECTION = "kernel"
-DESCRIPTION = "Linux kernel for OMAP processors"
-LICENSE = "GPL"
+require linux-omap1.inc
-SRC_URI = "git://source.mvista.com/git/linux-omap-2.6.git;protocol=git \
+PR = "r1"
+
+SRC_URI = "git://source.mvista.com/git/linux-omap-2.6.git;protocol=http \
file://defconfig"
S = "${WORKDIR}/git"
-KERNEL_IMAGETYPE = "vmlinux"
-
-DEPENDS = "u-boot"
-
-inherit kernel
-
-KERNEL_OUTPUT = "${KERNEL_IMAGETYPE}"
KERNEL_RELEASE = "2.6.18-omap1"
-
-COMPATIBLE_HOST = 'arm.*-linux'
-
-do_configure_prepend() {
-# if [ "${MACHINE}" == "omap5912osk" ] ; then
-# oe_runmake omap_osk_5912_defconfig
-# fi
- install -m 0644 ${WORKDIR}/defconfig ${S}/.config
- make oldconfig
-}
-
-do_deploy() {
- if [ "${MACHINE}" == "omap5912osk" ]; then
- install -d ${DEPLOY_DIR_IMAGE}
- arm-linux-objcopy -O binary -R .note -R .comment -S ${KERNEL_OUTPUT} ${DEPLOY_DIR_IMAGE}/linux.bin
- gzip -f -9 ${DEPLOY_DIR_IMAGE}/linux.bin
- mkimage -A arm -O linux -T kernel -C gzip -a 0x10008000 -e 0x10008000 -n "OE" -d ${DEPLOY_DIR_IMAGE}/linux.bin.gz ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${MACHINE}-${DATETIME}.bin
- rm ${DEPLOY_DIR_IMAGE}/linux.bin.gz
- fi
-}
-
-
-do_deploy[dirs] = "${S}"
-
-addtask deploy before do_build after do_compile