summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-06-26 17:23:10 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-26 17:23:10 +0000
commita09b2107b88de568ad9674cb8e7c34b3ecca3207 (patch)
treec3d2bfc15bc0f1063ca92c270c8b575a79564831 /packages/linux
parentf57d95b38aff633888ae1c24b8c0c3bdf69905bb (diff)
ep93xx: add 2.6.17.1/derevo19 kernel
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/ep93xx-kernel_2.6.17.1.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/packages/linux/ep93xx-kernel_2.6.17.1.bb b/packages/linux/ep93xx-kernel_2.6.17.1.bb
new file mode 100644
index 0000000000..d8caa8c5e3
--- /dev/null
+++ b/packages/linux/ep93xx-kernel_2.6.17.1.bb
@@ -0,0 +1,54 @@
+DESCRIPTION = "Linux Kernel for Cirrus Logic ep39xx compatible machines"
+SECTION = "kernel"
+MAINTAINER = "Koen Kooi <koen@dominion.kabel.utwente.nl>"
+LICENSE = "GPL"
+PR = "r0"
+
+COMPATIBLE_MACHINE = "ep93xx"
+
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.17.1.tar.bz2 \
+ http://www.wantstofly.org/~buytenh/ep93xx/derevo19.diff;patch=1 \
+ file://defconfig \
+ "
+
+S = "${WORKDIR}/linux-2.6.16"
+
+inherit kernel
+
+KERNEL_IMAGETYPE = "zImage"
+
+do_configure() {
+ rm -f ${S}/.config
+
+ if [ ! -e ${WORKDIR}/defconfig ]; then
+ die "No default configuration for ${MACHINE} available."
+ fi
+
+
+ if [ "${TARGET_OS}" == "linux-gnueabi" ]; then
+ echo "CONFIG_AEABI=y" >> ${S}/.config
+ echo "CONFIG_OABI_COMPAT=y" >> ${S}/.config
+ else
+ echo "# CONFIG_AEABI is not set" >> ${S}/.config
+ echo "# CONFIG_OABI_COMPAT is not set" >> ${S}/.config
+ fi
+
+ sed -e '/CONFIG_AEABI/d' \
+ -e '/CONFIG_OABI_COMPAT=/d' \
+ '${WORKDIR}/defconfig' >>'${S}/.config'
+
+ yes '' | oe_runmake oldconfig
+
+
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_build after do_compile
+
+