summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorJeremy Laine <jeremy.laine@m4x.org>2008-09-10 18:50:13 +0000
committerJeremy Laine <jeremy.laine@m4x.org>2008-09-10 18:50:13 +0000
commit1773c0a81a712156357b14936a982f68761b2f73 (patch)
treece681ea368cf8352eda1f8ee9fac04605b1e69d7 /packages/linux
parentd6faef6e34bf44cd61214eade04d14ae7a12182d (diff)
linux-2.6.26: add support for mpc8313e-rdb's eth0
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-2.6.26/mpc8313e-rdb/defconfig6
-rw-r--r--packages/linux/linux-2.6.26/mpc8313e-rdb/mpc8313e-rdb-eth-fixed.patch25
-rw-r--r--packages/linux/linux_2.6.26.bb3
3 files changed, 30 insertions, 4 deletions
diff --git a/packages/linux/linux-2.6.26/mpc8313e-rdb/defconfig b/packages/linux/linux-2.6.26/mpc8313e-rdb/defconfig
index e71d3b6b5d..76634da120 100644
--- a/packages/linux/linux-2.6.26/mpc8313e-rdb/defconfig
+++ b/packages/linux/linux-2.6.26/mpc8313e-rdb/defconfig
@@ -854,17 +854,17 @@ CONFIG_PHYLIB=y
#
# MII PHY device drivers
#
-# CONFIG_MARVELL_PHY is not set
+CONFIG_MARVELL_PHY=y
# CONFIG_DAVICOM_PHY is not set
# CONFIG_QSEMI_PHY is not set
# CONFIG_LXT_PHY is not set
-CONFIG_CICADA_PHY=y
+# CONFIG_CICADA_PHY is not set
# CONFIG_VITESSE_PHY is not set
# CONFIG_SMSC_PHY is not set
# CONFIG_BROADCOM_PHY is not set
# CONFIG_ICPLUS_PHY is not set
# CONFIG_REALTEK_PHY is not set
-# CONFIG_FIXED_PHY is not set
+CONFIG_FIXED_PHY=y
# CONFIG_MDIO_BITBANG is not set
# CONFIG_NET_ETHERNET is not set
CONFIG_NETDEV_1000=y
diff --git a/packages/linux/linux-2.6.26/mpc8313e-rdb/mpc8313e-rdb-eth-fixed.patch b/packages/linux/linux-2.6.26/mpc8313e-rdb/mpc8313e-rdb-eth-fixed.patch
new file mode 100644
index 0000000000..eab918994e
--- /dev/null
+++ b/packages/linux/linux-2.6.26/mpc8313e-rdb/mpc8313e-rdb-eth-fixed.patch
@@ -0,0 +1,25 @@
+diff -urN linux-2.6.26.orig/arch/powerpc/boot/dts/mpc8313erdb.dts linux-2.6.26/arch/powerpc/boot/dts/mpc8313erdb.dts
+--- linux-2.6.26.orig/arch/powerpc/boot/dts/mpc8313erdb.dts 2008-07-13 23:51:29.000000000 +0200
++++ linux-2.6.26/arch/powerpc/boot/dts/mpc8313erdb.dts 2008-09-10 07:57:42.000000000 +0200
+@@ -160,12 +160,6 @@
+ #size-cells = <0>;
+ compatible = "fsl,gianfar-mdio";
+ reg = <0x24520 0x20>;
+- phy1: ethernet-phy@1 {
+- interrupt-parent = <&ipic>;
+- interrupts = <19 0x8>;
+- reg = <0x1>;
+- device_type = "ethernet-phy";
+- };
+ phy4: ethernet-phy@4 {
+ interrupt-parent = <&ipic>;
+ interrupts = <20 0x8>;
+@@ -183,7 +177,7 @@
+ local-mac-address = [ 00 00 00 00 00 00 ];
+ interrupts = <37 0x8 36 0x8 35 0x8>;
+ interrupt-parent = <&ipic>;
+- phy-handle = < &phy1 >;
++ fixed-link = <1 1 1000 0 0>;
+ };
+
+ enet1: ethernet@25000 {
diff --git a/packages/linux/linux_2.6.26.bb b/packages/linux/linux_2.6.26.bb
index 9e33257442..5b6cd14fba 100644
--- a/packages/linux/linux_2.6.26.bb
+++ b/packages/linux/linux_2.6.26.bb
@@ -1,6 +1,6 @@
require linux.inc
-PR = "r0"
+PR = "r1"
# Mark archs/machines that this kernel supports
DEFAULT_PREFERENCE = "-1"
@@ -13,6 +13,7 @@ SRC_URI_append_mpc8313e-rdb = "\
file://mpc831x-nand.patch;patch=1 \
file://mpc8313e-rdb-leds.patch;patch=1 \
file://mpc8313e-rdb-cardbus.patch;patch=1 \
+ file://mpc8313e-rdb-eth-fixed.patch;patch=1 \
"
# see http://bugzilla.kernel.org/show_bug.cgi?id=11143