summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2005-08-02 11:43:25 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-02 11:43:25 +0000
commitfec6d9b12d01c5a1c450108ffb838335862a4051 (patch)
tree1304c6e8f62cb2989e781ea73bdc848c5f00d125 /packages/linux
parenta4dc9b83d233a7b07e920e0eeceffdcf2053ab02 (diff)
parent0bef08582a7aa3378ba6cb4d1899dd9ae7267483 (diff)
merge of 8893b7644179a244e95e78cea49c28cecbedc8b2
and 9ef371d5ab888cd926919c7bf505d283e4f19f54
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/gumstix_2.6.5-gnalm1-gum0.bb3
-rw-r--r--packages/linux/linux-netvista_2.4.27.bb17
-rw-r--r--packages/linux/linux-openzaurus-2.6.13-rc3-mm3/.mtn2git_empty (renamed from packages/linux/linux-openzaurus-2.6.13-rc3-mm1/.mtn2git_empty)0
-rw-r--r--packages/linux/linux-openzaurus-2.6.13-rc3-mm3/add-elpp-stuff.patch (renamed from packages/linux/linux-openzaurus-2.6.13-rc3-mm1/add-elpp-stuff.patch)0
-rw-r--r--packages/linux/linux-openzaurus-2.6.13-rc3-mm3/add-oz-release-string.patch (renamed from packages/linux/linux-openzaurus-2.6.13-rc3-mm1/add-oz-release-string.patch)0
-rw-r--r--packages/linux/linux-openzaurus-2.6.13-rc3-mm3/defconfig-c7x0 (renamed from packages/linux/linux-openzaurus-2.6.13-rc3-mm1/defconfig-c7x0)0
-rw-r--r--packages/linux/linux-openzaurus-2.6.13-rc3-mm3/defconfig-collie (renamed from packages/linux/linux-openzaurus-2.6.13-rc3-mm1/defconfig-collie)0
-rw-r--r--packages/linux/linux-openzaurus-2.6.13-rc3-mm3/defconfig-ipaq-pxa-2.6 (renamed from packages/linux/linux-openzaurus-2.6.13-rc3-mm1/defconfig-ipaq-pxa-2.6)0
-rw-r--r--packages/linux/linux-openzaurus-2.6.13-rc3-mm3/defconfig-poodle (renamed from packages/linux/linux-openzaurus-2.6.13-rc3-mm1/defconfig-poodle)0
-rw-r--r--packages/linux/linux-openzaurus-2.6.13-rc3-mm3/defconfig-spitz (renamed from packages/linux/linux-openzaurus-2.6.13-rc3-mm1/defconfig-spitz)0
-rw-r--r--packages/linux/linux-openzaurus-2.6.13-rc3-mm3/defconfig-tosa (renamed from packages/linux/linux-openzaurus-2.6.13-rc3-mm1/defconfig-tosa)0
-rw-r--r--packages/linux/linux-openzaurus-2.6.13-rc3-mm3/dtl1_cs-add-socket-revE.patch (renamed from packages/linux/linux-openzaurus-2.6.13-rc3-mm1/dtl1_cs-add-socket-revE.patch)0
-rw-r--r--packages/linux/linux-openzaurus-2.6.13-rc3-mm3/pxa-serial-hack.patch (renamed from packages/linux/linux-openzaurus-2.6.13-rc3-mm1/pxa-serial-hack.patch)0
-rw-r--r--packages/linux/linux-openzaurus_2.6.11.bb34
-rw-r--r--packages/linux/linux-openzaurus_2.6.13-rc3-mm3.bb (renamed from packages/linux/linux-openzaurus_2.6.13-rc3-mm1.bb)13
-rw-r--r--packages/linux/nslu2-kernel/2.6.12/missing-exports.patch19
-rw-r--r--packages/linux/nslu2-kernel_2.6.12.2.bb3
-rw-r--r--packages/linux/openslug-kernel-2.6.12.2/defconfig4
18 files changed, 60 insertions, 33 deletions
diff --git a/packages/linux/gumstix_2.6.5-gnalm1-gum0.bb b/packages/linux/gumstix_2.6.5-gnalm1-gum0.bb
index 9bf400a9f7..c0b3bf2742 100644
--- a/packages/linux/gumstix_2.6.5-gnalm1-gum0.bb
+++ b/packages/linux/gumstix_2.6.5-gnalm1-gum0.bb
@@ -1,3 +1,6 @@
+BROKEN = "1"
+#linux-2.6.5-gnalm1-gum0.patch is not fetchable
+
SECTION = "kernel"
DESCRIPTION = "Linux kernel for OMAP processors"
LICENSE = "GPL"
diff --git a/packages/linux/linux-netvista_2.4.27.bb b/packages/linux/linux-netvista_2.4.27.bb
index 576cfb891c..10c9bfc203 100644
--- a/packages/linux/linux-netvista_2.4.27.bb
+++ b/packages/linux/linux-netvista_2.4.27.bb
@@ -1,21 +1,26 @@
DESCRIPTION = "Linux kernel x86 for IBM Netvista"
-LICENSE = "GPL"
-
-
-PR = "r2"
+LICENSE = "GPL"
+MAINTAINER = "Florian Boor <florian@kernelconcepts.de>
+PR = "r4"
SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.4/linux-${PV}.tar.bz2 \
file://netvista_defconfig"
S = "${WORKDIR}/linux-${PV}"
-COMPATIBLE_HOST = 'i.86.*-linux'
+COMPATIBLE_HOST='i.86.*-linux'
inherit kernel
-KERNEL_CCSUFFIX="-3.3.4"
+KERNEL_CCSUFFIX = "-3.3.4"
ARCH = "i386"
KERNEL_IMAGETYPE = "bzImage"
+# Avoid getting the kernel in the rootfs
+FILES_kernel = ""
+ALLOW_EMPTY_kernel = "1"
+PACKAGES += "kernel-image"
+FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
+
do_configure_prepend() {
install -m 0644 ${WORKDIR}/netvista_defconfig ${S}/.config
}
diff --git a/packages/linux/linux-openzaurus-2.6.13-rc3-mm1/.mtn2git_empty b/packages/linux/linux-openzaurus-2.6.13-rc3-mm3/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/linux/linux-openzaurus-2.6.13-rc3-mm1/.mtn2git_empty
+++ b/packages/linux/linux-openzaurus-2.6.13-rc3-mm3/.mtn2git_empty
diff --git a/packages/linux/linux-openzaurus-2.6.13-rc3-mm1/add-elpp-stuff.patch b/packages/linux/linux-openzaurus-2.6.13-rc3-mm3/add-elpp-stuff.patch
index 85d07191b9..85d07191b9 100644
--- a/packages/linux/linux-openzaurus-2.6.13-rc3-mm1/add-elpp-stuff.patch
+++ b/packages/linux/linux-openzaurus-2.6.13-rc3-mm3/add-elpp-stuff.patch
diff --git a/packages/linux/linux-openzaurus-2.6.13-rc3-mm1/add-oz-release-string.patch b/packages/linux/linux-openzaurus-2.6.13-rc3-mm3/add-oz-release-string.patch
index 22a6fd3943..22a6fd3943 100644
--- a/packages/linux/linux-openzaurus-2.6.13-rc3-mm1/add-oz-release-string.patch
+++ b/packages/linux/linux-openzaurus-2.6.13-rc3-mm3/add-oz-release-string.patch
diff --git a/packages/linux/linux-openzaurus-2.6.13-rc3-mm1/defconfig-c7x0 b/packages/linux/linux-openzaurus-2.6.13-rc3-mm3/defconfig-c7x0
index b993f2ac26..b993f2ac26 100644
--- a/packages/linux/linux-openzaurus-2.6.13-rc3-mm1/defconfig-c7x0
+++ b/packages/linux/linux-openzaurus-2.6.13-rc3-mm3/defconfig-c7x0
diff --git a/packages/linux/linux-openzaurus-2.6.13-rc3-mm1/defconfig-collie b/packages/linux/linux-openzaurus-2.6.13-rc3-mm3/defconfig-collie
index 9f51b61169..9f51b61169 100644
--- a/packages/linux/linux-openzaurus-2.6.13-rc3-mm1/defconfig-collie
+++ b/packages/linux/linux-openzaurus-2.6.13-rc3-mm3/defconfig-collie
diff --git a/packages/linux/linux-openzaurus-2.6.13-rc3-mm1/defconfig-ipaq-pxa-2.6 b/packages/linux/linux-openzaurus-2.6.13-rc3-mm3/defconfig-ipaq-pxa-2.6
index 8b41380784..8b41380784 100644
--- a/packages/linux/linux-openzaurus-2.6.13-rc3-mm1/defconfig-ipaq-pxa-2.6
+++ b/packages/linux/linux-openzaurus-2.6.13-rc3-mm3/defconfig-ipaq-pxa-2.6
diff --git a/packages/linux/linux-openzaurus-2.6.13-rc3-mm1/defconfig-poodle b/packages/linux/linux-openzaurus-2.6.13-rc3-mm3/defconfig-poodle
index 42a851dd5f..42a851dd5f 100644
--- a/packages/linux/linux-openzaurus-2.6.13-rc3-mm1/defconfig-poodle
+++ b/packages/linux/linux-openzaurus-2.6.13-rc3-mm3/defconfig-poodle
diff --git a/packages/linux/linux-openzaurus-2.6.13-rc3-mm1/defconfig-spitz b/packages/linux/linux-openzaurus-2.6.13-rc3-mm3/defconfig-spitz
index ed5010d5c8..ed5010d5c8 100644
--- a/packages/linux/linux-openzaurus-2.6.13-rc3-mm1/defconfig-spitz
+++ b/packages/linux/linux-openzaurus-2.6.13-rc3-mm3/defconfig-spitz
diff --git a/packages/linux/linux-openzaurus-2.6.13-rc3-mm1/defconfig-tosa b/packages/linux/linux-openzaurus-2.6.13-rc3-mm3/defconfig-tosa
index c7eba4a337..c7eba4a337 100644
--- a/packages/linux/linux-openzaurus-2.6.13-rc3-mm1/defconfig-tosa
+++ b/packages/linux/linux-openzaurus-2.6.13-rc3-mm3/defconfig-tosa
diff --git a/packages/linux/linux-openzaurus-2.6.13-rc3-mm1/dtl1_cs-add-socket-revE.patch b/packages/linux/linux-openzaurus-2.6.13-rc3-mm3/dtl1_cs-add-socket-revE.patch
index a2dbce3325..a2dbce3325 100644
--- a/packages/linux/linux-openzaurus-2.6.13-rc3-mm1/dtl1_cs-add-socket-revE.patch
+++ b/packages/linux/linux-openzaurus-2.6.13-rc3-mm3/dtl1_cs-add-socket-revE.patch
diff --git a/packages/linux/linux-openzaurus-2.6.13-rc3-mm1/pxa-serial-hack.patch b/packages/linux/linux-openzaurus-2.6.13-rc3-mm3/pxa-serial-hack.patch
index ee761b75ad..ee761b75ad 100644
--- a/packages/linux/linux-openzaurus-2.6.13-rc3-mm1/pxa-serial-hack.patch
+++ b/packages/linux/linux-openzaurus-2.6.13-rc3-mm3/pxa-serial-hack.patch
diff --git a/packages/linux/linux-openzaurus_2.6.11.bb b/packages/linux/linux-openzaurus_2.6.11.bb
index d93006ffa7..ef1a97d2e4 100644
--- a/packages/linux/linux-openzaurus_2.6.11.bb
+++ b/packages/linux/linux-openzaurus_2.6.11.bb
@@ -21,31 +21,31 @@ JLSRC = "http://www.cs.wisc.edu/~lenz/zaurus/files/"
SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.11.tar.gz \
http://www.kernel.org/pub/linux/kernel/people/rml/inotify/v2.6/0.22/inotify-0.22-rml-2.6.11-1.patch;patch=1 \
${JLSRC}/zaurus-base-2.6.11.diff.gz;patch=1 \
- ${RPSRC}/rndis_fix-r0.patch;patch=1 \
- ${RPSRC}/w100_malloc-r2.patch;patch=1 \
- ${RPSRC}/pxairq_printk-r0.patch;patch=1 \
- ${RPSRC}/corgi_kbd-r14.patch;patch=1 \
- ${RPSRC}/corgi_ts-r10.patch;patch=1 \
- ${RPSRC}/sharp_multi_scoop-r1.patch;patch=1 \
- ${RPSRC}/corgi_kbd1-r0.patch;patch=1 \
- ${RPSRC}/sharpsl_param-r5.patch;patch=1 \
+ ${RPSRC}/archive/rndis_fix-r0.patch;patch=1 \
+ ${RPSRC}/archive/w100_malloc-r2.patch;patch=1 \
+ ${RPSRC}/archive/pxairq_printk-r0.patch;patch=1 \
+ ${RPSRC}/archive/corgi_kbd-r14.patch;patch=1 \
+ ${RPSRC}/archive/corgi_ts-r10.patch;patch=1 \
+ ${RPSRC}/archive/sharp_multi_scoop-r1.patch;patch=1 \
+ ${RPSRC}/archive/corgi_kbd1-r0.patch;patch=1 \
+ ${RPSRC}/archive/sharpsl_param-r5.patch;patch=1 \
${RPSRC}/pxa_rtc-r1.patch;patch=1 \
- ${RPSRC}/pxa_irda-r1.patch;patch=1 \
- ${RPSRC}/pxaudc_susres-r1.patch;patch=1 \
+ ${RPSRC}/archive/pxa_irda-r1.patch;patch=1 \
+ ${RPSRC}/archive/pxaudc_susres-r1.patch;patch=1 \
${RPSRC}/sharp_multi_pcmcia-r2.patch;patch=1 \
- ${RPSRC}/pxa_turbo-r0.patch;patch=1 \
- ${RPSRC}/sharpsl_mapprom-r1.patch;patch=1 \
- ${RPSRC}/input_power-r1.patch;patch=1 \
+ ${RPSRC}/archive/pxa_turbo-r0.patch;patch=1 \
+ ${RPSRC}/archive/sharpsl_mapprom-r1.patch;patch=1 \
+ ${RPSRC}/archive/input_power-r1.patch;patch=1 \
${RPSRC}/corgi_irda-r2.patch;patch=1 \
${RPSRC}/corgi_base_extras1-r2.patch;patch=1 \
${RPSRC}/jffs2_longfilename-r0.patch;patch=1 \
- ${RPSRC}/corgi_power-r22.patch;patch=1 \
+ ${RPSRC}/archive/corgi_power-r22.patch;patch=1 \
${RPSRC}/corgi_power1-r1.patch;patch=1 \
- ${RPSRC}/ide_fixes-r1.patch;patch=1 \
- ${RPSRC}/mmc_sd-r4.patch;patch=1 \
+ ${RPSRC}/archive/ide_fixes-r1.patch;patch=1 \
+ ${RPSRC}/archive/mmc_sd-r4.patch;patch=1 \
${RPSRC}/mmc_timeout-r0.patch;patch=1 \
${RPSRC}/corgi_snd-r6.patch;patch=1 \
- ${RPSRC}/w100_split-r5-r1.patch;patch=1 \
+ ${RPSRC}/archive/w100_split-r5-r1.patch;patch=1 \
${DOSRC}/pxa2xx-ir-dma-r0.patch;patch=1 \
${DOSRC}/tc6393-device-r2.patch;patch=1 \
${DOSRC}/tc6393_nand-r2.patch;patch=1 \
diff --git a/packages/linux/linux-openzaurus_2.6.13-rc3-mm1.bb b/packages/linux/linux-openzaurus_2.6.13-rc3-mm3.bb
index 4f764c7803..2c7042c7ca 100644
--- a/packages/linux/linux-openzaurus_2.6.13-rc3-mm1.bb
+++ b/packages/linux/linux-openzaurus_2.6.13-rc3-mm3.bb
@@ -5,7 +5,7 @@ LICENSE = "GPL"
#KV = "${@bb.data.getVar('PV',d,True).split('-')[0]}"
KV = "${@bb.data.getVar('PV',d,True)}"
-PR = "r2"
+PR = "r0"
DOSRC = "http://www.do13.in-berlin.de/openzaurus/patches"
RPSRC = "http://www.rpsys.net/openzaurus/patches"
@@ -23,10 +23,9 @@ BASRC = "http://www.orca.cx/zaurus/patches"
# Patches submitted upstream are towards top of this list
SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.12.tar.gz \
ftp://ftp.kernel.org/pub/linux/kernel/v2.6/testing/patch-2.6.13-rc3.bz2;patch=1 \
- ftp://ftp.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.13-rc3/2.6.13-rc3-mm1/2.6.13-rc3-mm1.bz2;patch=1 \
- ${RPSRC}/nand_softlockup-r0.patch;patch=1 \
- ${RPSRC}/oprofile_irqfix-r0.patch;patch=1 \
- ${RPSRC}/preempt_nwfpe-r1.patch;patch=1 \
+ ftp://ftp.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.13-rc3/2.6.13-rc3-mm3/2.6.13-rc3-mm3.bz2;patch=1 \
+ ${RPSRC}/2.6.13-rc3-mm3_fix-r0.patch;patch=1 \
+ ${RPSRC}/preempt_nwfpe-r2.patch;patch=1 \
${RPSRC}/oprofile_typo-r0.patch;patch=1 \
${RPSRC}/corgi_tspmu-r2.patch;patch=1 \
${RPSRC}/w100_core-r1.patch;patch=1 \
@@ -52,7 +51,7 @@ SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.12.tar.gz \
${DOSRC}/rmk-i2c-pxa-r0.patch;patch=1 \
${RPSRC}/spitz_mtd-r0.patch;patch=1 \
${RPSRC}/ipaq/hx2750_base-r19.patch;patch=1 \
- ${RPSRC}/ipaq/hx2750_bl-r0.patch;patch=1 \
+ ${RPSRC}/ipaq/hx2750_bl-r1.patch;patch=1 \
${RPSRC}/ipaq/hx2750_pcmcia-r1.patch;patch=1 \
${RPSRC}/ipaq/pxa_keys-r1.patch;patch=1 \
${RPSRC}/ipaq/tsc2101-r7.patch;patch=1 \
@@ -70,7 +69,7 @@ SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.12.tar.gz \
${DOSRC}/tosa-udc-r3.patch;patch=1 \
${DOSRC}/tosa-irda-r2.patch;patch=1 \
${DOSRC}/tosa-lcd-r3.patch;patch=1 \
- ${DOSRC}/tosa-bl-r4.patch;patch=1 \
+ ${RPSRC}/temp/tosa-bl-r5.patch;patch=1 \
${JLSRC}/zaurus-local-2.6.11.diff.gz;patch=1 \
file://add-oz-release-string.patch;patch=1 \
file://add-elpp-stuff.patch;patch=1 \
diff --git a/packages/linux/nslu2-kernel/2.6.12/missing-exports.patch b/packages/linux/nslu2-kernel/2.6.12/missing-exports.patch
new file mode 100644
index 0000000000..935dd29115
--- /dev/null
+++ b/packages/linux/nslu2-kernel/2.6.12/missing-exports.patch
@@ -0,0 +1,19 @@
+--- linux-2.6.12/drivers/char/random.c~ 2005-05-14 16:42:24.000000000 -0400
++++ linux-2.6.12/drivers/char/random.c 2005-05-14 16:42:46.000000000 -0400
+@@ -646,6 +646,7 @@ extern void add_input_randomness(unsigne
+ add_timer_randomness(&input_timer_state,
+ (type << 4) ^ code ^ (code >> 4) ^ value);
+ }
++EXPORT_SYMBOL_GPL(add_input_randomness);
+
+ void add_interrupt_randomness(int irq)
+ {
+--- linux-2.6.12/lib/kobject_uevent.c~ 2005-05-14 16:45:13.000000000 -0400
++++ linux-2.6.12/lib/kobject_uevent.c 2005-05-14 16:45:27.000000000 -0400
+@@ -178,6 +178,7 @@ static inline int send_uevent(const char
+
+ #ifdef CONFIG_HOTPLUG
+ char hotplug_path[HOTPLUG_PATH_LEN] = "/sbin/hotplug";
++EXPORT_SYMBOL_GPL(hotplug_path);
+ u64 hotplug_seqnum;
+ static DEFINE_SPINLOCK(sequence_lock);
diff --git a/packages/linux/nslu2-kernel_2.6.12.2.bb b/packages/linux/nslu2-kernel_2.6.12.2.bb
index d72015c29a..8b54cdc703 100644
--- a/packages/linux/nslu2-kernel_2.6.12.2.bb
+++ b/packages/linux/nslu2-kernel_2.6.12.2.bb
@@ -1,5 +1,5 @@
# Kernel for NSLU2
-PR = "r4"
+PR = "r6"
include nslu2-kernel.inc
# N2K_EXTRA_PATCHES - list of patches to apply (can include
@@ -21,4 +21,5 @@ N2K_PATCHES = "\
file://xscale-reset.patch;patch=1 \
file://x1205-rtc.c-id.patch;patch=1 \
file://mtd-shutdown.patch;patch=1 \
+ file://missing-exports.patch;patch=1 \
"
diff --git a/packages/linux/openslug-kernel-2.6.12.2/defconfig b/packages/linux/openslug-kernel-2.6.12.2/defconfig
index ba3744e2f5..fef846fe33 100644
--- a/packages/linux/openslug-kernel-2.6.12.2/defconfig
+++ b/packages/linux/openslug-kernel-2.6.12.2/defconfig
@@ -626,7 +626,7 @@ CONFIG_INPUT=m
CONFIG_INPUT_MOUSEDEV=n
# CONFIG_INPUT_JOYDEV is not set
# CONFIG_INPUT_TSDEV is not set
-# CONFIG_INPUT_EVDEV is not set
+CONFIG_INPUT_EVDEV=m
# CONFIG_INPUT_EVBUG is not set
#
@@ -929,7 +929,7 @@ CONFIG_USB_HIDDEV=y
#
# USB HID Boot Protocol drivers
#
-# CONFIG_USB_KBD is not set
+CONFIG_USB_KBD=m
# CONFIG_USB_MOUSE is not set
# CONFIG_USB_AIPTEK is not set
# CONFIG_USB_WACOM is not set