summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-12-17 01:36:21 +0000
committerRichard Purdie <rpurdie@rpsys.net>2006-12-17 01:36:21 +0000
commit1f5d884f31b9d70f5a8fa3f5610bb20e950968c3 (patch)
treec40939a392e6e6d4f3f5fb6792361225f8d7e635 /packages/linux
parent6d6054a22c1874c1030dff471d4c0740bc3a618b (diff)
linux-rp-2.6.19+git: Fix two compile failures
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-rp-2.6.19+git/squashfs3.0-2.6.15.patch2
-rw-r--r--packages/linux/linux-rp_2.6.19+git.bb4
2 files changed, 3 insertions, 3 deletions
diff --git a/packages/linux/linux-rp-2.6.19+git/squashfs3.0-2.6.15.patch b/packages/linux/linux-rp-2.6.19+git/squashfs3.0-2.6.15.patch
index 097659abad..405d4ec124 100644
--- a/packages/linux/linux-rp-2.6.19+git/squashfs3.0-2.6.15.patch
+++ b/packages/linux/linux-rp-2.6.19+git/squashfs3.0-2.6.15.patch
@@ -2182,7 +2182,7 @@ Index: git/fs/squashfs/inode.c
+static struct inode *squashfs_alloc_inode(struct super_block *sb)
+{
+ struct squashfs_inode_info *ei;
-+ ei = kmem_cache_alloc(squashfs_inode_cachep, SLAB_KERNEL);
++ ei = kmem_cache_alloc(squashfs_inode_cachep, GFP_KERNEL);
+ if (!ei)
+ return NULL;
+ return &ei->vfs_inode;
diff --git a/packages/linux/linux-rp_2.6.19+git.bb b/packages/linux/linux-rp_2.6.19+git.bb
index 5dfe715872..f5af2ae05e 100644
--- a/packages/linux/linux-rp_2.6.19+git.bb
+++ b/packages/linux/linux-rp_2.6.19+git.bb
@@ -1,6 +1,6 @@
require linux-rp.inc
-PR = "r0"
+PR = "r1"
DEFAULT_PREFERENCE = "-1"
@@ -29,7 +29,7 @@ SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;
${RPSRC}/sharpsl_pm_fixes1-r0.patch;patch=1 \
${RPSRC}/pm_changes-r1.patch;patch=1 \
${RPSRC}/usb_add_epalloc-r3.patch;patch=1 \
- ${RPSRC}/usb_pxa27x_udc-r2.patch;patch=1 \
+ ${RPSRC}/usb_pxa27x_udc-r3.patch;patch=1 \
${DOSRC}/kexec-arm-r3.patch;patch=1 \
${RPSRC}/locomo_kbd_tweak-r1.patch;patch=1 \
${RPSRC}/poodle_pm-r3.patch;patch=1 \