summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-01-19 09:13:56 +0100
committerKoen Kooi <koen@openembedded.org>2009-01-19 09:13:56 +0100
commit16ca87a9538cded1482898738ad7035101ca2cda (patch)
treee94420e37fb400bdd7fda1b26e106655bf8f0f2c /packages/linux
parent1fbae05c3880ddf8b2b1e08142accc2d47ee5340 (diff)
linux-omap git: update to 2.6.29rc2
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-omap/dvb-fix-dma.diff60
-rw-r--r--packages/linux/linux-omap/tick-schedc-suppress-needless-timer-reprogramming.patch81
-rw-r--r--packages/linux/linux-omap/twl-asoc-fix-record.diff34
-rw-r--r--packages/linux/linux-omap_git.bb9
4 files changed, 3 insertions, 181 deletions
diff --git a/packages/linux/linux-omap/dvb-fix-dma.diff b/packages/linux/linux-omap/dvb-fix-dma.diff
deleted file mode 100644
index e05473fc7f..0000000000
--- a/packages/linux/linux-omap/dvb-fix-dma.diff
+++ /dev/null
@@ -1,60 +0,0 @@
-Hi,
-I post this patch that fixes a kernel crash that happens when using a dvb
-usb stick on a mips platform and I think even on other platforms on which
-the dma access in not cache-coherent.
-
-The problem's origin is that, inside the method usb_bulk_urb_init of file
-drivers/media/dvb/dvb-usb/usb-urb.c, stream->urb_list[i]->transfer_buffer
-points to a memory area that has been allocated to be dma-coherent but
-stream->urb_list[i]->transfer_flags doesn't include the
-URB_NO_TRANSFER_DMA_MAP flag and stream->urb_list[i]->transfer_dma is not
-set.
-When later on the stream->urb_list[i]->transfer_buffer pointer is used
-inside function usb_hcd_submit_urb of file drivers/usb/core/hcd.c since the
-flag URB_NO_TRANSFER_DMA_MAP is not set the urb->transfer_buffer pointer is
-passed to the dma_map_single function that since the address is dma-coherent
-returns a wrong tranfer_dma address that later on leads to the kernel crash.
-
-The problem is solved by setting the URB_NO_TRANSFER_DMA_MAP flag and the
-stream->urb_list[i]->transfer_dma address.
-
-Perhaps to be more safe the URB_NO_TRANSFER_DMA_MAP flag can be set only
-if stream->urb_list[i]->transfer_dma != 0.
-
-I don't know if half of the fault can be of the dma_map_single function that
-should anyway returns a valid address both for a not dma-coherent and a
-dma-coherent address.
-
-Just to be clear:
-I've done this patch to solve my problem and I tested it only on a mips
-platform
-but I think it should not cause any problems on other platforms.
-I posted it here to help someone else that can have my same problem and to
-point it out
-to the mantainer of this part of code.
-You can use it at your own risk and I'm not resposible in any way for any
-problem or
-damage that it can cause.
-I'm available to discuss about it
-
-Bye
-
-Michele Scorcia
-
---------------------
-
-
-
-
---- /tmp/usb-urb.c 2008-10-08 09:53:23.000000000 +0200
-+++ git/drivers/media/dvb/dvb-usb/usb-urb.c 2008-10-08 09:54:16.000000000 +0200
-@@ -152,7 +152,8 @@
- stream->props.u.bulk.buffersize,
- usb_urb_complete, stream);
-
-- stream->urb_list[i]->transfer_flags = 0;
-+ stream->urb_list[i]->transfer_flags = URB_NO_TRANSFER_DMA_MAP;
-+ stream->urb_list[i]->transfer_dma = stream->dma_addr[i];
- stream->urbs_initialized++;
- }
- return 0;
diff --git a/packages/linux/linux-omap/tick-schedc-suppress-needless-timer-reprogramming.patch b/packages/linux/linux-omap/tick-schedc-suppress-needless-timer-reprogramming.patch
deleted file mode 100644
index c5cf4ef6ef..0000000000
--- a/packages/linux/linux-omap/tick-schedc-suppress-needless-timer-reprogramming.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-From: "Woodruff, Richard" <r-woodruff2@ti.com>
-
-In my device I get many interrupts from a high speed USB device in a very
-short period of time. The system spends a lot of time reprogramming the
-hardware timer which is in a slower timing domain as compared to the CPU.
-This results in the CPU spending a huge amount of time waiting for the
-timer posting to be done. All of this reprogramming is useless as the
-wake up time has not changed.
-
-As measured using ETM trace this drops my reprogramming penalty from
-almost 60% CPU load down to 15% during high interrupt rate. I can send
-traces to show this.
-
-
-Suppress setting of duplicate timer event when timer already stopped.
-Timer programming can be very costly and can result in long cpu stall/wait
-times.
-
-[akpm@linux-foundation.org: coding-style fixes]
-Signed-off-by: Richard Woodruff <r-woodruff2@ti.com>
-Cc: Thomas Gleixner <tglx@linutronix.de>
-
-On Wed, 24 Sep 2008 18:31:29 +0200 (CEST) Thomas Gleixner <tglx@linutronix.de> wrote:
-
-> No, we only fall trrough into raise_softirq() when the reprogram code
-> detects that the event already expired. So you change the flow :)
->
-> It does also not deal with delta_jiffies >= NEXT_TIMER_MAX_DELTA :(
->
-> I have a closer look on that.
-
-Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
----
-
- kernel/time/tick-sched.c | 19 +++++++++++++------
- 1 file changed, 13 insertions(+), 6 deletions(-)
-
-diff -puN kernel/time/tick-sched.c~tick-schedc-suppress-needless-timer-reprogramming kernel/time/tick-sched.c
---- a/kernel/time/tick-sched.c~tick-schedc-suppress-needless-timer-reprogramming
-+++ a/kernel/time/tick-sched.c
-@@ -282,6 +282,17 @@ void tick_nohz_stop_sched_tick(int inidl
- /* Schedule the tick, if we are at least one jiffie off */
- if ((long)delta_jiffies >= 1) {
-
-+ /*
-+ * calculate the expiry time for the next timer wheel
-+ * timer
-+ */
-+ expires = ktime_add_ns(last_update, tick_period.tv64 *
-+ delta_jiffies);
-+
-+ /* Skip reprogram of event if its not changed */
-+ if (ts->tick_stopped && ktime_equal(expires, dev->next_event))
-+ goto out2;
-+
- if (delta_jiffies > 1)
- cpu_set(cpu, nohz_cpu_mask);
- /*
-@@ -332,12 +343,7 @@ void tick_nohz_stop_sched_tick(int inidl
- goto out;
- }
-
-- /*
-- * calculate the expiry time for the next timer wheel
-- * timer
-- */
-- expires = ktime_add_ns(last_update, tick_period.tv64 *
-- delta_jiffies);
-+ /* Mark expiries */
- ts->idle_expires = expires;
-
- if (ts->nohz_mode == NOHZ_MODE_HIGHRES) {
-@@ -356,6 +362,7 @@ void tick_nohz_stop_sched_tick(int inidl
- tick_do_update_jiffies64(ktime_get());
- cpu_clear(cpu, nohz_cpu_mask);
- }
-+out2:
- raise_softirq_irqoff(TIMER_SOFTIRQ);
- out:
- ts->next_jiffies = next_jiffies;
-_
diff --git a/packages/linux/linux-omap/twl-asoc-fix-record.diff b/packages/linux/linux-omap/twl-asoc-fix-record.diff
deleted file mode 100644
index 9c0ceaa2e0..0000000000
--- a/packages/linux/linux-omap/twl-asoc-fix-record.diff
+++ /dev/null
@@ -1,34 +0,0 @@
-From linux-omap-owner@vger.kernel.org Sat Dec 06 02:14:21 2008
-Date: Fri, 5 Dec 2008 16:46:34 -0800
-From: "Steve Sakoman" <sakoman@gmail.com>
-To: "linux-omap@vger.kernel.org" <linux-omap@vger.kernel.org>
-Subject: [FYI PATCH] ASOC:TWL4030 Audio capture fix
-
-A couple of folks have noticed an issue with audio capture -- the
-capture result is always silence.
-
-The patch below is a quick fix for those with this issue. There are
-substantial changes to the codec driver that will be trickling down
-from ASoC, and they deal with this issue differently.
-
-So consider this as a bandaid for those who don't want to wait for the
-trickle down :-)
-
-Steve
-
-
-diff --git a/sound/soc/codecs/twl4030.c b/sound/soc/codecs/twl4030.c
-index ee2f0d3..8b4aafb 100644
---- a/sound/soc/codecs/twl4030.c
-+++ b/sound/soc/codecs/twl4030.c
-@@ -45,8 +45,8 @@ static const u8 twl4030_reg[TWL4030_CACHEREGNUM] = {
- 0xc3, /* REG_OPTION (0x2) */
- 0x00, /* REG_UNKNOWN (0x3) */
- 0x00, /* REG_MICBIAS_CTL (0x4) */
-- 0x24, /* REG_ANAMICL (0x5) */
-- 0x04, /* REG_ANAMICR (0x6) */
-+ 0x34, /* REG_ANAMICL (0x5) */
-+ 0x14, /* REG_ANAMICR (0x6) */
- 0x0a, /* REG_AVADC_CTL (0x7) */
- 0x00, /* REG_ADCMICSEL (0x8) */
- 0x00, /* REG_DIGMIXING (0x9) */
diff --git a/packages/linux/linux-omap_git.bb b/packages/linux/linux-omap_git.bb
index 24613c8b39..9abe76dd8d 100644
--- a/packages/linux/linux-omap_git.bb
+++ b/packages/linux/linux-omap_git.bb
@@ -10,10 +10,10 @@ DEFAULT_PREFERENCE_omap3evm = "1"
DEFAULT_PREFERENCE_omap3-pandora = "1"
-SRCREV = "15f75b6226c2d3b82062bb721e7cb9a1d6f35efd"
+SRCREV = "45e5c5ffd32ade5a21a5e87b4040072590ec3ae1"
#PV = "2.6.27+2.6.28-rc8+${PR}+gitr${SRCREV}"
-PV = "2.6.28+${PR}+gitr${SRCREV}"
+PV = "2.6.28+2.6.29-rc2${PR}+gitr${SRCREV}"
PR = "r9"
SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git;protocol=git \
@@ -30,11 +30,8 @@ SRC_URI_append = " \
file://mru-improve-pixclock-config.diff;patch=1 \
file://mru-make-video-timings-selectable.diff;patch=1 \
file://mru-enable-overlay-optimalization.diff;patch=1 \
- file://dvb-fix-dma.diff;patch=1 \
file://0001-Removed-resolution-check-that-prevents-scaling-when.patch;patch=1 \
file://0001-Implement-downsampling-with-debugs.patch;patch=1 \
- file://twl-asoc-fix-record.diff;patch=1 \
- file://tick-schedc-suppress-needless-timer-reprogramming.patch;patch=1 \
file://0001-DSS-New-display-subsystem-driver-for-OMAP2-3.patch;patch=1 \
file://0002-DSS-OMAPFB-fb-driver-for-new-display-subsystem.patch;patch=1 \
file://0003-DSS-Add-generic-DVI-panel.patch;patch=1 \
@@ -49,7 +46,7 @@ SRC_URI_append = " \
file://0012-DSS-Add-comments-to-FAKE_VSYNC-to-make-things-more.patch;patch=1 \
file://0013-DSS-OMAPFB-remove-extra-spaces.patch;patch=1 \
file://0014-DSS-fix-clk_get_usecount.patch;patch=1 \
- file://0001-ASoC-Add-support-for-OMAP3-EVM.patch;patch=1 \
+# file://0001-ASoC-Add-support-for-OMAP3-EVM.patch;patch=1 \
file://0001-This-merges-Steve-Kipisz-USB-EHCI-support.-He-star.patch;patch=1 \
"