summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2006-01-04 11:51:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-04 11:51:37 +0000
commit13505c0756b7eca3af798862c7bf666dae3ec29e (patch)
tree4e8bf4dccb23c55bf66f56e8d11e41a3272ecf9c /packages/linux
parentccdbeb03c5e95d3ff0d054eb0b48ab84559e8dff (diff)
unslung-kernel: Added cp437 back into the kernel instead of being a module, Added flash-is-now-hdd patch, Removed the 1gblimit and ext3flash-on-disk1 patches to prepare for future handling of flash disks on Unslung 6.x (to co-exist better with multiple NTFS drive support), Changed rc.unslung to rc.optware, Removed some of the Samba codepages to make space in the flash, Replaced stand-alone wget with busybox applet to save JFFS2 space, Updated linuxrc to only accept rootfs if .sdXroot is present, and added the leading candidate logo.
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/unslung-kernel/defconfig4
-rw-r--r--packages/linux/unslung-kernel/flash-is-now-hdd.patch57
-rw-r--r--packages/linux/unslung-kernel/linux-kernel-R29_to_R63.patch50
-rw-r--r--packages/linux/unslung-kernel_2.4.22.l2.3r63.bb12
4 files changed, 112 insertions, 11 deletions
diff --git a/packages/linux/unslung-kernel/defconfig b/packages/linux/unslung-kernel/defconfig
index 110728b68e..f5d965379a 100644
--- a/packages/linux/unslung-kernel/defconfig
+++ b/packages/linux/unslung-kernel/defconfig
@@ -660,7 +660,7 @@ CONFIG_SR_EXTRA_DEVS=2
# Some SCSI devices (e.g. CD jukebox) support multiple LUNs
#
# CONFIG_SCSI_DEBUG_QUEUES is not set
-# CONFIG_SCSI_MULTI_LUN is not set
+CONFIG_SCSI_MULTI_LUN=y
# CONFIG_SCSI_CONSTANTS is not set
# CONFIG_SCSI_LOGGING is not set
@@ -982,7 +982,7 @@ CONFIG_NLS=y
# Native Language Support
#
CONFIG_NLS_DEFAULT="iso8859-1"
-CONFIG_NLS_CODEPAGE_437=m
+CONFIG_NLS_CODEPAGE_437=y
CONFIG_NLS_CODEPAGE_737=m
# CONFIG_NLS_CODEPAGE_775 is not set
CONFIG_NLS_CODEPAGE_850=m
diff --git a/packages/linux/unslung-kernel/flash-is-now-hdd.patch b/packages/linux/unslung-kernel/flash-is-now-hdd.patch
new file mode 100644
index 0000000000..cf7352672f
--- /dev/null
+++ b/packages/linux/unslung-kernel/flash-is-now-hdd.patch
@@ -0,0 +1,57 @@
+--- linux-2.4.22/drivers/scsi/sd.c~ 2005-12-13 06:04:08.000000000 +1030
++++ linux-2.4.22/drivers/scsi/sd.c 2005-12-13 10:08:13.912932696 +1030
+@@ -1087,6 +1087,7 @@
+ rscsi_disks[i].capacity >>= 1;
+ }
+ // add by super, moified by pete
++#if 0
+ if (rscsi_disks[i].device->removable){
+ if(0x32 == rscsi_disks[i].device->host->hostt->port){
+ printk("is removable disk \n");
+@@ -1113,6 +1114,7 @@
+ );
+ }
+ }else {
++#endif
+ printk("%x port connect!!!!!\n",rscsi_disks[i].device->host->hostt->port);
+ if(0x32 == rscsi_disks[i].device->host->hostt->port){
+ *IXP425_GPIO_GPOUTR &= 0xfffb;
+@@ -1133,7 +1135,9 @@
+ NULL
+ );
+ }
++#if 0
+ }
++#endif
+ //end
+
+
+@@ -1682,22 +1686,28 @@
+ port2_attached = 0;
+ if(port2_attached == 0)
+ *IXP425_GPIO_GPOUTR |= 0x8;
++#if 0
+ if(SDp->removable == 1){
+ sprintf(flash, "flash_sd%c", 'a' + i);
+ remove_proc_entry(flash, NULL);
+ remove_proc_entry(media, NULL);
+ }else{
++#endif
+ sprintf(hdd, "hdd_sd%c", 'a' + i);
+ remove_proc_entry(hdd,NULL);
+ remove_proc_entry(media, NULL);
++#if 0
+ }
++#endif
+ break;
+ case 0x32:
+ *IXP425_GPIO_GPOUTR |= 0x4;
++#if 0
+ if(SDp->removable == 1){
+ remove_proc_entry("flash_sda",NULL);
+ }
+ else
++#endif
+ remove_proc_entry("hdd_sda",NULL);
+ break;
+ default:
diff --git a/packages/linux/unslung-kernel/linux-kernel-R29_to_R63.patch b/packages/linux/unslung-kernel/linux-kernel-R29_to_R63.patch
index f676df36ad..6882b335f3 100644
--- a/packages/linux/unslung-kernel/linux-kernel-R29_to_R63.patch
+++ b/packages/linux/unslung-kernel/linux-kernel-R29_to_R63.patch
@@ -793,7 +793,7 @@
if (ss != NULL) {
/* Existing device -- re-connect */
US_DEBUGP("Found existing GUID " GUID_FORMAT "\n",
-@@ -747,95 +735,6 @@
+@@ -747,93 +735,6 @@
USB_ENDPOINT_NUMBER_MASK;
ss->ep_int = ep_int;
@@ -837,7 +837,6 @@
- ss->htmplt.removable = 1;
- }
-#endif
--#if 0
- /* restrict device on certain port */
- if ( ss->htmplt.removable && (USB_DEVPATH_1 == dev->devpath[0]))
- if ( ss->htmplt.removable ^ (USB_DEVPATH_2 == dev->devpath[0]) )
@@ -854,8 +853,7 @@
- free_us_data( pre_ss, ss );
- return NULL;
- }
--#endif
-- if (ss->htmplt.removable && (USB_DEVPATH_2 == dev->devpath[0])){
+- if (ss->htmplt.removable){
- printk("is removable disk \n");
- *IXP425_GPIO_GPOUTR &= 0xfffb;
- create_proc_read_entry("usb_conn",
@@ -6397,3 +6395,47 @@
struct inode *i_fat_inode; /* struct inode of this one */
struct list_head i_fat_hash; /* hash by i_location */
};
+--- R29/drivers/scsi/scsi_scan.c 2005-12-13 02:15:15.000000000 +1030
++++ R63/drivers/scsi/scsi_scan.c 2005-05-31 15:03:23.000000000 +0930
+@@ -703,7 +703,7 @@
+ printk("*** %d\n", SDpnt->host->hostt->port);
+ /* restrict device on certain port grant */
+ SDpnt->host->hostt->removable = SDpnt->removable;
+-
++#if 0
+ if ( SDpnt->removable && (USB_DEVPATH_1 == SDpnt->host->hostt->port) )
+ {
+ create_proc_read_entry("usb_err",
+@@ -718,8 +718,9 @@
+ shpnt->porttype = 1;
+ return 0;
+ }
++#endif
+ // add by super
+- if (SDpnt->removable){
++ /*if (SDpnt->removable){
+ printk("is removable disk \n");
+ *IXP425_GPIO_GPOUTR &= 0xfffb;
+ create_proc_read_entry("usb_conn",
+@@ -747,7 +748,7 @@
+ NULL
+ );
+ }
+- }
++ }*/
+ //end
+ /*
+ * Check the peripheral qualifier field - this tells us whether LUNS
+--- R29/drivers/scsi/sd.c 2005-12-13 02:15:53.000000000 +1030
++++ R63/drivers/scsi/sd.c 2005-07-02 16:31:14.000000000 +0930
+@@ -1393,7 +1393,9 @@
+ * commands if they know what they're doing and they ask for it
+ * explicitly via the SHpnt->max_sectors API.
+ */
+- sd_max_sectors[i] = MAX_SEGMENTS*8;
++ //super
++ sd_max_sectors[i] = 8*8;
++ // sd_max_sectors[i] = MAX_SEGMENTS*8;
+ }
+
+ for (i = 0; i < N_USED_SD_MAJORS; i++) {
diff --git a/packages/linux/unslung-kernel_2.4.22.l2.3r63.bb b/packages/linux/unslung-kernel_2.4.22.l2.3r63.bb
index 8752a6ed04..5b35574a9e 100644
--- a/packages/linux/unslung-kernel_2.4.22.l2.3r63.bb
+++ b/packages/linux/unslung-kernel_2.4.22.l2.3r63.bb
@@ -4,7 +4,7 @@ include nslu2-linksys-kernel_2.4.22.bb
DESCRIPTION = "Unslung kernel for the Linksys NSLU2 device"
MAINTAINER = "NSLU2 Linux <www.nlsu2-linux.org>"
-PR = "r4"
+PR = "r7"
KERNEL_SUFFIX = "unslung"
@@ -12,17 +12,19 @@ CMDLINE_ROOT = "root=/dev/mtdblock4 rootfstype=jffs2 rw init=/linuxrc mem=32M@0x
UNSLUNG_KERNEL_EXTRA_SRC_URI ?=
-SRC_URI += "file://limit1gb.patch;patch=1 \
+# file://limit1gb.patch;patch=1 \
+# file://ext3flash-on-disk1.patch;patch=1 \
+
+SRC_URI += "file://linux-kernel-R25_to_R29.patch;patch=1 \
+ file://linux-kernel-R29_to_R63.patch;patch=1 \
+ file://flash-is-now-hdd.patch;patch=1 \
file://gl811e.patch;patch=1 \
- file://ext3flash-on-disk1.patch;patch=1 \
file://usbnet.patch;patch=1 \
file://missing-usb-ioctls.patch;patch=1 \
file://anonymiser.patch;patch=1 \
file://ppp_mppe.patch;patch=1 \
file://nfs-blocksize.patch;patch=1 \
file://pl2303.patch;patch=1 \
- file://linux-kernel-R25_to_R29.patch;patch=1 \
- file://linux-kernel-R29_to_R63.patch;patch=1 \
${UNSLUNG_KERNEL_EXTRA_SRC_URI}"
FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/unslung-kernel', '${FILE_DIRNAME}/nslu2-linksys-kernel-2.4.22', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"