summaryrefslogtreecommitdiff
path: root/packages/linux/unslung-kernel_2.4.22.l2.3r29.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-07-01 20:41:54 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-01 20:41:54 +0000
commit111f86089107b5ad0964e4c83f5560ed088addef (patch)
treef85658a8adb28b0a2d8b1ccb9349286956b49d51 /packages/linux/unslung-kernel_2.4.22.l2.3r29.bb
parent63f04a6a3c2ad5a5503787afcbfbfa80136767f2 (diff)
Fix unslung image build by putting the kernel version number
into the package (.bb) PV value
Diffstat (limited to 'packages/linux/unslung-kernel_2.4.22.l2.3r29.bb')
-rw-r--r--packages/linux/unslung-kernel_2.4.22.l2.3r29.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/linux/unslung-kernel_2.4.22.l2.3r29.bb b/packages/linux/unslung-kernel_2.4.22.l2.3r29.bb
new file mode 100644
index 0000000000..604dbd21ba
--- /dev/null
+++ b/packages/linux/unslung-kernel_2.4.22.l2.3r29.bb
@@ -0,0 +1,35 @@
+SECTION = "kernel"
+
+include nslu2-linksys-kernel_2.4.22.bb
+
+DESCRIPTION = "Unslung kernel for the Linksys NSLU2 device"
+MAINTAINER = "NSLU2 Linux <www.nlsu2-linux.org>"
+PR = "r2"
+
+KERNEL_SUFFIX = "unslung"
+
+CMDLINE_ROOT = "root=/dev/mtdblock4 rootfstype=jffs2 rw init=/linuxrc mem=32M@0x00000000"
+
+UNSLUNG_KERNEL_EXTRA_SRC_URI ?=
+
+SRC_URI += "file://limit1gb.patch;patch=1 \
+ file://gl811e.patch;patch=1 \
+ file://ext3flash-on-disk1.patch;patch=1 \
+ file://usbnet.patch;patch=1 \
+ file://missing-usb-ioctls.patch;patch=1 \
+ file://anonymiser.patch;patch=1 \
+ file://ppp_mppe.patch;patch=1 \
+ file://nfs-blocksize.patch;patch=1 \
+ file://pl2303.patch;patch=1 \
+ file://linux-kernel-R25_to_R29.patch;patch=1 \
+ ${UNSLUNG_KERNEL_EXTRA_SRC_URI}"
+
+FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/unslung-kernel', '${FILE_DIRNAME}/nslu2-linksys-kernel-2.4.22', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
+
+python () {
+ # Don't build unslung kernel unless we're targeting an nslu2
+ mach = bb.data.getVar("MACHINE", d, 1)
+ dist = bb.data.getVar("DISTRO", d, 1)
+ if mach != 'nslu2' or dist != 'unslung':
+ raise bb.parse.SkipPackage("Unslung only builds for the Linksys NSLU2")
+}