summaryrefslogtreecommitdiff
path: root/packages/linux/opensimpad_2.4.25-vrs2-pxa1-jpm1.bb
diff options
context:
space:
mode:
authorFrederic Bompart <frederic@unknown.openembedded.org>2005-11-11 14:51:32 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-11 14:51:32 +0000
commit5fb88e711e1f6614c358d6a331e81881ba11d1bc (patch)
treea5be76558dfac886e2ddfc1b505e3c4c77b2f172 /packages/linux/opensimpad_2.4.25-vrs2-pxa1-jpm1.bb
parentddfdc42ce0e9c07226c1a6390b03e5df4e731902 (diff)
opensimpad: MMC support + better support for SinusPad and 128M SIMpad
- There's now a config options to build the kernel for 128Mb SIMpad (as there was one for the SinusPad) - The .bb files automatically turn on these options depending on the total memory available. - The MMC driver was made by Clement Ballabriga <clement@asso.ups-tlse.fr> and Guylhem Aznar <simpad@externe.net>. Adding an MMC card (internal or external) to the SIMpad is described on these pages: http://externe.net/zaurus/simpad-bluetooth/ http://www.iral.com/~albertr/linux/simpad/mmc/
Diffstat (limited to 'packages/linux/opensimpad_2.4.25-vrs2-pxa1-jpm1.bb')
-rw-r--r--packages/linux/opensimpad_2.4.25-vrs2-pxa1-jpm1.bb20
1 files changed, 17 insertions, 3 deletions
diff --git a/packages/linux/opensimpad_2.4.25-vrs2-pxa1-jpm1.bb b/packages/linux/opensimpad_2.4.25-vrs2-pxa1-jpm1.bb
index a707910122..6970dd994b 100644
--- a/packages/linux/opensimpad_2.4.25-vrs2-pxa1-jpm1.bb
+++ b/packages/linux/opensimpad_2.4.25-vrs2-pxa1-jpm1.bb
@@ -1,12 +1,12 @@
DESCRIPTION = "Linux kernel for the SIEMENS SIMpad family of devices."
-MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+MAINTAINER = "Frederic Devernay <frederic.devernay@m4x.org>"
SECTION = "kernel"
LICENSE = "GPL"
KV = "${@bb.data.getVar('PV',d,True).split('-')[0]}"
VRSV = "${@bb.data.getVar('PV',d,True).split('-')[1]}"
PXAV = "${@bb.data.getVar('PV',d,True).split('-')[2]}"
JPMV = "${@bb.data.getVar('PV',d,True).split('-')[3]}"
-PR = "r19"
+PR = "r20"
FILESPATH = "${FILE_DIRNAME}/opensimpad-${PV}:${FILE_DIRNAME}/opensimpad:${FILE_DIRNAME}/files:${FILE_DIRNAME}"
@@ -26,7 +26,9 @@ SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.4/linux-${KV}.tar.bz2 \
file://simpad-apm.diff;patch=1;pnum=0 \
file://simpad-ts-noninput.patch;patch=1 \
file://simpad-pm-updates.patch;patch=1;pnum=0 \
- file://support-128mb-flash.patch;patch=1"
+ file://support-128mb-ram.patch;patch=1 \
+ file://mmc-spi.patch;patch=1 \
+"
# apply this when we have a patch that allows building with gcc 3.x:
# SRC_URI_append = file://gcc-3.3.patch;patch=1
@@ -65,6 +67,18 @@ do_configure() {
echo "CONFIG_MTDRAM_ERASE_SIZE=1" >> ${S}/.config
echo "CONFIG_MTDRAM_ABS_POS=$addr" >> ${S}/.config
fi
+ if [ "$total" == "128" ]
+ then
+ echo "CCONFIG_SA1100_SIMPAD_128M=y" >> ${S}/.config
+ else
+ echo "# CONFIG_SA1100_SIMPAD_128M is not set" >> ${S}/.config
+ fi
+ if [ "$total" == "32" ]
+ then
+ echo "CONFIG_SA1100_SIMPAD_SINUSPAD=y" >> ${S}/.config
+ else
+ echo "# CONFIG_SA1100_SIMPAD_SINUSPAD is not set" >> ${S}/.config
+ fi
echo "CONFIG_CMDLINE=\"${CMDLINE} mem=${mem}M\"" >> ${S}/.config
oe_runmake oldconfig
}