summaryrefslogtreecommitdiff
path: root/packages/linux/nslu2-kernel/2.6
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/linux/nslu2-kernel/2.6
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/linux/nslu2-kernel/2.6')
-rw-r--r--packages/linux/nslu2-kernel/2.6/.mtn2git_empty0
-rw-r--r--packages/linux/nslu2-kernel/2.6/compile-switches.patch58
-rw-r--r--packages/linux/nslu2-kernel/2.6/ixp4xx-regs.patch11
-rw-r--r--packages/linux/nslu2-kernel/2.6/x1205-rtc.patch38
4 files changed, 107 insertions, 0 deletions
diff --git a/packages/linux/nslu2-kernel/2.6/.mtn2git_empty b/packages/linux/nslu2-kernel/2.6/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/linux/nslu2-kernel/2.6/.mtn2git_empty
diff --git a/packages/linux/nslu2-kernel/2.6/compile-switches.patch b/packages/linux/nslu2-kernel/2.6/compile-switches.patch
index e69de29bb2..4b7a688313 100644
--- a/packages/linux/nslu2-kernel/2.6/compile-switches.patch
+++ b/packages/linux/nslu2-kernel/2.6/compile-switches.patch
@@ -0,0 +1,58 @@
+--- linux-2.6.11/arch/arm/Makefile.orig 2005-03-20 15:02:07.587138712 -0800
++++ linux-2.6.11/arch/arm/Makefile 2005-03-20 15:10:36.546765088 -0800
+@@ -33,6 +33,12 @@
+ AFLAGS += -mlittle-endian
+ endif
+
++ifeq ($(CONFIG_ARM_THUMB_INTERWORK),y)
++CFLAGS += -mthumb-interwork
++else
++CFLAGS += -mno-thumb-interwork
++endif
++
+ comma = ,
+
+ # This selects which instruction set is used.
+@@ -43,6 +49,8 @@
+ arch-$(CONFIG_CPU_32v5) :=-D__LINUX_ARM_ARCH__=5 $(call cc-option,-march=armv5te,-march=armv4)
+ arch-$(CONFIG_CPU_32v4) :=-D__LINUX_ARM_ARCH__=4 -march=armv4
+ arch-$(CONFIG_CPU_32v3) :=-D__LINUX_ARM_ARCH__=3 -march=armv3
++# The following overrides the CPU_32v5 setting if specified
++arch-$(CONFIG_ARCH_XSCALE) :=-D__LINUX_ARM_ARCH__=5 $(call cc-option,-march=xscale,-march=armv5te)
+
+ # This selects how we optimise for the processor.
+ tune-$(CONFIG_CPU_ARM610) :=-mtune=arm610
+--- linux-2.6.11/arch/arm/mm/Kconfig.orig 2005-03-20 14:54:07.927058128 -0800
++++ linux-2.6.11/arch/arm/mm/Kconfig 2005-03-20 15:01:26.727350344 -0800
+@@ -366,6 +366,31 @@
+
+ If you don't know what this all is, saying Y is a safe choice.
+
++config ARM_THUMB_INTERWORK
++ bool "Support Thumb code within the kernel"
++ depends on CPU_ARM720T || CPU_ARM920T || CPU_ARM922T || CPU_ARM925T || CPU_ARM926T || CPU_ARM1020 || CPU_ARM1020E || CPU_ARM1022 || CPU_ARM1026 || CPU_XSCALE || CPU_V6
++ default n
++ help
++ Say Y to compile the whole kernel with support for the interworking
++ of the 16 bit thumb instruction set and 32 bit ARM instruction set.
++
++ You only need this if some parts of the kernel will be compiled
++ as thumb code, this is not usual. It increases the total kernel
++ size by about 3%.
++
++config ARCH_XSCALE
++ bool "Use -march=xscale in preference to -march=armv5te"
++ depends on CPU_XSCALE
++ default y
++ help
++ Say yes to ask gcc to use the xscale architecture (instruction set)
++ in preference to armv5te. This allows gcc to use the extra xscale
++ instructions but means the code will not run on a standard (non-xscale)
++ armv5te. At present this makes no difference - gcc 3.4.3 does not
++ generate any xscale specific instructions - however gcc 3.4.3 does
++ generate slightly more optimal instructions if this is specified (this
++ is an error inside gcc 3.4.3 which should be fixed in 4.1.)
++
+ config CPU_BIG_ENDIAN
+ bool "Build big-endian kernel"
+ depends on ARCH_SUPPORTS_BIG_ENDIAN
diff --git a/packages/linux/nslu2-kernel/2.6/ixp4xx-regs.patch b/packages/linux/nslu2-kernel/2.6/ixp4xx-regs.patch
index e69de29bb2..32f7e3ccb8 100644
--- a/packages/linux/nslu2-kernel/2.6/ixp4xx-regs.patch
+++ b/packages/linux/nslu2-kernel/2.6/ixp4xx-regs.patch
@@ -0,0 +1,11 @@
+--- linux-2.6.11/.pc/2.6.patch/include/asm-arm/arch-ixp4xx/ixp4xx-regs.h 2005-03-01 23:37:49.000000000 -0800
++++ linux-2.6.11/include/asm-arm/arch-ixp4xx/ixp4xx-regs.h 2005-06-17 17:51:32.569981939 -0700
+@@ -52,7 +52,7 @@
+ * Expansion BUS Configuration registers
+ */
+ #define IXP4XX_EXP_CFG_BASE_PHYS (0xC4000000)
+-#define IXP4XX_EXP_CFG_BASE_VIRT (0xFFBFD000)
++#define IXP4XX_EXP_CFG_BASE_VIRT (0xFFBFE000)
+ #define IXP4XX_EXP_CFG_REGION_SIZE (0x00001000)
+
+ /*
diff --git a/packages/linux/nslu2-kernel/2.6/x1205-rtc.patch b/packages/linux/nslu2-kernel/2.6/x1205-rtc.patch
index e69de29bb2..913f44e2ae 100644
--- a/packages/linux/nslu2-kernel/2.6/x1205-rtc.patch
+++ b/packages/linux/nslu2-kernel/2.6/x1205-rtc.patch
@@ -0,0 +1,38 @@
+--- linux-2.6.11/.pc/2.6.patch/drivers/i2c/chips/Kconfig 2005-06-17 17:51:28.635578329 -0700
++++ linux-2.6.11/drivers/i2c/chips/Kconfig 2005-06-17 17:51:32.565982545 -0700
+@@ -430,6 +430,15 @@
+
+ This driver can also be built as a module. If so, the module
+ will be called isp1301_omap.
++config SENSORS_X1205
++ tristate "Xicor X1205 RTC chip"
++ depends on I2C && EXPERIMENTAL
++ select I2C_SENSOR
++ help
++ If you say yes here you get support for the Xicor x1205 RTC chip.
++
++ This driver can also be built as a module. If so, the module
++ will be called x1205-rtc
+
+ config SENSORS_M41T00
+ tristate "ST M41T00 RTC chip"
+--- linux-2.6.11/.pc/2.6.patch/drivers/i2c/chips/Makefile 2005-06-17 17:51:28.636578177 -0700
++++ linux-2.6.11/drivers/i2c/chips/Makefile 2005-06-17 17:51:32.566982394 -0700
+@@ -41,6 +41,7 @@
+ obj-$(CONFIG_SENSORS_VIA686A) += via686a.o
+ obj-$(CONFIG_SENSORS_W83L785TS) += w83l785ts.o
+ obj-$(CONFIG_ISP1301_OMAP) += isp1301_omap.o
++obj-$(CONFIG_SENSORS_X1205) += x1205-rtc.o
+
+ ifeq ($(CONFIG_I2C_DEBUG_CHIP),y)
+ EXTRA_CFLAGS += -DDEBUG
+--- linux-2.6.11/.pc/2.6.patch/include/linux/i2c-id.h 2005-06-17 17:51:31.358165630 -0700
++++ linux-2.6.11/include/linux/i2c-id.h 2005-06-17 17:51:32.569981939 -0700
+@@ -108,6 +108,7 @@
+ #define I2C_DRIVERID_TDA7313 62 /* TDA7313 audio processor */
+ #define I2C_DRIVERID_MAX6900 63 /* MAX6900 real-time clock */
+ #define I2C_DRIVERID_SAA7114H 64 /* video decoder */
++#define I2C_DRIVERID_X1205 0xF0
+
+
+ #define I2C_DRIVERID_EXP0 0xF0 /* experimental use id's */