summaryrefslogtreecommitdiff
path: root/packages/linux/nslu2-kernel/2.6.14
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-09-26 00:16:03 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-26 00:16:03 +0000
commita849644d197331926f945cb6c5f1d4f799476b3c (patch)
tree28d0cdd5e44ead1bdc7b00aa5466df4c9c99b6e5 /packages/linux/nslu2-kernel/2.6.14
parent59da362b2275316766121212e772d4b2a034d2ea (diff)
nslu2-kernel_2.6.14-rc2: remove nslu2-part.c from the kernel
Diffstat (limited to 'packages/linux/nslu2-kernel/2.6.14')
-rw-r--r--packages/linux/nslu2-kernel/2.6.14/50-nslu2-arch.patch14
-rw-r--r--packages/linux/nslu2-kernel/2.6.14/50-nslu2-general.patch126
2 files changed, 1 insertions, 139 deletions
diff --git a/packages/linux/nslu2-kernel/2.6.14/50-nslu2-arch.patch b/packages/linux/nslu2-kernel/2.6.14/50-nslu2-arch.patch
index 14c40ca955..de9499f1fc 100644
--- a/packages/linux/nslu2-kernel/2.6.14/50-nslu2-arch.patch
+++ b/packages/linux/nslu2-kernel/2.6.14/50-nslu2-arch.patch
@@ -34,20 +34,6 @@
#
# IXCDP1100 is the exact same HW as IXDP425, but with a different machine
---- linux-2.6.11/.pc/2.6.patch/drivers/mtd/maps/ixp4xx.c 2005-03-01 23:37:30.000000000 -0800
-+++ linux-2.6.11/drivers/mtd/maps/ixp4xx.c 2005-06-17 17:51:32.566982394 -0700
-@@ -94,7 +94,11 @@
- struct resource *res;
- };
-
-+#ifdef CONFIG_MACH_NSLU2
-+static const char *probes[] = { "cmdlinepart", "RedBoot", "NSLU2", NULL };
-+#else
- static const char *probes[] = { "RedBoot", "cmdlinepart", NULL };
-+#endif
-
- static int ixp4xx_flash_remove(struct device *_dev)
- {
--- linux-2.6.11/.pc/2.6.patch/include/asm-arm/arch-ixp4xx/hardware.h 2005-03-01 23:37:51.000000000 -0800
+++ linux-2.6.11/include/asm-arm/arch-ixp4xx/hardware.h 2005-06-17 17:51:32.567982242 -0700
@@ -44,5 +44,6 @@
diff --git a/packages/linux/nslu2-kernel/2.6.14/50-nslu2-general.patch b/packages/linux/nslu2-kernel/2.6.14/50-nslu2-general.patch
index 4f473e59f9..a4923de72d 100644
--- a/packages/linux/nslu2-kernel/2.6.14/50-nslu2-general.patch
+++ b/packages/linux/nslu2-kernel/2.6.14/50-nslu2-general.patch
@@ -5,7 +5,7 @@ diff -urN linux-2.6.14-rc2/arch/arm/mach-ixp4xx/Makefile test3/arch/arm/mach-ixp
obj-$(CONFIG_MACH_IXDPG425) += ixdpg425-pci.o coyote-setup.o
obj-$(CONFIG_ARCH_ADI_COYOTE) += coyote-pci.o coyote-setup.o
obj-$(CONFIG_MACH_GTWX5715) += gtwx5715-pci.o gtwx5715-setup.o
-+obj-$(CONFIG_MACH_NSLU2) += nslu2-pci.o nslu2-setup.o nslu2-part.o nslu2-io.o nslu2-rtc.o
++obj-$(CONFIG_MACH_NSLU2) += nslu2-pci.o nslu2-setup.o nslu2-io.o nslu2-rtc.o
diff -urN linux-2.6.14-rc2/arch/arm/mach-ixp4xx/nslu2-io.c test3/arch/arm/mach-ixp4xx/nslu2-io.c
--- linux-2.6.14-rc2/arch/arm/mach-ixp4xx/nslu2-io.c 1970-01-01 01:00:00.000000000 +0100
@@ -707,130 +707,6 @@ diff -urN linux-2.6.14-rc2/arch/arm/mach-ixp4xx/nslu2-io.c test3/arch/arm/mach-i
+module_param(debug, int, 0644);
+MODULE_PARM_DESC(debug, "Debugging enabled = 8");
+
-diff -urN linux-2.6.14-rc2/arch/arm/mach-ixp4xx/nslu2-part.c test3/arch/arm/mach-ixp4xx/nslu2-part.c
---- linux-2.6.14-rc2/arch/arm/mach-ixp4xx/nslu2-part.c 1970-01-01 01:00:00.000000000 +0100
-+++ test3/arch/arm/mach-ixp4xx/nslu2-part.c 2005-09-24 13:21:22.000000000 +0200
-@@ -0,0 +1,120 @@
-+/*
-+ * nslu2-part.c
-+ *
-+ * Maintainers: http://www.nslu2-linux.org/
-+ * Initial port: Mark Rakes <mrakes AT mac.com>
-+ *
-+ * "Parse" the fixed partition table of the Linksys NSLU2 and
-+ * produce a Linux partition array to match.
-+ */
-+
-+#include <linux/kernel.h>
-+#include <linux/slab.h>
-+#include <linux/init.h>
-+#include <linux/vmalloc.h>
-+#include <linux/mtd/mtd.h>
-+#include <linux/mtd/partitions.h>
-+
-+/* info we know about the NSLU2's flash setup:
-+ *
-+ * Num Partition offset size
-+ * --- --------- ---------- -----------
-+ * 0 RedBoot 0x00000000 0x00040000
-+ * 1 System Configuration 0x00040000 0x00020000
-+ * 2 Kernel 0x00060000 0x00100000
-+ * 3 Ramdisk 0x00160000 0x006a0000
-+ */
-+ #define NSLU2_NUM_FLASH_PARTITIONS 4
-+ #define NSLU2_FLASH_PART0_NAME "RedBoot"
-+ #define NSLU2_FLASH_PART0_OFFSET 0x00000000
-+ #define NSLU2_FLASH_PART0_SIZE 0x00040000
-+ #define NSLU2_FLASH_PART1_NAME "System Configuration"
-+ #define NSLU2_FLASH_PART1_OFFSET (NSLU2_FLASH_PART0_OFFSET + NSLU2_FLASH_PART0_SIZE)
-+ #define NSLU2_FLASH_PART1_SIZE 0x00020000
-+ #define NSLU2_FLASH_PART2_NAME "Kernel"
-+ #define NSLU2_FLASH_PART2_OFFSET (NSLU2_FLASH_PART1_OFFSET + NSLU2_FLASH_PART1_SIZE)
-+ #define NSLU2_FLASH_PART2_SIZE 0x00100000
-+ #define NSLU2_FLASH_PART3_NAME "Ramdisk"
-+ #define NSLU2_FLASH_PART3_OFFSET (NSLU2_FLASH_PART2_OFFSET + NSLU2_FLASH_PART2_SIZE)
-+ #define NSLU2_FLASH_PART3_SIZE 0x006a0000
-+
-+static int parse_nslu2_partitions(struct mtd_info *master,
-+ struct mtd_partition **pparts,
-+ unsigned long flash_start)
-+{
-+ struct mtd_partition *parts;
-+ int ret = 0, namelen = 0;
-+ char *names;
-+
-+ namelen = strlen(NSLU2_FLASH_PART0_NAME) +
-+ strlen(NSLU2_FLASH_PART1_NAME) +
-+ strlen(NSLU2_FLASH_PART2_NAME) +
-+ strlen(NSLU2_FLASH_PART3_NAME) +
-+ NSLU2_NUM_FLASH_PARTITIONS; /*4 strings + each terminator */
-+
-+ parts = kmalloc(sizeof(*parts)*NSLU2_NUM_FLASH_PARTITIONS + namelen, GFP_KERNEL);
-+ if (!parts) {
-+ ret = -ENOMEM;
-+ goto out;
-+ }
-+
-+ memset(parts, 0, sizeof(*parts)*NSLU2_NUM_FLASH_PARTITIONS + namelen);
-+ names = (char *)&parts[NSLU2_NUM_FLASH_PARTITIONS];
-+
-+ /* RedBoot partition */
-+ parts[0].size = NSLU2_FLASH_PART0_SIZE;
-+ parts[0].offset = NSLU2_FLASH_PART0_OFFSET;
-+ parts[0].name = NSLU2_FLASH_PART0_NAME;
-+ parts[0].mask_flags = MTD_WRITEABLE; /* readonly */
-+ strcpy(names, NSLU2_FLASH_PART0_NAME);
-+ names += strlen(names)+1;
-+ /* System Configuration */
-+ parts[1].size = NSLU2_FLASH_PART1_SIZE;
-+ parts[1].offset = NSLU2_FLASH_PART1_OFFSET;
-+ parts[1].name = NSLU2_FLASH_PART1_NAME;
-+ parts[1].mask_flags = MTD_WRITEABLE; /* readonly */
-+ strcpy(names, NSLU2_FLASH_PART1_NAME);
-+ names += strlen(names)+1;
-+ /* Kernel */
-+ parts[2].size = NSLU2_FLASH_PART2_SIZE;
-+ parts[2].offset = NSLU2_FLASH_PART2_OFFSET;
-+ parts[2].name = NSLU2_FLASH_PART2_NAME;
-+ parts[2].mask_flags = MTD_WRITEABLE; /* readonly */
-+ strcpy(names, NSLU2_FLASH_PART2_NAME);
-+ names += strlen(names)+1;
-+ /* Ramdisk */
-+ parts[3].size = NSLU2_FLASH_PART3_SIZE;
-+ parts[3].offset = NSLU2_FLASH_PART3_OFFSET;
-+ parts[3].name = NSLU2_FLASH_PART3_NAME;
-+ parts[3].mask_flags = MTD_WRITEABLE; /* readonly */
-+ strcpy(names, NSLU2_FLASH_PART3_NAME);
-+ names += strlen(names)+1;
-+
-+ ret = NSLU2_NUM_FLASH_PARTITIONS;
-+ *pparts = parts;
-+ out:
-+ return ret;
-+}
-+
-+static struct mtd_part_parser nslu2_parser = {
-+ .owner = THIS_MODULE,
-+ .parse_fn = parse_nslu2_partitions,
-+ .name = "NSLU2",
-+};
-+
-+static int __init nslu2_parser_init(void)
-+{
-+ return register_mtd_parser(&nslu2_parser);
-+}
-+
-+static void __exit nslu2_parser_exit(void)
-+{
-+ deregister_mtd_parser(&nslu2_parser);
-+}
-+
-+module_init(nslu2_parser_init);
-+module_exit(nslu2_parser_exit);
-+
-+MODULE_LICENSE("GPL");
-+MODULE_AUTHOR("Mark Rakes");
-+MODULE_DESCRIPTION("Parsing code for NSLU2 flash tables");
diff -urN linux-2.6.14-rc2/arch/arm/mach-ixp4xx/nslu2-pci.c test3/arch/arm/mach-ixp4xx/nslu2-pci.c
--- linux-2.6.14-rc2/arch/arm/mach-ixp4xx/nslu2-pci.c 1970-01-01 01:00:00.000000000 +0100
+++ test3/arch/arm/mach-ixp4xx/nslu2-pci.c 2005-09-24 15:19:54.000000000 +0200