summaryrefslogtreecommitdiff
path: root/packages/linux/nslu2-kernel.inc
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-09-23 22:41:56 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-23 22:41:56 +0000
commitdecd5713b87a01a4c5ee4400f8ac2031d4fdacd5 (patch)
tree0b5377e2ce2c0767caef5e1a00cdc0c44d745b78 /packages/linux/nslu2-kernel.inc
parent6b3470da8576dbd561bf89b21a650e46faf6bf9a (diff)
nslu2-kernel: initial .bb files for 2.6.13.2 and 2.6.14-rc2
Diffstat (limited to 'packages/linux/nslu2-kernel.inc')
-rw-r--r--packages/linux/nslu2-kernel.inc5
1 files changed, 3 insertions, 2 deletions
diff --git a/packages/linux/nslu2-kernel.inc b/packages/linux/nslu2-kernel.inc
index 8946822574..33867b0e34 100644
--- a/packages/linux/nslu2-kernel.inc
+++ b/packages/linux/nslu2-kernel.inc
@@ -213,10 +213,11 @@ ARCH = "arm"
KERNEL_IMAGETYPE = "zImage"
# To specify the console set KERNEL_CONSOLE in the .bb file.
# CMDLINE_ROOT contains the boot options
-CMDLINE_ROOT ?= "root=/dev/mtdblock4 rw rootfstype=jffs2 mem=32M@0x00000000 init=/linuxrc reboot=s"
+CMDLINE_REBOOT ?= "reboot=s"
+CMDLINE_ROOT ?= "root=/dev/mtdblock4 rw rootfstype=jffs2 mem=32M@0x00000000 init=/linuxrc"
# Add distro specific debug (or non-debug) options to this
CMDLINE_DEBUG ?= ""
-CMDLINE = "${CMDLINE_ROOT} ${CMDLINE_DEBUG} ${CMDLINE_CONSOLE}"
+CMDLINE = "${CMDLINE_ROOT} ${CMDLINE_REBOOT} ${CMDLINE_DEBUG} ${CMDLINE_CONSOLE}"
# Add the architecture compiler flags to KERNEL_CC and KERNEL_LD as
# required. Notice that this has to be done for each separately built