summaryrefslogtreecommitdiff
path: root/packages/linux/linux_2.6.23.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-12-23 10:50:30 +0000
committerKoen Kooi <koen@openembedded.org>2007-12-23 10:50:30 +0000
commite49ed8da00b7a5d874fd92a806c6b036a726069c (patch)
tree4c2986b1f377b0363e6637cc792e8e553c2b39a4 /packages/linux/linux_2.6.23.bb
parent95580064683ef83263017dce9b610c74306348bb (diff)
parenta5ab4c1e92a80b977b53072b349e05ab0f097dd1 (diff)
merge of '6765ce1f621a9ef917ba1521afc7b81013e14dc2'
and 'fcc520f13c2e5df6e6b7d52dcbfb32cb1750c941'
Diffstat (limited to 'packages/linux/linux_2.6.23.bb')
-rw-r--r--packages/linux/linux_2.6.23.bb19
1 files changed, 18 insertions, 1 deletions
diff --git a/packages/linux/linux_2.6.23.bb b/packages/linux/linux_2.6.23.bb
index 897694adca..0b276b4d63 100644
--- a/packages/linux/linux_2.6.23.bb
+++ b/packages/linux/linux_2.6.23.bb
@@ -7,7 +7,10 @@ DEFAULT_PREFERENCE_mpc8313e-rdb = "1"
DEFAULT_PREFERENCE_mpc8323e-rdb = "1"
DEFAULT_PREFERENCE_avr32 = "1"
-PR = "r6"
+DEPENDS_append_mpc8313e-rdb = " dtc-native"
+DEPENDS_append_mpc8323e-rdb = " dtc-native"
+
+PR = "r8"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.23.tar.bz2 \
file://binutils-buildid-arm.patch;patch=1 \
@@ -38,6 +41,9 @@ SRC_URI_append_mpc8323e-rdb = "\
CMDLINE_cm-x270 = "console=${CMX270_CONSOLE_SERIAL_PORT},38400 monitor=8 bpp=16 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),-(root);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init root=mtd3 rootfstype=jffs2"
+DEVICETREE_mpc8313e-rdb = "arch/${ARCH}/boot/dts/mpc8313erdb.dts"
+DEVICETREE_mpc8323e-rdb = "arch/${ARCH}/boot/dts/mpc832x_rdb.dts"
+
FILES_kernel-image_cm-x270 = ""
python do_compulab_image() {
@@ -75,4 +81,15 @@ python do_compulab_image() {
os.symlink(img_file, link_file)
}
+do_devicetree_image() {
+ if test -n "${DEVICETREE}" ; then
+ dtc -I dts -O dtb -o ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_BASE_NAME}.dtb ${DEVICETREE}
+
+ cd ${DEPLOY_DIR_IMAGE}
+ rm -f ${KERNEL_IMAGE_SYMLINK_NAME}.dtb
+ ln -sf ${KERNEL_IMAGE_BASE_NAME}.dtb ${KERNEL_IMAGE_SYMLINK_NAME}.dtb
+ fi
+}
+
addtask compulab_image after do_deploy before do_package
+addtask devicetree_image after do_deploy before do_package