summaryrefslogtreecommitdiff
path: root/packages/linux/linux_2.6.21.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-05-25 10:07:42 +0000
committerKoen Kooi <koen@openembedded.org>2007-05-25 10:07:42 +0000
commitb2d6791b01a83e10b736258faca11aafe48922ce (patch)
treef1ef6e81e34151c6f378268400212ad6a49b1793 /packages/linux/linux_2.6.21.bb
parent948cd33b724094d91b54ddb127323211cb9590f8 (diff)
linux 2.6.21: add EABI magic
Diffstat (limited to 'packages/linux/linux_2.6.21.bb')
-rw-r--r--packages/linux/linux_2.6.21.bb14
1 files changed, 13 insertions, 1 deletions
diff --git a/packages/linux/linux_2.6.21.bb b/packages/linux/linux_2.6.21.bb
index be3c57c350..f107dada3f 100644
--- a/packages/linux/linux_2.6.21.bb
+++ b/packages/linux/linux_2.6.21.bb
@@ -23,6 +23,18 @@ KERNEL_IMAGETYPE_simpad = "zImage"
KERNEL_IMAGETYPE_kb9202 = "zImage"
do_configure_prepend() {
- install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ if [ "${TARGET_OS}" == "linux-gnueabi" -o "${TARGET_OS}" == "linux-uclibcgnueabi" ]; then
+ echo "CONFIG_AEABI=y" >> ${S}/.config
+ echo "CONFIG_OABI_COMPAT=y" >> ${S}/.config
+ else
+ echo "# CONFIG_AEABI is not set" >> ${S}/.config
+ echo "# CONFIG_OABI_COMPAT is not set" >> ${S}/.config
+ fi
+
+ sed -e '/CONFIG_AEABI/d' \
+ -e '/CONFIG_OABI_COMPAT=/d' \
+ '${WORKDIR}/defconfig' >>'${S}/.config'
+
+ yes '' | oe_runmake oldconfig
}