summaryrefslogtreecommitdiff
path: root/packages/linux/linux_2.6.19-rc6.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-11-27 12:51:46 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-11-27 12:51:46 +0000
commitbc3a31ab59f86705e2d8a27ff87b786f5fb011f3 (patch)
tree6fa8bc48bd908b9986f57f642d190bec5ea4aecb /packages/linux/linux_2.6.19-rc6.bb
parent57df117212cda3ea64f33606a8c0cfb7a3d009b4 (diff)
linux: added 2.6.19-rc6 kernel without any patches
- this recipe can be used as base for those builds which do not need any patches other then mainline - supports only progear for now - adding new machines is easy - create linux/MACHINE/defconfig and build
Diffstat (limited to 'packages/linux/linux_2.6.19-rc6.bb')
-rw-r--r--packages/linux/linux_2.6.19-rc6.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/linux/linux_2.6.19-rc6.bb b/packages/linux/linux_2.6.19-rc6.bb
new file mode 100644
index 0000000000..56007c3222
--- /dev/null
+++ b/packages/linux/linux_2.6.19-rc6.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Linux Kernel"
+SECTION = "kernel"
+LICENSE = "GPL"
+PV = "2.6.18+2.6.19-rc6"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.18.tar.bz2 \
+ ftp://ftp.kernel.org/pub/linux/kernel/v2.6/testing/patch-2.6.19-rc1.bz2;patch=1 \
+ ftp://ftp.kernel.org/pub/linux/kernel/v2.6/testing/incr/patch-2.6.19-rc1-rc2.bz2;patch=1 \
+ ftp://ftp.kernel.org/pub/linux/kernel/v2.6/testing/incr/patch-2.6.19-rc2-rc3.bz2;patch=1 \
+ ftp://ftp.kernel.org/pub/linux/kernel/v2.6/testing/incr/patch-2.6.19-rc3-rc4.bz2;patch=1 \
+ ftp://ftp.kernel.org/pub/linux/kernel/v2.6/testing/incr/patch-2.6.19-rc4-rc5.bz2;patch=1 \
+ ftp://ftp.kernel.org/pub/linux/kernel/v2.6/testing/incr/patch-2.6.19-rc5-rc6.bz2;patch=1 \
+ file://defconfig"
+
+S = "${WORKDIR}/linux-2.6.18"
+
+inherit kernel
+
+KERNEL_IMAGETYPE = "bzImage"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+}
+
+KERNEL_RELEASE = "2.6.19-rc6"