summaryrefslogtreecommitdiff
path: root/packages/linux/linux_2.6.14.bb
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-03-07 02:46:35 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-03-07 02:46:35 +0000
commit95ab40dfc8bbb89f1579b5b5e2167459c97fcf8f (patch)
treef3219bf7f14af450187e1f4a07736110bf6acdad /packages/linux/linux_2.6.14.bb
parent9338aae8d11d18af9758e0d4d6a091cbe5026f6b (diff)
linux 2.6.14: Add kernel for acern30 (vanilla + patches).
* Based on the Letux distribution (www.letux.org, materials from http://www.openembedded.org/~koen/letux/), contributed by Dr. H. Nikolaus Schaller.
Diffstat (limited to 'packages/linux/linux_2.6.14.bb')
-rw-r--r--packages/linux/linux_2.6.14.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/packages/linux/linux_2.6.14.bb b/packages/linux/linux_2.6.14.bb
new file mode 100644
index 0000000000..3ddfec809a
--- /dev/null
+++ b/packages/linux/linux_2.6.14.bb
@@ -0,0 +1,51 @@
+DESCRIPTION = "Linux Kernel"
+SECTION = "kernel"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ file://defconfig"
+
+SRC_URI_append_progear = " \
+ file://progear_bl-r6.patch;patch=1 \
+ "
+SRC_URI_append_acern30 = "\
+ http://lechat.rtp-net.org/ipaq/patches/2.6.14-3/v2.6.14-gitcurrent.patch;patch=1 \
+ http://lechat.rtp-net.org/ipaq/patches/2.6.14-3/full.patch;patch=1 \
+ file://n30-cleanup.patch;patch=1 \
+ file://n35.patch;patch=1 \
+ file://n30-lcd.patch;patch=1 \
+ file://n30-backlight.patch;patch=1 \
+ file://n30-ts.patch;patch=1 \
+ file://n30-buttons.patch;patch=1 \
+ file://n30-mmc.patch;patch=1 \
+ file://n30-mmc-power.patch;patch=1 \
+ file://n30-mmc-wprotect.patch;patch=1 \
+ file://n30-nand.patch;patch=1 \
+ file://n30-usbstart.patch;patch=1 \
+ file://n30-hardcode.patch;patch=1 \
+ file://n30-apm.patch;patch=1 \
+ file://s3c2410fb-resume.patch;patch=1 \
+ file://s3c2410_ts-pm.patch;patch=1 \
+ file://s3c2410_lcd-pm.c;patch=1 \
+ file://s3c2410mci-pm.patch;patch=1 \
+ file://s3c2410-nand-pm.patch;patch=1 \
+ file://n30-nand-hack.patch;patch=1 \
+ file://mmc-plus.patch;patch=1 \
+ file://gpio-sysfs.patch;patch=1 \
+ file://regdump.patch;patch=1 \
+ file://n30-pm.patch;patch=1 \
+ file://spi.patch;patch=1 \
+ file://wingel-hacking.patch;patch=1 \
+ file://gcc4-fixes.patch;patch=1 \
+ "
+
+inherit kernel
+
+KERNEL_IMAGETYPE = "bzImage"
+KERNEL_IMAGETYPE_simpad = "zImage"
+KERNEL_IMAGETYPE_acern30 = "zImage"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+}