summaryrefslogtreecommitdiff
path: root/packages/linux/linux.inc
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-11-29 13:46:08 +0000
committerKoen Kooi <koen@openembedded.org>2007-11-29 13:46:08 +0000
commitfb66e592cba4e91fdb85570cfb51e4110ea75b28 (patch)
tree018f99af09b92a1ec7734192984798db855ccac7 /packages/linux/linux.inc
parent82ef14e73032b4364c7ef2b372f9868f5ceed793 (diff)
parent8c1a5e33bf439c0274b795cc580a30c5de951df7 (diff)
propagate from branch 'org.openembedded.dev' (head 0238eff8862126ac83c3f05d7a6fb094feff89e9)
to branch 'org.openembedded.dev.avr32' (head afeaa97ba6962d277699aab10b0b6a8089342824)
Diffstat (limited to 'packages/linux/linux.inc')
-rw-r--r--packages/linux/linux.inc9
1 files changed, 9 insertions, 0 deletions
diff --git a/packages/linux/linux.inc b/packages/linux/linux.inc
index 09cf05f7d4..eada45bac2 100644
--- a/packages/linux/linux.inc
+++ b/packages/linux/linux.inc
@@ -85,6 +85,11 @@ do_configure_prepend() {
yes '' | oe_runmake oldconfig
}
+
+do_configure_append_avr32() {
+ sed -i -e s:-mno-pic::g arch/avr32/Makefile
+}
+
# Support checking the kernel size since some kernels need to reside in partitions
# with a fixed length or there is a limit in transferring the kernel to memory
do_sizecheck() {
@@ -126,6 +131,10 @@ do_deploy() {
${OBJCOPY} -O binary -R .note -R .comment -S arch/${ARCH}/boot/compressed/vmlinux linux.bin
uboot-mkimage -A ${ARCH} -O linux -T kernel -C none -a ${UBOOT_ENTRYPOINT} -e ${UBOOT_ENTRYPOINT} -n "${DISTRO_NAME}/${PV}/${MACHINE}" -d linux.bin ${DEPLOY_DIR_IMAGE}/uImage-${PV}-${PR}-${MACHINE}-${DATETIME}.bin
rm -f linux.bin
+ elif test -e arch/${ARCH}/boot/images/vmlinux.gz ; then
+ ${OBJCOPY} -O binary -R .note -R .comment -S arch/${ARCH}/boot/images/vmlinux.gz linux.bin
+ uboot-mkimage -A ${ARCH} -O linux -T kernel -C gzip -a ${UBOOT_ENTRYPOINT} -e ${UBOOT_ENTRYPOINT} -n "${DISTRO_NAME}/${PV}/${MACHINE}" -d linux.bin ${DEPLOY_DIR_IMAGE}/uImage-${PV}-${PR}-${MACHINE}-${DATETIME}.bin
+ rm -f linux.bin
else
${OBJCOPY} -O binary -R .note -R .comment -S vmlinux linux.bin
rm -f linux.bin.gz