summaryrefslogtreecommitdiff
path: root/packages/linux/linux.inc
diff options
context:
space:
mode:
authorThomas Kunze <thommycheck@gmx.de>2009-03-06 00:22:58 +0100
committerThomas Kunze <thommycheck@gmx.de>2009-03-06 00:22:58 +0100
commit29839e2c84c15d64f0c422cf504da2ac2f943393 (patch)
treea0833c235b415c2565fe8d85328565532bd72fa0 /packages/linux/linux.inc
parent266a77ff6f44e6bcd63aa69a803bf0764113c549 (diff)
fix configuration of older kernels
Was broken from commit b697819f7e84e19ca2adc9846421c8c8137b8fca for kernels that have no scripts/Makefile.fwinst (<=2.6.26 or so)
Diffstat (limited to 'packages/linux/linux.inc')
-rw-r--r--packages/linux/linux.inc5
1 files changed, 3 insertions, 2 deletions
diff --git a/packages/linux/linux.inc b/packages/linux/linux.inc
index 5e714e1b7e..f3d3bf8baa 100644
--- a/packages/linux/linux.inc
+++ b/packages/linux/linux.inc
@@ -124,7 +124,6 @@ do_configure_prepend() {
echo "CONFIG_ROOT_NFS=y" >> ${S}/.config
echo "CONFIG_CMDLINE=\"${CMDLINE_NFSROOT_USB}\"" >> ${S}/.config
fi
- yes '' | oe_runmake oldconfig
}
do_configure_append_avr32() {
@@ -132,7 +131,9 @@ do_configure_append_avr32() {
}
do_configure_append() {
- sed -i -e "s:-m0644:-m 0644:g" scripts/Makefile.fwinst
+ if test -e scripts/Makefile.fwinst ; then
+ sed -i -e "s:-m0644:-m 0644:g" scripts/Makefile.fwinst
+ fi
}
do_compile_append() {