summaryrefslogtreecommitdiff
path: root/packages/linux/linux-xilinx-slab_git.bb
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2008-06-26 14:25:49 +0000
committerPhilip Balister <philip@balister.org>2008-06-26 14:25:49 +0000
commitd032555264023e95a5e9847be6133dd1d8c974c8 (patch)
tree390599e37a07d5b836a27f9afeeb1d132cea7591 /packages/linux/linux-xilinx-slab_git.bb
parent40b978626b9884ba8f821e702d34d437249d9762 (diff)
linux-xilinx-slab : Modify kernel bb file for xilinx based ppc boards using
secretlab.cs git repo so they compile. The resulting kernel may not work, but creating images needs a buildable kernel bb file. With this commit console image for the xlinix-ml403 dev board builds.
Diffstat (limited to 'packages/linux/linux-xilinx-slab_git.bb')
-rw-r--r--packages/linux/linux-xilinx-slab_git.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/packages/linux/linux-xilinx-slab_git.bb b/packages/linux/linux-xilinx-slab_git.bb
new file mode 100644
index 0000000000..df71fee865
--- /dev/null
+++ b/packages/linux/linux-xilinx-slab_git.bb
@@ -0,0 +1,48 @@
+#Kernel for the xilinx-ml403 board using SecretLabs git tree
+# Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for Xilinx ML403 Virtex 4 fpga board"
+LICENSE = "GPL"
+
+SRCREV = "d7ed933b578d9c4dec0e23a5a6f78c464b31c47c"
+
+PR = "r3"
+PV = "2.6.25+2.6.26+${PR}+git${SRCREV}"
+
+COMPATIBLE_MACHINE = "xilinx-ml403"
+
+#inherit kernel xilinx-bsp
+inherit kernel
+
+S = "${WORKDIR}/git"
+
+
+FILES_kernel-image = "/boot/zImage.elf"
+
+export OS = "Linux"
+ARCH = "ppc"
+KERNEL_IMAGETYPE = "zImage"
+KERNEL_OUTPUT = "arch/ppc/boot/images/zImage.elf"
+
+SRC_URI = "\
+ git://git.secretlab.ca/git/linux-2.6-virtex.git;protocol=git \
+ "
+
+do_configure() {
+
+ make ARCH=${ARCH} ml403_defconfig
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 arch/${ARCH}/boot/images/${KERNEL_IMAGETYPE}.elf \
+ ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
+}
+
+#seems like 2.6.21 kernel images have moved (or is this only for the Denx kernel ?)
+#so we need to copy the kernel image where kernel.bbclass expects it to be
+#do_install_prepend() {
+# install -m 0644 arch/${ARCH}/boot/images/${KERNEL_IMAGETYPE}.elf \
+# arch/${ARCH}/boot/${KERNEL_IMAGETYPE}
+#}