summaryrefslogtreecommitdiff
path: root/packages/linux/linux-x86_2.6.20.bb
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2007-07-03 16:49:42 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2007-07-03 16:49:42 +0000
commitd003b363ab2fb8c22ef26b300bfc56d993421a1f (patch)
tree73a11f569f582c6158af0c5c89358dd0a603ad78 /packages/linux/linux-x86_2.6.20.bb
parent5f61eb5253c25e2612ad736140194ff4f423433c (diff)
linux-x86: Add deploying of kernel image again.
Diffstat (limited to 'packages/linux/linux-x86_2.6.20.bb')
-rw-r--r--packages/linux/linux-x86_2.6.20.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/packages/linux/linux-x86_2.6.20.bb b/packages/linux/linux-x86_2.6.20.bb
index ec79c94bc4..cfc8af6f21 100644
--- a/packages/linux/linux-x86_2.6.20.bb
+++ b/packages/linux/linux-x86_2.6.20.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Linux Kernel for x86 compatible machines"
SECTION = "kernel"
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 "
@@ -29,3 +29,12 @@ do_configure_prepend_i686() {
install -m 0644 ${WORKDIR}/i686-defconfig ${S}/.config
}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 arch/i386/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_populate_staging after do_compile