summaryrefslogtreecommitdiff
path: root/packages/linux/linux-x86_2.6.20.bb
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-05-29 11:05:35 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-05-29 11:05:35 +0000
commit212faea582979db2195c01ce884fe992a9478e58 (patch)
tree6fb3fab4d6a1499934746a420e8ca19ab981ad53 /packages/linux/linux-x86_2.6.20.bb
parentb8c68ffd294ba82ae973a0af5e9166b846601b6c (diff)
parentf82e817a6c920a9b9b1ee6308b64022915eb4947 (diff)
merge of '7a8b58eb1559ce42d012bca6d3e376d7039ca042'
and '9cf7a02e468c0f4c9f50d118cdeb06565eeac2ea'
Diffstat (limited to 'packages/linux/linux-x86_2.6.20.bb')
-rw-r--r--packages/linux/linux-x86_2.6.20.bb26
1 files changed, 15 insertions, 11 deletions
diff --git a/packages/linux/linux-x86_2.6.20.bb b/packages/linux/linux-x86_2.6.20.bb
index c73ee58d2f..ef5a451af0 100644
--- a/packages/linux/linux-x86_2.6.20.bb
+++ b/packages/linux/linux-x86_2.6.20.bb
@@ -1,10 +1,14 @@
DESCRIPTION = "Linux Kernel for x86 compatible machines"
SECTION = "kernel"
LICENSE = "GPL"
-PR = "r2"
+PR = "r0"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 "
+
+SRC_URI_append_x86 = "file://i486-defconfig"
+SRC_URI_append_i586-generic = "file://i586-defconfig"
+SRC_URI_append_i686-generic = "file://i686-defconfig"
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
- file://defconfig"
S = "${WORKDIR}/linux-${PV}"
@@ -13,15 +17,15 @@ inherit kernel
COMPATIBLE_HOST = "i.86.*-linux"
KERNEL_IMAGETYPE = "bzImage"
-do_configure_prepend() {
- install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+do_configure_prepend_x86() {
+ install -m 0644 ${WORKDIR}/i486-defconfig ${S}/.config
}
-do_deploy() {
- install -d ${DEPLOY_DIR_IMAGE}
- install -m 0644 arch/i386/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
-}
+do_configure_prepend_i586-generic() {
+ install -m 0644 ${WORKDIR}/i586-defconfig ${S}/.config
+}
-do_deploy[dirs] = "${S}"
+do_configure_prepend_i686() {
+ install -m 0644 ${WORKDIR}/i686-defconfig ${S}/.config
+}
-addtask deploy before do_populate_staging after do_compile