summaryrefslogtreecommitdiff
path: root/packages/linux/linux-x86_2.6.20.bb
diff options
context:
space:
mode:
authorStelios Koroneos <skoroneos@digital-opsis.com>2007-02-20 14:24:13 +0000
committerStelios Koroneos <skoroneos@digital-opsis.com>2007-02-20 14:24:13 +0000
commitf53262b3a0a7c2dbdef6b41a0da4fada1a9eac9e (patch)
tree6865433997da7f5c33a1cd6c270014a20ed7b52d /packages/linux/linux-x86_2.6.20.bb
parent69a75358e3e8d592d44a558427079a920573d32a (diff)
packages/linux: Add kernel 2.6.20 for x86
Diffstat (limited to 'packages/linux/linux-x86_2.6.20.bb')
-rw-r--r--packages/linux/linux-x86_2.6.20.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/packages/linux/linux-x86_2.6.20.bb b/packages/linux/linux-x86_2.6.20.bb
new file mode 100644
index 0000000000..5db1563733
--- /dev/null
+++ b/packages/linux/linux-x86_2.6.20.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Linux Kernel for x86 compatible machines"
+SECTION = "kernel"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ file://defconfig"
+
+S = "${WORKDIR}/linux-${PV}"
+
+inherit kernel
+
+COMPATIBLE_HOST = "i.86.*-linux"
+KERNEL_IMAGETYPE = "bzImage"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+}
+