summaryrefslogtreecommitdiff
path: root/packages/linux/linux-wrt-2.4.30/100-gcc3-mtune
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/linux/linux-wrt-2.4.30/100-gcc3-mtune
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/linux/linux-wrt-2.4.30/100-gcc3-mtune')
-rw-r--r--packages/linux/linux-wrt-2.4.30/100-gcc3-mtune28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/linux/linux-wrt-2.4.30/100-gcc3-mtune b/packages/linux/linux-wrt-2.4.30/100-gcc3-mtune
index e69de29bb2..0f5a7017e9 100644
--- a/packages/linux/linux-wrt-2.4.30/100-gcc3-mtune
+++ b/packages/linux/linux-wrt-2.4.30/100-gcc3-mtune
@@ -0,0 +1,28 @@
+--- linux-mips-cvs-21012005/arch/mips/Makefile 2004-11-18 05:16:52.000000000 +0100
++++ linux-broadcom/arch/mips/Makefile 2005-01-24 02:56:02.000000000 +0100
+@@ -71,13 +74,13 @@
+ set_gccflags = $(shell \
+ while :; do \
+ cpu=$(1); isa=-$(2); \
+- for gcc_opt in -march= -mcpu=; do \
++ for gcc_opt in -march= -mtune=; do \
+ $(CC) $$gcc_opt$$cpu $$isa -S -o /dev/null \
+ -xc /dev/null > /dev/null 2>&1 && \
+ break 2; \
+ done; \
+ cpu=$(3); isa=-$(4); \
+- for gcc_opt in -march= -mcpu=; do \
++ for gcc_opt in -march= -mtune=; do \
+ $(CC) $$gcc_opt$$cpu $$isa -S -o /dev/null \
+ -xc /dev/null > /dev/null 2>&1 && \
+ break 2; \
+@@ -92,7 +95,7 @@
+ fi; \
+ gas_abi=-Wa,-32; gas_cpu=$$cpu; gas_isa=-Wa,$$isa; \
+ while :; do \
+- for gas_opt in -Wa,-march= -Wa,-mcpu=; do \
++ for gas_opt in -Wa,-march= -Wa,-mtune=; do \
+ $(CC) $$gas_abi $$gas_opt$$cpu $$gas_isa -Wa,-Z -c \
+ -o /dev/null -xassembler /dev/null > /dev/null 2>&1 && \
+ break 2; \
+