summaryrefslogtreecommitdiff
path: root/packages/linux/linux-wrt-2.4.30/001-Makefile
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/linux/linux-wrt-2.4.30/001-Makefile
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/linux/linux-wrt-2.4.30/001-Makefile')
-rw-r--r--packages/linux/linux-wrt-2.4.30/001-Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/packages/linux/linux-wrt-2.4.30/001-Makefile b/packages/linux/linux-wrt-2.4.30/001-Makefile
index e69de29bb2..d01051f844 100644
--- a/packages/linux/linux-wrt-2.4.30/001-Makefile
+++ b/packages/linux/linux-wrt-2.4.30/001-Makefile
@@ -0,0 +1,43 @@
+--- ../../../kernel/linux-mips-cvs/Makefile 2005-01-20 03:19:21.000000000 +0100
++++ linux-2.4.29.new/Makefile 2005-03-15 01:15:27.441095231 +0100
+@@ -17,9 +17,9 @@
+ FINDHPATH = $(HPATH)/asm $(HPATH)/linux $(HPATH)/scsi $(HPATH)/net $(HPATH)/math-emu
+
+ HOSTCC = gcc
+-HOSTCFLAGS = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer
++HOSTCFLAGS = -Wall -Wstrict-prototypes -Os -fomit-frame-pointer
+
+-CROSS_COMPILE =
++CROSS_COMPILE=
+
+ #
+ # Include the make variables (CC, etc...)
+@@ -91,8 +91,18 @@
+
+ CPPFLAGS := -D__KERNEL__ -I$(HPATH)
+
+-CFLAGS := $(CPPFLAGS) -Wall -Wstrict-prototypes -Wno-trigraphs -O2 \
++CFLAGS := $(CPPFLAGS) -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
+ -fno-strict-aliasing -fno-common
++
++
++# Turn on -pg to instrument the kernel with calls to mcount().
++# Unfortunately, gcc won't allow -pg without frame pointers.
++ifdef CONFIG_MCOUNT
++ CFLAGS += -pg
++ CFLAGS_KERNEL += -pg
++ CONFIG_FRAME_POINTER = 1
++endif
++
+ ifndef CONFIG_FRAME_POINTER
+ CFLAGS += -fomit-frame-pointer
+ endif
+@@ -501,7 +511,7 @@
+ ifdef CONFIG_MODVERSIONS
+ $(MAKE) update-modverfile
+ endif
+- scripts/mkdep -- `find $(FINDHPATH) \( -name SCCS -o -name .svn \) -prune -o -follow -name \*.h ! -name modversions.h -print` > .hdepend
++ (find $(FINDHPATH) \( -name SCCS -o -name .svn \) -prune -o -follow -name \*.h ! -name modversions.h -print | xargs -r scripts/mkdep -- ) > .hdepend
+ scripts/mkdep -- init/*.c > .depend
+
+ ifdef CONFIG_MODVERSIONS