summaryrefslogtreecommitdiff
path: root/packages/linux/linux-wrap-geode_2.6.17.bb
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-09-01 01:48:58 +0000
committerJamie Lenehan <lenehan@twibble.org>2006-09-01 01:48:58 +0000
commit0fd1a70f523a36b525055337d1963a9454b372b5 (patch)
tree7bdca45f06e35c2ed9e945711794f3844cc2c9bb /packages/linux/linux-wrap-geode_2.6.17.bb
parent17c6027f5979a73ec425199947ca1c046d0c7aa6 (diff)
linux: Add a 2.6.17 kernel for the pcengines WRAP (Wireless Router
Application Platform) boards. These boards use a 233MHz AMD Geode SC1100 CPU (i486).
Diffstat (limited to 'packages/linux/linux-wrap-geode_2.6.17.bb')
-rw-r--r--packages/linux/linux-wrap-geode_2.6.17.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/linux/linux-wrap-geode_2.6.17.bb b/packages/linux/linux-wrap-geode_2.6.17.bb
new file mode 100644
index 0000000000..d02aca79f7
--- /dev/null
+++ b/packages/linux/linux-wrap-geode_2.6.17.bb
@@ -0,0 +1,24 @@
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for PC-Engines WRAP which are \
+Geode SC1100 (i486) based wirless router appliance boards"
+LICENSE = "GPL"
+MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>
+PR = "r0"
+
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ file://defconfig"
+S = "${WORKDIR}/linux-${PV}"
+
+COMPATIBLE_HOST = 'i486.*-linux'
+COMPATIBLE_MACHINE = "wrap"
+
+inherit kernel
+
+ARCH = "i386"
+KERNEL_IMAGETYPE = "bzImage"
+KERNEL_OUTPUT = "arch/${ARCH}/boot/${KERNEL_IMAGETYPE}"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ yes '' | oe_runmake oldconfig
+}