summaryrefslogtreecommitdiff
path: root/packages/linux/linux-titan-sh4_2.6.21.bb
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-04-30 19:02:38 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-04-30 19:02:38 +0000
commit14d8757a50c592986ccc236b6dcd5bf4b61f894b (patch)
treea96f0e21ef3164146e3f89a22e309f5482869d93 /packages/linux/linux-titan-sh4_2.6.21.bb
parent85e7e5d440d9090d1e5cb1f384655767971445ce (diff)
parentf1d57e9f9f701f19e1ca2987571d059888bd3035 (diff)
merge of '3744a34d57095e84a89851df9f2cabc7b5a0dd0d'
and 'bdbd61d03008d901627ae17450554a101ca42e5b'
Diffstat (limited to 'packages/linux/linux-titan-sh4_2.6.21.bb')
-rw-r--r--packages/linux/linux-titan-sh4_2.6.21.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/linux/linux-titan-sh4_2.6.21.bb b/packages/linux/linux-titan-sh4_2.6.21.bb
new file mode 100644
index 0000000000..ee890e2415
--- /dev/null
+++ b/packages/linux/linux-titan-sh4_2.6.21.bb
@@ -0,0 +1,29 @@
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for SH4 based TITAN (NP51R/LinkGear Series 100) router appliance"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ file://titan-flash.patch;patch=1 \
+ file://titan-pcibios-scan-update.patch;patch=1 \
+ file://no-mm-mutex.patch;patch=1 \
+ file://titan-config"
+S = "${WORKDIR}/linux-${PV}"
+
+COMPATIBLE_HOST = 'sh4.*-linux'
+COMPATIBLE_MACHINE = "titan"
+
+inherit kernel
+
+ARCH = "sh"
+KERNEL_IMAGETYPE = "zImage"
+KERNEL_OUTPUT = "arch/${ARCH}/boot/${KERNEL_IMAGETYPE}"
+
+#
+# Use an updated defconfig which includes the flash driver
+# The flash driver quality doesn't allow it to be a part of the main kernel
+#
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/titan-config ${S}/arch/sh/configs/titan_defconfig
+ yes '' | oe_runmake titan_defconfig
+}