summaryrefslogtreecommitdiff
path: root/packages/linux/linux-titan-sh4_2.6.16.bb
diff options
context:
space:
mode:
authorKristoffer Ericson <kristoffer_e1@hotmail.com>2006-06-28 23:02:09 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-28 23:02:09 +0000
commit7e91a61ba8b5b1e3510c7ec1505ac71a3a0ce6b4 (patch)
tree826d8408d48dcc37052ecfe2067f830833df2a07 /packages/linux/linux-titan-sh4_2.6.16.bb
parentf3ea435114c6d51e41ac7e9474e3e223277427a0 (diff)
parent8ae098ac7348611935439c2ebc61c9165b046a9e (diff)
merge of 2688bfa9b672d5b4d8734a288aa8b1e77ee47a60
and 451e0728f5380a834da5ad8ecd79994cf6f12315
Diffstat (limited to 'packages/linux/linux-titan-sh4_2.6.16.bb')
-rw-r--r--packages/linux/linux-titan-sh4_2.6.16.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/packages/linux/linux-titan-sh4_2.6.16.bb b/packages/linux/linux-titan-sh4_2.6.16.bb
new file mode 100644
index 0000000000..2c4316aea0
--- /dev/null
+++ b/packages/linux/linux-titan-sh4_2.6.16.bb
@@ -0,0 +1,49 @@
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for SH4 based TITAN router appliance"
+LICENSE = "GPL"
+MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>
+PR = "r0"
+
+# The "date=20060328" should be changed to "tag=linux-2_6_16" - but the
+# tag won't exit till 2.6.17 is released
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+cvs://anonymous@linuxsh.cvs.sourceforge.net/cvsroot/linuxsh;module=linux;data=20060331 \
+ file://titan-flash.patch;patch=1 \
+ file://titan-config"
+S = "${WORKDIR}/linux-${PV}"
+
+COMPATIBLE_HOST = 'sh4.*-linux'
+
+inherit kernel
+
+ARCH = "sh"
+KERNEL_IMAGETYPE = "vmlinux"
+KERNEL_OUTPUT = "${KERNEL_IMAGETYPE}"
+
+#
+# The linux-sh cvs tree is a "drop in source tree" and needs to be copied
+# over the top of the normal linux source since it only includes modified
+# files.
+#
+do_unpack_extra(){
+ cp -pPR ${WORKDIR}/linux/* ${S}
+}
+addtask unpack_extra after do_unpack before do_patch
+
+#
+# Use an updated defconfig which includes the flash driver
+# The flash driver quality doesn't allow it to be a part of the main kernel
+#
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/titan-config ${S}/arch/sh/configs/titan_defconfig
+ yes '' | oe_runmake titan_defconfig
+}
+
+#
+# Should I make the nfs boot image?
+#
+#do_deploy_titan() {
+# To NFS boot you need to objcopy the image...
+# ${HOST_PREFIX}objcopy -O binary -R .note -R .comment -S arch/sh/boot/compressed/vmlinux ${DEPLOY_DIR}/linux.bin
+#}
+#addtask deploy before do_build after do_compile