summaryrefslogtreecommitdiff
path: root/packages/linux/linux-storcenter_2.6.12.6.bb
diff options
context:
space:
mode:
authorAndrew Wilcox <andy@protium.com>2006-12-07 19:10:02 +0000
committerAndrew Wilcox <andy@protium.com>2006-12-07 19:10:02 +0000
commit1d5f50bce888b5b4f20ff3bd14f6685f2c0355e7 (patch)
treee049136cac188f128c93055b1c0f065be32331a7 /packages/linux/linux-storcenter_2.6.12.6.bb
parent6363b1e9e61b4b4d8cc6541ae1a75de3e5e09870 (diff)
linux-storcenter: kernel patch, default config, and bitbake file for storcenter kernel.
Diffstat (limited to 'packages/linux/linux-storcenter_2.6.12.6.bb')
-rw-r--r--packages/linux/linux-storcenter_2.6.12.6.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/packages/linux/linux-storcenter_2.6.12.6.bb b/packages/linux/linux-storcenter_2.6.12.6.bb
new file mode 100644
index 0000000000..280cb5bd62
--- /dev/null
+++ b/packages/linux/linux-storcenter_2.6.12.6.bb
@@ -0,0 +1,60 @@
+DESCRIPTION = "Linux Kernel for the Iomega storcenter platform"
+SECTION = "kernel"
+LICENSE = "GPL"
+PR = "r0"
+
+# notes on iom def kernel:
+#
+# can probably remove :
+# BLK_DEV_RAM ?
+# MD_RAID5
+# QUOTA
+# QFMT_V2
+# DNOTIFY?
+# MSDOS_FS, VFAT_FS, NTFS_FS?
+#
+# USB_GADGET? - USB_GADGET_NET2280, USB_ETH, USB_ETH_RNDIS
+#
+#
+# should add:
+# EXT3_FS
+# PACKET_MMAP ?
+# i2c_chardev?
+# usb audio:
+# USB_EMI62?
+# USB_EMI26?
+
+COMPATIBLE_MACHINE = "storcenter"
+
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ file://kernel.patch-${PV};patch=1 \
+ file://10-command-line.patch;patch=1 \
+ file://defconfig-${PV} "
+
+S = "${WORKDIR}/linux-${PV}"
+
+inherit kernel
+
+KERNEL_IMAGETYPE = "uImage"
+KERNEL_OUTPUT = "arch/${ARCH}/boot/images/${KERNEL_IMAGETYPE}"
+
+do_configure() {
+ install -m 644 ${WORKDIR}/defconfig-${PV} ${S}/.config
+ make ARCH=ppc oldconfig
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 arch/${ARCH}/boot/images/${KERNEL_IMAGETYPE} ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
+}
+
+#ppc build leaves the kernel in a different place
+#do_movekernel() {
+#
+#}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_build after do_compile
+
+