summaryrefslogtreecommitdiff
path: root/packages/linux/linux-rt_2.6.24.bb
diff options
context:
space:
mode:
authorLeon Woestenberg <leon.woestenberg@gmail.com>2008-02-13 23:41:18 +0000
committerLeon Woestenberg <leon.woestenberg@gmail.com>2008-02-13 23:41:18 +0000
commitad8af9b7951ed766eb1c6b5f9548fb130a5f024c (patch)
tree8fd1f308134c9883e75a531ad92a87351a220a6f /packages/linux/linux-rt_2.6.24.bb
parent2fe10c088ac5f959fcce4aac04d596f88f598fdd (diff)
linux-rt: New .bb for the real-time kernel (experimental).
Diffstat (limited to 'packages/linux/linux-rt_2.6.24.bb')
-rw-r--r--packages/linux/linux-rt_2.6.24.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/packages/linux/linux-rt_2.6.24.bb b/packages/linux/linux-rt_2.6.24.bb
new file mode 100644
index 0000000000..38bdfef48b
--- /dev/null
+++ b/packages/linux/linux-rt_2.6.24.bb
@@ -0,0 +1,37 @@
+require linux.inc
+
+# Mark archs/machines that this kernel supports
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_mpc8313e-rdb = "1"
+
+DEPENDS_append_mpc8313e-rdb = " dtc-native"
+
+PR = "r0"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
+ ${KERNELORG_MIRROR}/pub/linux/kernel/projects/rt/patch-2.6.24-rt1.bz2;patch=1 \
+ file://defconfig \
+ "
+
+S = "${WORKDIR}/linux-2.6.24"
+
+#SRC_URI_append_mpc8313e-rdb = "\
+# file://mpc8313e-rdb-leds.patch;patch=1"
+# file://mpc831x-nand.patch;patch=1 \
+# file://mpc8313e-rdb-rtc.patch;patch=1 "
+
+DEVICETREE_mpc8313e-rdb = "arch/${ARCH}/boot/dts/mpc8313erdb.dts"
+DEVICETREE_FLAGS_mpc8313e-rdb = "-R 8 -S 0x3000"
+
+do_devicetree_image() {
+ if test -n "${DEVICETREE}" ; then
+ dtc -I dts -O dtb ${DEVICETREE_FLAGS} -o ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_BASE_NAME}.dtb ${DEVICETREE}
+
+ cd ${DEPLOY_DIR_IMAGE}
+ rm -f ${KERNEL_IMAGE_SYMLINK_NAME}.dtb
+ ln -sf ${KERNEL_IMAGE_BASE_NAME}.dtb ${KERNEL_IMAGE_SYMLINK_NAME}.dtb
+ fi
+}
+
+addtask devicetree_image after do_deploy before do_package
+