summaryrefslogtreecommitdiff
path: root/packages/linux/linux-openmoko
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2008-01-11 13:33:57 +0000
committerGraeme Gregory <dp@xora.org.uk>2008-01-11 13:33:57 +0000
commitea4aa4cbfdac1f6a5c875be23c21577f71e9dfec (patch)
tree90c2d7ef32c91f819fa5660b04b25ca79664c561 /packages/linux/linux-openmoko
parentca878cece7ccbde0bd83487aad91cf13922d6fb2 (diff)
linux-openmoko_2.6.22.5.bb : fix bug in gta02 sound driver that misreported
the speaker state alsa-state.bb : state files corrected now bug is fixed
Diffstat (limited to 'packages/linux/linux-openmoko')
-rw-r--r--packages/linux/linux-openmoko/gta02-sound.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/packages/linux/linux-openmoko/gta02-sound.patch b/packages/linux/linux-openmoko/gta02-sound.patch
index 66fc850350..f742c77303 100644
--- a/packages/linux/linux-openmoko/gta02-sound.patch
+++ b/packages/linux/linux-openmoko/gta02-sound.patch
@@ -280,7 +280,7 @@ Index: linux-2.6.22/sound/soc/s3c24xx/neo1973_gta02_wm8753.c
+static int lm4853_get_spk(struct snd_kcontrol *kcontrol,
+ struct snd_ctl_elem_value *ucontrol)
+{
-+ ucontrol->value.integer.value[0] = (lm4853_state & LM4853_AMP) >> 1;
++ ucontrol->value.integer.value[0] = (lm4853_state & LM4853_SPK) >> 1;
+
+ return 0;
+}