summaryrefslogtreecommitdiff
path: root/packages/linux/linux-openmoko/0003-squashfs-force-O2.patch
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2008-07-17 15:59:18 +0000
committerGraeme Gregory <dp@xora.org.uk>2008-07-17 15:59:18 +0000
commitfcbe107913b10643d1ba8ac137de273e12e8854a (patch)
tree2235c3d2a30eac66c0319b7cff55928990c89bbd /packages/linux/linux-openmoko/0003-squashfs-force-O2.patch
parent19b9576325acb8162f5fb1c03bbbc054eeaaeeef (diff)
linux-openmoko_2.6.24+git.bb : add squashfs to the build #4437
Diffstat (limited to 'packages/linux/linux-openmoko/0003-squashfs-force-O2.patch')
-rw-r--r--packages/linux/linux-openmoko/0003-squashfs-force-O2.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/packages/linux/linux-openmoko/0003-squashfs-force-O2.patch b/packages/linux/linux-openmoko/0003-squashfs-force-O2.patch
new file mode 100644
index 0000000000..550077b9fa
--- /dev/null
+++ b/packages/linux/linux-openmoko/0003-squashfs-force-O2.patch
@@ -0,0 +1,17 @@
+The kernel patch from the squashfs-3.1r2 release did not compile on my
+armeb-linux-gcc 4.1.1 when optimizing for size (-Os). This works around
+that problem by using optimization flag -O2 instead for these two files.
+
+Signed-off-by: Leon Woestenberg <leonw@mailcan.com>
+
+Index: linux-2.6.19/fs/squashfs/Makefile
+===================================================================
+--- linux-2.6.19.orig/fs/squashfs/Makefile
++++ linux-2.6.19/fs/squashfs/Makefile
+@@ -5,3 +5,6 @@
+ obj-$(CONFIG_SQUASHFS) += squashfs.o
+ squashfs-y += inode.o
+ squashfs-y += squashfs2_0.o
++
++CFLAGS_squashfs2_0.o = "-O2"
++CFLAGS_inode.o = "-O2"