summaryrefslogtreecommitdiff
path: root/packages/linux/linux-openmoko/0003-squashfs-force-O2.patch
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-07-17 18:07:12 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-07-17 18:07:12 +0000
commit12f8a39939c28003a39b84713d9a51305511650d (patch)
tree2235c3d2a30eac66c0319b7cff55928990c89bbd /packages/linux/linux-openmoko/0003-squashfs-force-O2.patch
parent058132b8be45ac2041a574782b8800c1956e44d3 (diff)
parentfcbe107913b10643d1ba8ac137de273e12e8854a (diff)
merge of '470ca3fe64c9411d3a7d992db39d5efbed869839'
and '912f388483a3e1703ca89d7b2309723fd3407420'
Diffstat (limited to 'packages/linux/linux-openmoko/0003-squashfs-force-O2.patch')
-rw-r--r--packages/linux/linux-openmoko/0003-squashfs-force-O2.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/packages/linux/linux-openmoko/0003-squashfs-force-O2.patch b/packages/linux/linux-openmoko/0003-squashfs-force-O2.patch
new file mode 100644
index 0000000000..550077b9fa
--- /dev/null
+++ b/packages/linux/linux-openmoko/0003-squashfs-force-O2.patch
@@ -0,0 +1,17 @@
+The kernel patch from the squashfs-3.1r2 release did not compile on my
+armeb-linux-gcc 4.1.1 when optimizing for size (-Os). This works around
+that problem by using optimization flag -O2 instead for these two files.
+
+Signed-off-by: Leon Woestenberg <leonw@mailcan.com>
+
+Index: linux-2.6.19/fs/squashfs/Makefile
+===================================================================
+--- linux-2.6.19.orig/fs/squashfs/Makefile
++++ linux-2.6.19/fs/squashfs/Makefile
+@@ -5,3 +5,6 @@
+ obj-$(CONFIG_SQUASHFS) += squashfs.o
+ squashfs-y += inode.o
+ squashfs-y += squashfs2_0.o
++
++CFLAGS_squashfs2_0.o = "-O2"
++CFLAGS_inode.o = "-O2"