summaryrefslogtreecommitdiff
path: root/packages/linux/linux-omap2-git
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-05-09 08:11:36 +0000
committerKoen Kooi <koen@openembedded.org>2008-05-09 08:11:36 +0000
commit887d1db73251bb7787a5b110ac79e88100bdf816 (patch)
tree91cd6194032d0f5378c5f4dd8b9c6bc23f2a471f /packages/linux/linux-omap2-git
parent9bf42f65af5bf511454d16a684ee622ae5b8fabe (diff)
linux-omap2 git: bump SRCREV, add patch for beagleboard RTC support and add (disabled) patch that aims to enable the DVI chip
Diffstat (limited to 'packages/linux/linux-omap2-git')
-rw-r--r--packages/linux/linux-omap2-git/beagleboard/0001-This-patch-adds-RTC-support-to-the-omap3-based-beagl.patch43
-rw-r--r--packages/linux/linux-omap2-git/beagleboard/beagle-dvi-first-try.diff187
2 files changed, 230 insertions, 0 deletions
diff --git a/packages/linux/linux-omap2-git/beagleboard/0001-This-patch-adds-RTC-support-to-the-omap3-based-beagl.patch b/packages/linux/linux-omap2-git/beagleboard/0001-This-patch-adds-RTC-support-to-the-omap3-based-beagl.patch
new file mode 100644
index 0000000000..3f861ebf9d
--- /dev/null
+++ b/packages/linux/linux-omap2-git/beagleboard/0001-This-patch-adds-RTC-support-to-the-omap3-based-beagl.patch
@@ -0,0 +1,43 @@
+From 3f8441b4e1fc297caf5cf712c1bc3f506ec28065 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@openembedded.org>
+Date: Thu, 8 May 2008 18:30:41 +0200
+Subject: [PATCH] This patch adds RTC support to the omap3 based beagleboard
+
+Signed-off-by: Koen Kooi <koen@openembedded.org>
+---
+ arch/arm/mach-omap2/board-omap3beagle.c | 12 ++++++++++++
+ 1 files changed, 12 insertions(+), 0 deletions(-)
+
+diff --git a/arch/arm/mach-omap2/board-omap3beagle.c b/arch/arm/mach-omap2/board-omap3beagle.c
+index 626f004..0c0cbfc 100644
+--- a/arch/arm/mach-omap2/board-omap3beagle.c
++++ b/arch/arm/mach-omap2/board-omap3beagle.c
+@@ -58,13 +58,25 @@ static struct omap_mmc_config omap3beagle_mmc_config __initdata = {
+ },
+ };
+
++static struct platform_device omap3_beagle_twl4030rtc_device = {
++ .name = "twl4030_rtc",
++ .id = -1,
++};
++
+ static struct omap_board_config_kernel omap3_beagle_config[] __initdata = {
+ { OMAP_TAG_UART, &omap3_beagle_uart_config },
+ { OMAP_TAG_MMC, &omap3beagle_mmc_config },
+ };
+
++static struct platform_device *omap3_beagle_devices[] __initdata = {
++#ifdef CONFIG_RTC_DRV_TWL4030
++ &omap3_beagle_twl4030rtc_device,
++#endif
++};
++
+ static void __init omap3_beagle_init(void)
+ {
++ platform_add_devices(omap3_beagle_devices, ARRAY_SIZE(omap3_beagle_devices));
+ omap_board_config = omap3_beagle_config;
+ omap_board_config_size = ARRAY_SIZE(omap3_beagle_config);
+ omap_serial_init();
+--
+1.5.4.3
+
diff --git a/packages/linux/linux-omap2-git/beagleboard/beagle-dvi-first-try.diff b/packages/linux/linux-omap2-git/beagleboard/beagle-dvi-first-try.diff
new file mode 100644
index 0000000000..b6f9615ec4
--- /dev/null
+++ b/packages/linux/linux-omap2-git/beagleboard/beagle-dvi-first-try.diff
@@ -0,0 +1,187 @@
+diff --git a/arch/arm/mach-omap2/board-omap3beagle.c b/arch/arm/mach-omap2/board-omap3beagle.c
+index 0c0cbfc..c992cc7 100644
+--- a/arch/arm/mach-omap2/board-omap3beagle.c
++++ b/arch/arm/mach-omap2/board-omap3beagle.c
+@@ -63,12 +63,23 @@ static struct platform_device omap3_beagle_twl4030rtc_device = {
+ .id = -1,
+ };
+
++static struct platform_device omap3_beagle_lcd_device = {
++ .name = "omap3beagle_lcd",
++ .id = -1,
++};
++
++static struct omap_lcd_config omap3_beagle_lcd_config __initdata = {
++ .ctrl_name = "internal",
++};
++
+ static struct omap_board_config_kernel omap3_beagle_config[] __initdata = {
+ { OMAP_TAG_UART, &omap3_beagle_uart_config },
+ { OMAP_TAG_MMC, &omap3beagle_mmc_config },
++ { OMAP_TAG_LCD, &omap3_beagle_lcd_config },
+ };
+
+ static struct platform_device *omap3_beagle_devices[] __initdata = {
++ &omap3_beagle_lcd_device,
+ #ifdef CONFIG_RTC_DRV_TWL4030
+ &omap3_beagle_twl4030rtc_device,
+ #endif
+diff --git a/drivers/video/omap/Makefile b/drivers/video/omap/Makefile
+index cad6a68..fe7ee5d 100644
+--- a/drivers/video/omap/Makefile
++++ b/drivers/video/omap/Makefile
+@@ -32,6 +32,7 @@ objs-y$(CONFIG_MACH_OMAP_APOLLON) += lcd_apollon.o
+ objs-y$(CONFIG_MACH_OMAP_2430SDP) += lcd_2430sdp.o
+ objs-y$(CONFIG_MACH_OMAP_3430SDP) += lcd_2430sdp.o
+ objs-y$(CONFIG_MACH_OMAP3EVM) += lcd_omap3evm.o
++objs-y$(CONFIG_MACH_OMAP3_BEAGLE) += lcd_omap3beagle.o
+ objs-y$(CONFIG_FB_OMAP_LCD_MIPID) += lcd_mipid.o
+
+ omapfb-objs := $(objs-yy)
+diff --git a/drivers/video/omap/lcd_omap3beagle.c b/drivers/video/omap/lcd_omap3beagle.c
+new file mode 100644
+index 0000000..99343b1
+--- /dev/null
++++ b/drivers/video/omap/lcd_omap3beagle.c
+@@ -0,0 +1,141 @@
++/*
++ * LCD panel support for the TI OMAP3 Beagle board
++ *
++ * Author: Koen Kooi <koen@openembedded.org>
++ *
++ * Derived from drivers/video/omap/lcd-omap3evm.c
++ *
++ * This program is free software; you can redistribute it and/or modify it
++ * under the terms of the GNU General Public License as published by the
++ * Free Software Foundation; either version 2 of the License, or (at your
++ * option) any later version.
++ *
++ * This program is distributed in the hope that it will be useful, but
++ * WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++ * General Public License for more details.
++ *
++ * You should have received a copy of the GNU General Public License along
++ * with this program; if not, write to the Free Software Foundation, Inc.,
++ * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
++ */
++
++#include <linux/module.h>
++#include <linux/platform_device.h>
++#include <linux/i2c/twl4030.h>
++
++#include <asm/arch/gpio.h>
++#include <asm/arch/mux.h>
++#include <asm/arch/omapfb.h>
++#include <asm/mach-types.h>
++
++#define LCD_PANEL_ENABLE_GPIO 170
++
++#define LCD_XRES 1024
++#define LCD_YRES 768
++#define LCD_PIXCLOCK_MAX 16700 /* in pico seconds */
++#define LCD_PIXCLOCK_MIN 15200 /* in pico seconds */
++
++#define ENABLE_VDAC_DEDICATED 0x03
++#define ENABLE_VDAC_DEV_GRP 0x20
++#define ENABLE_VPLL2_DEDICATED 0x05
++#define ENABLE_VPLL2_DEV_GRP 0xE0
++
++static int omap3beagle_panel_init(struct lcd_panel *panel,
++ struct omapfb_device *fbdev)
++{
++ omap_request_gpio(LCD_PANEL_ENABLE_GPIO);
++
++ return 0;
++}
++
++static void omap3beagle_panel_cleanup(struct lcd_panel *panel)
++{
++}
++
++static int omap3beagle_panel_enable(struct lcd_panel *panel)
++{
++ omap_set_gpio_dataout(LCD_PANEL_ENABLE_GPIO, 0);
++ return 0;
++}
++
++static void omap3beagle_panel_disable(struct lcd_panel *panel)
++{
++ omap_set_gpio_dataout(LCD_PANEL_ENABLE_GPIO, 1);
++}
++
++static unsigned long omap3beagle_panel_get_caps(struct lcd_panel *panel)
++{
++ return 0;
++}
++
++struct lcd_panel omap3beagle_panel = {
++ .name = "omap3beagle",
++ .config = OMAP_LCDC_PANEL_TFT | OMAP_LCDC_INV_VSYNC |
++ OMAP_LCDC_INV_HSYNC,
++
++ .bpp = 16,
++ .data_lines = 18,
++ .x_res = LCD_XRES,
++ .y_res = LCD_YRES,
++ .hsw = 3, /* hsync_len (4) - 1 */
++ .hfp = 3, /* right_margin (4) - 1 */
++ .hbp = 39, /* left_margin (40) - 1 */
++ .vsw = 1, /* vsync_len (2) - 1 */
++ .vfp = 2, /* lower_margin */
++ .vbp = 7, /* upper_margin (8) - 1 */
++
++ .pixel_clock = LCD_PIXCLOCK_MAX,
++
++ .init = omap3beagle_panel_init,
++ .cleanup = omap3beagle_panel_cleanup,
++ .enable = omap3beagle_panel_enable,
++ .disable = omap3beagle_panel_disable,
++ .get_caps = omap3beagle_panel_get_caps,
++};
++
++static int omap3beagle_panel_probe(struct platform_device *pdev)
++{
++ omapfb_register_panel(&omap3beagle_panel);
++ return 0;
++}
++
++static int omap3beagle_panel_remove(struct platform_device *pdev)
++{
++ return 0;
++}
++
++static int omap3beagle_panel_suspend(struct platform_device *pdev,
++ pm_message_t mesg)
++{
++ return 0;
++}
++
++static int omap3beagle_panel_resume(struct platform_device *pdev)
++{
++ return 0;
++}
++
++struct platform_driver omap3beagle_panel_driver = {
++ .probe = omap3beagle_panel_probe,
++ .remove = omap3beagle_panel_remove,
++ .suspend = omap3beagle_panel_suspend,
++ .resume = omap3beagle_panel_resume,
++ .driver = {
++ .name = "omap3beagle_lcd",
++ .owner = THIS_MODULE,
++ },
++};
++
++static int __init omap3beagle_panel_drv_init(void)
++{
++ return platform_driver_register(&omap3beagle_panel_driver);
++}
++
++static void __exit omap3beagle_panel_drv_exit(void)
++{
++ platform_driver_unregister(&omap3beagle_panel_driver);
++}
++
++module_init(omap3beagle_panel_drv_init);
++module_exit(omap3beagle_panel_drv_exit);