summaryrefslogtreecommitdiff
path: root/packages/linux/linux-ml403-slab-2.6.x_git.bb
diff options
context:
space:
mode:
authorOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-10-07 00:34:07 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-10-07 00:34:07 +0000
commit2f8521c6d1173dd650d9ae2bba8c18e690fa3b1f (patch)
tree06bc2b997b60797bc42f696f3427f92890089d2b /packages/linux/linux-ml403-slab-2.6.x_git.bb
parent0d0bf315513039bd8560ac91865c7174e789d675 (diff)
parent6e90aae26efa66553063b74b9afa9563b70fb982 (diff)
merge of '603b2d0c7e4ad80e5779bd3bbdb822331cc0ea2b'
and '6ab53da82d157971966f5a17d0c29d54df22cac9'
Diffstat (limited to 'packages/linux/linux-ml403-slab-2.6.x_git.bb')
-rw-r--r--packages/linux/linux-ml403-slab-2.6.x_git.bb85
1 files changed, 85 insertions, 0 deletions
diff --git a/packages/linux/linux-ml403-slab-2.6.x_git.bb b/packages/linux/linux-ml403-slab-2.6.x_git.bb
new file mode 100644
index 0000000000..75233492eb
--- /dev/null
+++ b/packages/linux/linux-ml403-slab-2.6.x_git.bb
@@ -0,0 +1,85 @@
+#Kernel for the xilinx-ml403 board using SecretLabs git tree
+# Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for Xilinx ML403 Virtex 4 fpga board"
+LICENSE = "GPL"
+PR = "r2"
+PV = "2.6+git${SRCDATE}"
+
+COMPATIBLE_MACHINE = "xilinx-ml403"
+
+SRC_URI = "file://xilinx-ml403_defconfig "
+
+inherit kernel xilinx-bsp
+
+S = "${WORKDIR}/linux-2.6"
+
+
+FILES_kernel-image = "/boot/zImage.elf"
+
+export OS = "Linux"
+ARCH = "ppc"
+KERNEL_IMAGETYPE = "zImage"
+KERNEL_OUTPUT = "arch/ppc/boot/images/zImage.elf"
+
+#make sure git-native gets build before as
+python __anonymous () {
+
+ import bb
+
+
+ depends = bb.data.getVarFlag('do_fetch', 'depends', d) or ""
+ depends = depends + " git-native:do_populate_staging"
+ bb.data.setVarFlag('do_fetch', 'depends', depends, d)
+
+}
+
+
+do_fetch () {
+
+ cd ${WORKDIR}
+ ${STAGING_BINDIR_NATIVE}/git clone git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git
+ cd linux-2.6
+ ${STAGING_BINDIR_NATIVE}/git clone git://git.secretlab.ca/git/linux-2.6-virtex.git master
+}
+
+
+
+do_configure() {
+
+ install -m 644 ${WORKDIR}/xilinx-ml403_defconfig ${S}/.config
+ make ARCH=${ARCH} oldconfig
+}
+
+do_stage_append () {
+#need ppc platforms includes + friends in order for external kernel modules to compile as headers a$
+
+ install -d ${STAGING_KERNEL_DIR}/arch/
+ cp -a arch/ppc ${STAGING_KERNEL_DIR}/arch/
+ cp -a arch/powerpc ${STAGING_KERNEL_DIR}/arch/
+
+ install -d ${STAGING_KERNEL_DIR}/include/asm
+ cp -a include/asm-powerpc ${STAGING_KERNEL_DIR}/include/
+ cp -a include/asm-ppc ${STAGING_KERNEL_DIR}/include/
+}
+
+
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 arch/${ARCH}/boot/images/${KERNEL_IMAGETYPE}.elf \
+ ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
+}
+
+#seems like 2.6.21 kernel images have moved (or is this only for the Denx kernel ?)
+#so we need to copy the kernel image where kernel.bbclass expects it to be
+do_install_prepend() {
+ install -m 0644 arch/${ARCH}/boot/images/${KERNEL_IMAGETYPE}.elf \
+ arch/${ARCH}/boot/${KERNEL_IMAGETYPE}
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_build after do_compile
+