summaryrefslogtreecommitdiff
path: root/packages/linux/linux-ml403-mvista-2.6.x_git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/linux/linux-ml403-mvista-2.6.x_git.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/linux/linux-ml403-mvista-2.6.x_git.bb')
-rw-r--r--packages/linux/linux-ml403-mvista-2.6.x_git.bb57
1 files changed, 0 insertions, 57 deletions
diff --git a/packages/linux/linux-ml403-mvista-2.6.x_git.bb b/packages/linux/linux-ml403-mvista-2.6.x_git.bb
deleted file mode 100644
index 59bcff431e..0000000000
--- a/packages/linux/linux-ml403-mvista-2.6.x_git.bb
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
-# Released under the MIT license (see packages/COPYING)
-SECTION = "kernel"
-DESCRIPTION = "Linux kernel for Xilinx ML403 Virtex 4 fpga board"
-LICENSE = "GPL"
-DEPENDS = "git-native"
-PR = "r1"
-DEFAULT_PREFERENCE = "-1"
-COMPATIBLE_MACHINE = "xilinx-ml403"
-SRC_URI = "git://source.mvista.com/git/linux-xilinx-26;protocol=git \
- file://xilinx-ml403_defconfig "
-
-inherit kernel xilinx-bsp
-
-S = "${WORKDIR}/git"
-
-
-FILES_kernel-image = "/boot/zImage.elf"
-
-export OS = "Linux"
-ARCH = "ppc"
-KERNEL_IMAGETYPE = "zImage"
-KERNEL_OUTPUT = "arch/ppc/boot/images/zImage.elf"
-
-
-do_configure() {
-
- install -m 644 ${WORKDIR}/xilinx-ml403_defconfig ${S}/.config
- make ARCH=${ARCH} oldconfig
-}
-
-do_stage_append () {
-#need ppc platforms includes + friends in order for external kernel modules to compile as headers a$
-
- install -d ${STAGING_KERNEL_DIR}/arch/
- cp -pPR arch/ppc ${STAGING_KERNEL_DIR}/arch/
- cp -pPR arch/powerpc ${STAGING_KERNEL_DIR}/arch/
-
- install -d ${STAGING_KERNEL_DIR}/include/asm
- cp -pPR include/asm-powerpc ${STAGING_KERNEL_DIR}/include/
- cp -pPR include/asm-ppc ${STAGING_KERNEL_DIR}/include/
-}
-
-
-
-do_deploy() {
- install -d ${DEPLOY_DIR_IMAGE}
- install -m 0644 arch/${ARCH}/boot/images/${KERNEL_IMAGETYPE}.elf \
- ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
-}
-
-#seems like 2.6.21 kernel images have moved (or is this only for the Denx kernel ?)
-#so we need to copy the kernel image where kernel.bbclass expects it to be
-do_install_prepend() {
- install -m 0644 arch/${ARCH}/boot/images/${KERNEL_IMAGETYPE}.elf \
- arch/${ARCH}/boot/${KERNEL_IMAGETYPE}
-}