summaryrefslogtreecommitdiff
path: root/packages/linux/linux-jlime-arm_2.6.17.bb
diff options
context:
space:
mode:
authorKristoffer Ericson <kristoffer_e1@hotmail.com>2006-07-02 22:06:07 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-02 22:06:07 +0000
commitb464f87dffccc2a4b0d2fd501930dd1ba31ca98b (patch)
treef248efbb8edbf8cff85d0d0c471128814a64050b /packages/linux/linux-jlime-arm_2.6.17.bb
parent538548f125d52702713a8f8fe25c57b321d25bfe (diff)
linux-jlime-arm_2.6.16.bb: Addition of new jlime-7xx kernel
* Addition of jlime 7xx arm kernel, need of changes linux-jlime-sh3_2.6.16.20: Patch & new defconfig * Add of patch line * Change in defconfig file unexpected-int-fx.patch: Addition of patch * Removes "unexpected ide interrupt" spam
Diffstat (limited to 'packages/linux/linux-jlime-arm_2.6.17.bb')
-rw-r--r--packages/linux/linux-jlime-arm_2.6.17.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/linux/linux-jlime-arm_2.6.17.bb b/packages/linux/linux-jlime-arm_2.6.17.bb
new file mode 100644
index 0000000000..c6d9ba8877
--- /dev/null
+++ b/packages/linux/linux-jlime-arm_2.6.17.bb
@@ -0,0 +1,31 @@
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for Hitachi SH3 based Jornada 6xx"
+LICENSE = "GPL"
+PR = "r0"
+
+COMPATIBLE_HOST = "sh.*-linux"
+COMPATIBLE_MACHINE = 'jornada6xx'
+
+SRC_URI = "http://www.jlime.com/downloads/Releases/donkey/kernels/6xx/sources/jlime-2.6.16.20-patched.tar.gz \
+ file://defconfig_jlime \
+ file://unexpected-int-fix.patch;patch=1"
+
+S = "${WORKDIR}/linux-${PV}"
+
+inherit kernel
+
+#Lets let 3.4.x handle the compilation of this one
+KERNEL_CCSUFFIX = "-3.4.4"
+
+ARCH = "sh"
+KERNEL_IMAGETYPE = "zImage"
+FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig_jlime ${S}/.config
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 arch/$(ARCH)/boot/$(KERNEL_IMAGETYPE) $(DEPLOY_DIR)/images/$(KERNEL_IMAGETYPE)
+}