summaryrefslogtreecommitdiff
path: root/packages/linux/linux-ixp4xx_2.6.23.8.bb
diff options
context:
space:
mode:
authorJeremy Laine <jeremy.laine@m4x.org>2007-11-28 12:14:40 +0000
committerJeremy Laine <jeremy.laine@m4x.org>2007-11-28 12:14:40 +0000
commitdff263b991bbfbaa61fb4ca5420af35237516e2d (patch)
tree7d0b35596d2bf2c8a923f4f5ffe398cefafab404 /packages/linux/linux-ixp4xx_2.6.23.8.bb
parent0a7584d87cca139e6e88149eda137d77ed039501 (diff)
parent851746c1c01388990f6908dd51bf1c3756eabec1 (diff)
merge of 'ce64d96dcf3b268df1bdcd7e945e7188d09c7db8'
and 'd521cbe6aca8b81bda5eb51149cea06dd31e1dd2'
Diffstat (limited to 'packages/linux/linux-ixp4xx_2.6.23.8.bb')
-rw-r--r--packages/linux/linux-ixp4xx_2.6.23.8.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/linux/linux-ixp4xx_2.6.23.8.bb b/packages/linux/linux-ixp4xx_2.6.23.8.bb
new file mode 100644
index 0000000000..a6dcca41b5
--- /dev/null
+++ b/packages/linux/linux-ixp4xx_2.6.23.8.bb
@@ -0,0 +1,27 @@
+require linux.inc
+require linux-ixp4xx.inc
+
+VANILLA_VERSION = "2.6.23"
+KERNEL_RELEASE = "2.6.23.8"
+
+# If you use a rc, you will need to use this:
+#PV = "${VANILLA_VERSION}+${KERNEL_RELEASE}+svnr${SRCREV}"
+
+PV = "${KERNEL_RELEASE}+svnr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${VANILLA_VERSION}.tar.bz2 \
+ ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${KERNEL_RELEASE}.bz2;patch=1 \
+ svn://svn.nslu2-linux.org/svnroot/kernel/trunk/patches;module=${VANILLA_VERSION};proto=http \
+ file://defconfig-${KERNEL_RELEASE}"
+
+S = "${WORKDIR}/linux-${VANILLA_VERSION}"
+
+do_prepatch() {
+ mv ${WORKDIR}/${VANILLA_VERSION} ${S}/patches && cd ${S} && quilt push -av
+ mv patches patches.ixp4xx
+ mv .pc .pc.old
+ mv ${WORKDIR}/defconfig-${KERNEL_RELEASE} ${WORKDIR}/defconfig
+}
+
+addtask prepatch after do_unpack before do_patch