summaryrefslogtreecommitdiff
path: root/packages/linux/linux-ezx-2.6.24/update_patches.sh
diff options
context:
space:
mode:
authorJohn Lee <john_lee@openmoko.org>2008-02-27 07:50:52 +0000
committerOpenmoko anonymizer key <devel@lists.openmoko.org>2008-02-27 07:50:52 +0000
commitd6f3635f2e2baa680d878461fc8fa9b68c51162b (patch)
treea07627fc6746f21a02a543381681f1cb1320b38d /packages/linux/linux-ezx-2.6.24/update_patches.sh
parentb14906e8fa695a85b9ddf27838c959be1c8a5fad (diff)
parent9d22cb8106117d2d923bf7b2c263bf9e31b5305f (diff)
merge of '8dccbf106093aaa7b62b2a96962945185534c923'
and 'c50825ba187c292f591cf43c91216cebffb5e290'
Diffstat (limited to 'packages/linux/linux-ezx-2.6.24/update_patches.sh')
-rw-r--r--packages/linux/linux-ezx-2.6.24/update_patches.sh16
1 files changed, 16 insertions, 0 deletions
diff --git a/packages/linux/linux-ezx-2.6.24/update_patches.sh b/packages/linux/linux-ezx-2.6.24/update_patches.sh
new file mode 100644
index 0000000000..9a8d36e461
--- /dev/null
+++ b/packages/linux/linux-ezx-2.6.24/update_patches.sh
@@ -0,0 +1,16 @@
+#!/bin/sh
+set -e
+
+# Helper script to update patches and speedup filling the SRC_URI section of our .bb
+# Run it while in packages/linux/linux-ezx-2.6.x/
+
+[ -d patches ] && mtn drop -R patches
+rm -rf patches
+
+svn --quiet co http://svn.openezx.org/branches/kernel-2.6.24.x-patches patches
+find patches -type f -print0
+mtn add patches patches/*
+
+cat patches/series | grep ^[0-9A-Za-z] | sed -e 's/.*/\tfile:\/\/patches\/\0;patch=1 \\/'
+ls -1 patches/defconfig-* | sed -e 's/.*/\tfile:\/\/\0 \\/'
+