summaryrefslogtreecommitdiff
path: root/packages/linux/linux-efika_2.6.16.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-04-15 17:18:41 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-15 17:18:41 +0000
commit26c6a60f1ada1015e5f6d98c8c83a1a2293e1821 (patch)
tree8c227c410d71f7143b34993b581bc6a1a0d7cff0 /packages/linux/linux-efika_2.6.16.bb
parent1cb64c0872e717867a52ebea90f943ee43990252 (diff)
efika.conf, linux-efika: add files to get rudimentary support for the efika machine into OE.
* see http://www.pegasosppc.com/efika.php for more details
Diffstat (limited to 'packages/linux/linux-efika_2.6.16.bb')
-rw-r--r--packages/linux/linux-efika_2.6.16.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/linux/linux-efika_2.6.16.bb b/packages/linux/linux-efika_2.6.16.bb
new file mode 100644
index 0000000000..93a8863aba
--- /dev/null
+++ b/packages/linux/linux-efika_2.6.16.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Linux Kernel for the EFIKA dev platform"
+SECTION = "kernel"
+MAINTAINER = "Koen Kooi <koen@dominion.kabel.utwente.nl>"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.16.tar.bz2 \
+ file://defconfig \
+ "
+
+S = "${WORKDIR}/linux-2.6.16"
+
+inherit kernel
+
+KERNEL_IMAGETYPE = "zImage"
+
+do_configure() {
+ install -m 644 ${WORKDIR}/defconfig ${S}/.config
+ make ARCH=arm oldconfig
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_build after do_compile
+
+