summaryrefslogtreecommitdiff
path: root/packages/linux/linux-dht-walnut_2.6.23.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-12-26 13:11:50 +0000
committerKoen Kooi <koen@openembedded.org>2007-12-26 13:11:50 +0000
commitadb460b4c626a087140a870ae856a3ef11bc1b8e (patch)
treea3837ecc19ad7e3a3a6aa24aa7cf1159e59b2bbf /packages/linux/linux-dht-walnut_2.6.23.bb
parent219d38d250cddc81204428656918bd09ad3d9cfe (diff)
linux-dht-walnut: add 2.6.23
* disabled because uImage is 3.3MB larger as .20 and uboot doesn't boot it due to that size
Diffstat (limited to 'packages/linux/linux-dht-walnut_2.6.23.bb')
-rw-r--r--packages/linux/linux-dht-walnut_2.6.23.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/packages/linux/linux-dht-walnut_2.6.23.bb b/packages/linux/linux-dht-walnut_2.6.23.bb
new file mode 100644
index 0000000000..181488190e
--- /dev/null
+++ b/packages/linux/linux-dht-walnut_2.6.23.bb
@@ -0,0 +1,56 @@
+# Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+require linux.inc
+
+DESCRIPTION = "Linux kernel for DHT-Walnut (ppc) machine"
+
+DEFAULT_PREFERENCE = "-1"
+
+PR = "r0"
+DEPENDS = "u-boot"
+
+COMPATIBLE_MACHINE = "dht-walnut"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ file://defconfig"
+
+S = "${WORKDIR}/linux-${PV}"
+
+FILES_kernel-image = "/boot/zImage.elf"
+
+export OS = "Linux"
+ARCH = "ppc"
+
+do_stage_append () {
+#need ppc platforms includes + friends in order for external kernel modules to compile as headers as still split
+
+ install -d ${STAGING_KERNEL_DIR}/arch/
+ cp -pPR arch/ppc ${STAGING_KERNEL_DIR}/arch/
+ cp -pPR arch/powerpc ${STAGING_KERNEL_DIR}/arch/
+
+ cp -pPR include/asm-powerpc ${STAGING_KERNEL_DIR}/include/
+ cp -pPR include/asm-ppc ${STAGING_KERNEL_DIR}/include/
+}
+
+do_install_append () {
+ install -d ${DEPLOY_DIR_IMAGE}
+ if [ -e arch/ppc/boot/images/zImage.elf ] ; then
+ cp -a arch/ppc/boot/images/zImage.elf arch/ppc/boot/images/zImage
+ install -m 0755 arch/ppc/boot/images/zImage.elf \
+ ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}.elf
+ fi
+ install -m 0755 vmlinux ${DEPLOY_DIR_IMAGE}/
+}
+
+
+pkg_postinst_kernel () {
+ true
+}
+
+pkg_postrm_kernel () {
+ true
+}
+
+
+
+