summaryrefslogtreecommitdiff
path: root/packages/linux/linux-colinux_2.4.28.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/linux/linux-colinux_2.4.28.bb
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/linux/linux-colinux_2.4.28.bb')
-rw-r--r--packages/linux/linux-colinux_2.4.28.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/linux/linux-colinux_2.4.28.bb b/packages/linux/linux-colinux_2.4.28.bb
index e69de29bb2..1191945540 100644
--- a/packages/linux/linux-colinux_2.4.28.bb
+++ b/packages/linux/linux-colinux_2.4.28.bb
@@ -0,0 +1,27 @@
+SECTION = "kernel"
+DESCRIPTION = "User Mode Linux Kernel"
+LICENSE = "GPL"
+COLV = "0.6.1"
+
+#http://internap.dl.sourceforge.net/sourceforge/colinux/coLinux-0.6.1.tar.gz
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.4/linux-${PV}.tar.bz2 \
+ file://colinux-${COLV}.patch;patch=1 \
+ file://nofpu.patch;patch=1 \
+ file://shortloadbytes.patch;patch=1 \
+ file://gcc-registerparanoia.patch;patch=1 \
+ file://linux-2.4.24-attribute-used.patch;patch=1 \
+ file://gcc340-fixes-v2.4.26-try3.patch;patch=1 \
+ file://defconfig"
+
+S = "${WORKDIR}/linux-${PV}"
+
+inherit kernel
+
+COMPATIBLE_HOST = "i.86.*-linux"
+KERNEL_IMAGETYPE = "vmlinux"
+KERNEL_OUTPUT = "./${KERNEL_IMAGETYPE}"
+
+do_configure() {
+ install -m 0644 ${WORKDIR}/defconfig .config
+ kernel_do_configure
+}